Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/СУММАПРОИЗВ. Формула не охватывает смежные ячейки - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » СУММАПРОИЗВ. Формула не охватывает смежные ячейки (Формулы/Formulas)
СУММАПРОИЗВ. Формула не охватывает смежные ячейки
Nikonka89 Дата: Вторник, 17.11.2020, 18:29 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 37
Репутация: 0 ±
Замечаний: 20% ±

Excel 2019
Добрый вечер.
Подскажите с формулой СУММАПРОИЗВ. Почему-то считает неверно. Где-то допустила ошибку, но не могу понять где.
И выдаёт предупреждение, что формула не охватывает смежные ячейки

пример во вложении
К сообщению приложен файл: 8087553.xlsx(9.9 Kb)
 
Ответить
СообщениеДобрый вечер.
Подскажите с формулой СУММАПРОИЗВ. Почему-то считает неверно. Где-то допустила ошибку, но не могу понять где.
И выдаёт предупреждение, что формула не охватывает смежные ячейки

пример во вложении

Автор - Nikonka89
Дата добавления - 17.11.2020 в 18:29
-vp- Дата: Вторник, 17.11.2020, 18:41 | Сообщение № 2
Группа: Пользователи
Ранг: Участник
Сообщений: 57
Репутация: 10 ±
Замечаний: 0% ±

Excel 2019
Здравствуйте,
точку с запятой замените на знак умножения перед суммированым диапазоном:
Код
=СУММПРОИЗВ((СЖПРОБЕЛЫ(ПРАВБ(ПОДСТАВИТЬ($A2;" ";ПОВТОР(" ";99));99))=Лист2!C3:C9)*Лист2!D3:D9)
 
Ответить
СообщениеЗдравствуйте,
точку с запятой замените на знак умножения перед суммированым диапазоном:
Код
=СУММПРОИЗВ((СЖПРОБЕЛЫ(ПРАВБ(ПОДСТАВИТЬ($A2;" ";ПОВТОР(" ";99));99))=Лист2!C3:C9)*Лист2!D3:D9)

Автор - -vp-
Дата добавления - 17.11.2020 в 18:41
Pelena Дата: Вторник, 17.11.2020, 18:52 | Сообщение № 3
Группа: Админы
Ранг: Местный житель
Сообщений: 16766
Репутация: 3619 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Или немного по-другому
Код
=СУММЕСЛИ(Лист2!$C$3:$C$13;ПСТР(A2;ПОИСК(" ";A2)+1;99);Лист2!$D$3:$D$13)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеИли немного по-другому
Код
=СУММЕСЛИ(Лист2!$C$3:$C$13;ПСТР(A2;ПОИСК(" ";A2)+1;99);Лист2!$D$3:$D$13)

Автор - Pelena
Дата добавления - 17.11.2020 в 18:52
bmv98rus Дата: Вторник, 17.11.2020, 21:13 | Сообщение № 4
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3245
Репутация: 558 ±
Замечаний: 0% ±

Excel 2013/2016
Или почти по другому
Код
=SUMPRODUCT(Лист2!D3:D13*(Лист2!C3:C13=RIGHT(A2;LEN(Лист2!C3:C13))))


Замечательный Временно просто медведь , процентов на 20.
 
Ответить
СообщениеИли почти по другому
Код
=SUMPRODUCT(Лист2!D3:D13*(Лист2!C3:C13=RIGHT(A2;LEN(Лист2!C3:C13))))

Автор - bmv98rus
Дата добавления - 17.11.2020 в 21:13
Мир MS Excel » Вопросы и решения » Вопросы по Excel » СУММАПРОИЗВ. Формула не охватывает смежные ячейки (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

jooble Яндекс цитирования
© 2010-2020 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!