Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Формула подсчета уникальных значений с несколькими условиями - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Формула подсчета уникальных значений с несколькими условиями (Формулы/Formulas)
Формула подсчета уникальных значений с несколькими условиями
skyfors Дата: Четверг, 19.11.2020, 18:04 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 15
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Здравствуйте, прошу помочь составить формулу.
Нужно рассчитать сколько было уникальных значений в определенный период.
Например: сколько было за ноябрь продано телефонов Asus, но уникальных моделей. То есть, если за 10.11.2020 продано Asus ZenFone 4 Pro - 3 штуки, формула должна посчитать это как за 1 единицу, если за 12.11.2020 продан Asus PadFone S - это 1 единица, но за 12.11.2020 продано ещё 2 штуки Asus ZenFone 3 Laser - за одно число одна и та же модель считается как за 1 единицу. Итого формула в примере должна насчитать 3 единицы уникальных значений.
К сообщению приложен файл: primer.xls(27.0 Kb)
 
Ответить
СообщениеЗдравствуйте, прошу помочь составить формулу.
Нужно рассчитать сколько было уникальных значений в определенный период.
Например: сколько было за ноябрь продано телефонов Asus, но уникальных моделей. То есть, если за 10.11.2020 продано Asus ZenFone 4 Pro - 3 штуки, формула должна посчитать это как за 1 единицу, если за 12.11.2020 продан Asus PadFone S - это 1 единица, но за 12.11.2020 продано ещё 2 штуки Asus ZenFone 3 Laser - за одно число одна и та же модель считается как за 1 единицу. Итого формула в примере должна насчитать 3 единицы уникальных значений.

Автор - skyfors
Дата добавления - 19.11.2020 в 18:04
bigor Дата: Четверг, 19.11.2020, 20:34 | Сообщение № 2
Группа: Проверенные
Ранг: Обитатель
Сообщений: 334
Репутация: 63 ±
Замечаний: 0% ±

Excel 2016
Добрый вечер.

Проверяйте
Код
=СУММ(ЕСЛИ(СЧЁТЕСЛИМН(D2:D11;D2:D11;C2:C11;"Asus");1/(СЧЁТЕСЛИМН(D2:D11;D2:D11;C2:C11;"Asus"));0))

формула массивная


Сообщение отредактировал bigor - Четверг, 19.11.2020, 21:21
 
Ответить
СообщениеДобрый вечер.

Проверяйте
Код
=СУММ(ЕСЛИ(СЧЁТЕСЛИМН(D2:D11;D2:D11;C2:C11;"Asus");1/(СЧЁТЕСЛИМН(D2:D11;D2:D11;C2:C11;"Asus"));0))

формула массивная

Автор - bigor
Дата добавления - 19.11.2020 в 20:34
skyfors Дата: Четверг, 19.11.2020, 23:54 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 15
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
bigor, а как выставить ещё условие, чтобы формула учитывала период? Вроде вставляю во все места ЕСЛИ(B2:B11>=--"01.11.2020";ЕСЛИ(B2:B11<=--"30.11.2020"), но ничего не получается.


Сообщение отредактировал skyfors - Пятница, 20.11.2020, 07:01
 
Ответить
Сообщениеbigor, а как выставить ещё условие, чтобы формула учитывала период? Вроде вставляю во все места ЕСЛИ(B2:B11>=--"01.11.2020";ЕСЛИ(B2:B11<=--"30.11.2020"), но ничего не получается.

Автор - skyfors
Дата добавления - 19.11.2020 в 23:54
Pelena Дата: Пятница, 20.11.2020, 08:09 | Сообщение № 4
Группа: Админы
Ранг: Местный житель
Сообщений: 16779
Репутация: 3621 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Код
=СУММ(ЕСЛИ(СЧЁТЕСЛИМН(D2:D11;D2:D11;C2:C11;"Asus";B2:B11;">=01.11.2020";B2:B11;"<=30.11.2020");1/(СЧЁТЕСЛИМН(D2:D11;D2:D11;C2:C11;"Asus";B2:B11;">=01.11.2020";B2:B11;"<=30.11.2020"));0))


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
Сообщение
Код
=СУММ(ЕСЛИ(СЧЁТЕСЛИМН(D2:D11;D2:D11;C2:C11;"Asus";B2:B11;">=01.11.2020";B2:B11;"<=30.11.2020");1/(СЧЁТЕСЛИМН(D2:D11;D2:D11;C2:C11;"Asus";B2:B11;">=01.11.2020";B2:B11;"<=30.11.2020"));0))

Автор - Pelena
Дата добавления - 20.11.2020 в 08:09
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Формула подсчета уникальных значений с несколькими условиями (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

jooble Яндекс цитирования
© 2010-2020 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!