Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Некорректная работа списка с множеством значений с точками - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Некорректная работа списка с множеством значений с точками (Настройки Excel/Setup)
Некорректная работа списка с множеством значений с точками
Riff Дата: Пятница, 20.11.2020, 05:50 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 8
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
Добрый день! Смысл задачи прост: при выборе определенного пункта из списка - рядом должны проставиться значения соответствующие этому пункту (желто-зеленая зона в файле примера). И по сути все работает до значения 1.2.20. А ниже, как я понял, excel берет позиции из пункта 1.2.2. и формула перестает работать. Думаю что ексель понимает 1.2.20. и 1.2.2. как одно и то же значение. Но я пробовал подставить даже букву О вместо 0 и тоже результата это не дало. В чем может быть проблема?
К сообщению приложен файл: 7378532.xlsx(21.1 Kb)
 
Ответить
СообщениеДобрый день! Смысл задачи прост: при выборе определенного пункта из списка - рядом должны проставиться значения соответствующие этому пункту (желто-зеленая зона в файле примера). И по сути все работает до значения 1.2.20. А ниже, как я понял, excel берет позиции из пункта 1.2.2. и формула перестает работать. Думаю что ексель понимает 1.2.20. и 1.2.2. как одно и то же значение. Но я пробовал подставить даже букву О вместо 0 и тоже результата это не дало. В чем может быть проблема?

Автор - Riff
Дата добавления - 20.11.2020 в 05:50
and_evg Дата: Пятница, 20.11.2020, 06:49 | Сообщение № 2
Группа: Проверенные
Ранг: Обитатель
Сообщений: 356
Репутация: 61 ±
Замечаний: 0% ±

Excel 2007
Добрый день.
Укажите тип сопоставления "0"
Код
=ИНДЕКС($A$1:$G$70;ПОИСКПОЗ($I$3;A1:A70;0);2)
 
Ответить
СообщениеДобрый день.
Укажите тип сопоставления "0"
Код
=ИНДЕКС($A$1:$G$70;ПОИСКПОЗ($I$3;A1:A70;0);2)

Автор - and_evg
Дата добавления - 20.11.2020 в 06:49
Riff Дата: Пятница, 20.11.2020, 06:53 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 8
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
and_evg, большущее спасибо! Всё проще чем думал
 
Ответить
Сообщениеand_evg, большущее спасибо! Всё проще чем думал

Автор - Riff
Дата добавления - 20.11.2020 в 06:53
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Некорректная работа списка с множеством значений с точками (Настройки Excel/Setup)
  • Страница 1 из 1
  • 1
Поиск:

jooble Яндекс цитирования
© 2010-2020 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!