Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Сравнение значения и установка знака > или < - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сравнение значения и установка знака > или < (Формулы/Formulas)
Сравнение значения и установка знака > или <
lebensvoll Дата: Пятница, 20.11.2020, 20:17 | Сообщение № 1
Группа: Проверенные
Ранг: Ветеран
Сообщений: 910
Репутация: 26 ±
Замечаний: 0% ±

Excel 2010
Добрый вечер форумчане!!!
Давно не обращался к вам (возможно в очередной раз туплю) но не могу понять что я делаю не так!?
В файле имеется таблица данных вопрос и загвоздка именно в 14 графе таблицы
Цитата
Прошу не обращать внимание на ошибки кода вылетающие просто резал все лишнее из протокола чтоб мог загрузить файл на форум

Суть в чем
При испытании образцов кубов бетона мы получаем данные по прочности класс бетона В37 "Вф"
Проверяли мы класс бетона В25 "Внорм"
в 14 графе должно происходить сравнение двух этих классов Вф ≥ Внорм и по сути должен быть знак "≥" но блин ставится знак "≤"
И даже если я начинаю менять класс бетона Внорм в ячейке S19 с В25 на В40 то знак не меняется

В чем моя ошибка!?
Сама формула
Код
=ЕСЛИ(ЗНАЧЕН(P26)>27;(ЕСЛИ(ОКРУГЛ(O31*0,8;)>ВПР(S19;Класс!$A$5:$C$18;3;ИСТИНА);"B"&ОКРУГЛ(O31*0,8;)&" ≥ B"&ВПР(S19;Класс!$A$5:$C$18;3;ИСТИНА);"В"&ОКРУГЛ(O31*0,8;)&" ≤ В"&ВПР(S19;Класс!$A$5:$C$18;3;ИСТИНА)));("B"&ОКРУГЛ(O31*0,8;)))
К сообщению приложен файл: 4234142.xlsm(72.7 Kb)


Кто бы ты ни был, мир в твоих руках

Сообщение отредактировал lebensvoll - Пятница, 20.11.2020, 20:18
 
Ответить
СообщениеДобрый вечер форумчане!!!
Давно не обращался к вам (возможно в очередной раз туплю) но не могу понять что я делаю не так!?
В файле имеется таблица данных вопрос и загвоздка именно в 14 графе таблицы
Цитата
Прошу не обращать внимание на ошибки кода вылетающие просто резал все лишнее из протокола чтоб мог загрузить файл на форум

Суть в чем
При испытании образцов кубов бетона мы получаем данные по прочности класс бетона В37 "Вф"
Проверяли мы класс бетона В25 "Внорм"
в 14 графе должно происходить сравнение двух этих классов Вф ≥ Внорм и по сути должен быть знак "≥" но блин ставится знак "≤"
И даже если я начинаю менять класс бетона Внорм в ячейке S19 с В25 на В40 то знак не меняется

В чем моя ошибка!?
Сама формула
Код
=ЕСЛИ(ЗНАЧЕН(P26)>27;(ЕСЛИ(ОКРУГЛ(O31*0,8;)>ВПР(S19;Класс!$A$5:$C$18;3;ИСТИНА);"B"&ОКРУГЛ(O31*0,8;)&" ≥ B"&ВПР(S19;Класс!$A$5:$C$18;3;ИСТИНА);"В"&ОКРУГЛ(O31*0,8;)&" ≤ В"&ВПР(S19;Класс!$A$5:$C$18;3;ИСТИНА)));("B"&ОКРУГЛ(O31*0,8;)))

Автор - lebensvoll
Дата добавления - 20.11.2020 в 20:17
bigor Дата: Пятница, 20.11.2020, 20:28 | Сообщение № 2
Группа: Проверенные
Ранг: Обитатель
Сообщений: 337
Репутация: 63 ±
Замечаний: 0% ±

Excel 2016
Вот здесь=ЕСЛИ(ЗНАЧЕН(P26)>27;(ЕСЛИ(ОКРУГЛ(O31*0,8;)>ВПР(S19;Класс!$A$5:$C$18;3;ИСТИНА);"B"&ОКРУГЛ(O31*0,8;)&" ≥ B"&ВПР(S19;Класс!$A$5:$C$18;3;ИСТИНА);"В"&ОКРУГЛ(O31*0,8;)&" ≤ В"&ВПР(S19;Класс!$A$5:$C$18;3;ИСТИНА)));("B"&ОКРУГЛ(O31*0,8;))) красный кусок, ВПР возвращает текст, а текст всегда больше числа. Поэтому правим
Код
=ЕСЛИ(ЗНАЧЕН(P26)>27;(ЕСЛИ(ОКРУГЛ(O31*0,8;)>--ВПР(S19;Класс!$A$5:$C$18;3;ИСТИНА);"B"&ОКРУГЛ(O31*0,8;)&" ≥ B"&ВПР(S19;Класс!$A$5:$C$18;3;ИСТИНА);"В"&ОКРУГЛ(O31*0,8;)&" ≤ В"&ВПР(S19;Класс!$A$5:$C$18;3;ИСТИНА)));("B"&ОКРУГЛ(O31*0,8;)))
и пробуем


Сообщение отредактировал bigor - Пятница, 20.11.2020, 20:30
 
Ответить
СообщениеВот здесь=ЕСЛИ(ЗНАЧЕН(P26)>27;(ЕСЛИ(ОКРУГЛ(O31*0,8;)>ВПР(S19;Класс!$A$5:$C$18;3;ИСТИНА);"B"&ОКРУГЛ(O31*0,8;)&" ≥ B"&ВПР(S19;Класс!$A$5:$C$18;3;ИСТИНА);"В"&ОКРУГЛ(O31*0,8;)&" ≤ В"&ВПР(S19;Класс!$A$5:$C$18;3;ИСТИНА)));("B"&ОКРУГЛ(O31*0,8;))) красный кусок, ВПР возвращает текст, а текст всегда больше числа. Поэтому правим
Код
=ЕСЛИ(ЗНАЧЕН(P26)>27;(ЕСЛИ(ОКРУГЛ(O31*0,8;)>--ВПР(S19;Класс!$A$5:$C$18;3;ИСТИНА);"B"&ОКРУГЛ(O31*0,8;)&" ≥ B"&ВПР(S19;Класс!$A$5:$C$18;3;ИСТИНА);"В"&ОКРУГЛ(O31*0,8;)&" ≤ В"&ВПР(S19;Класс!$A$5:$C$18;3;ИСТИНА)));("B"&ОКРУГЛ(O31*0,8;)))
и пробуем

Автор - bigor
Дата добавления - 20.11.2020 в 20:28
lebensvoll Дата: Пятница, 20.11.2020, 20:32 | Сообщение № 3
Группа: Проверенные
Ранг: Ветеран
Сообщений: 910
Репутация: 26 ±
Замечаний: 0% ±

Excel 2010
bigor, спасибо за ответ
если честно при проверки формулы через "Вычислить формулу" я думал что это текст %) но ни как не мог сообразить почему это текст ведь там везде значения же (((((
СПАСИБО ВАМ ОГРОМНОЕ


Кто бы ты ни был, мир в твоих руках
 
Ответить
Сообщениеbigor, спасибо за ответ
если честно при проверки формулы через "Вычислить формулу" я думал что это текст %) но ни как не мог сообразить почему это текст ведь там везде значения же (((((
СПАСИБО ВАМ ОГРОМНОЕ

Автор - lebensvoll
Дата добавления - 20.11.2020 в 20:32
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сравнение значения и установка знака > или < (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

jooble Яндекс цитирования
© 2010-2020 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!