Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Последовательность последовательностей - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Последовательность последовательностей (Формулы/Formulas)
Последовательность последовательностей
yn4k_Wert Дата: Четверг, 26.11.2020, 17:54 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
ИМеется простенькая таблица с цифрами-длинами последовательностей (от 2 до 10 значений), значения в которой могут меняться.
Нужно простроить последовательность, состоящую из последовательной записи последовательностей с указанными длинами.
т.е. имеем таблицу: [2,3,6,2,5]
На выходе ожидаем: [1,2,1,2,3,1,2,3,4,5,6,1,2,1,2,3,4,5] каждая цифра - в отдельной ячейке, нет пустых ячеек между элементами последовательности
Звучит мудрено, но задача на самом деле должна быть простой. По сути у нас есть несколько списков разной длины, нужно их объединить и вывести результат в столбец поэлементно. Только вот конкатенирование последовательностей - выполняет поэлементную конкатенацию, а нужно целиком.
Нужно сделать без макросов, но как - теряюсь в догатках. Подозреваю что ответ на поверхности, но нащупать его не могу уже слишком долго.
К сообщению приложен файл: 0345023.xlsx(16.5 Kb)
 
Ответить
СообщениеИМеется простенькая таблица с цифрами-длинами последовательностей (от 2 до 10 значений), значения в которой могут меняться.
Нужно простроить последовательность, состоящую из последовательной записи последовательностей с указанными длинами.
т.е. имеем таблицу: [2,3,6,2,5]
На выходе ожидаем: [1,2,1,2,3,1,2,3,4,5,6,1,2,1,2,3,4,5] каждая цифра - в отдельной ячейке, нет пустых ячеек между элементами последовательности
Звучит мудрено, но задача на самом деле должна быть простой. По сути у нас есть несколько списков разной длины, нужно их объединить и вывести результат в столбец поэлементно. Только вот конкатенирование последовательностей - выполняет поэлементную конкатенацию, а нужно целиком.
Нужно сделать без макросов, но как - теряюсь в догатках. Подозреваю что ответ на поверхности, но нащупать его не могу уже слишком долго.

Автор - yn4k_Wert
Дата добавления - 26.11.2020 в 17:54
Pelena Дата: Четверг, 26.11.2020, 18:58 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 17052
Репутация: 3681 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Вариант
Код
=ЕСЛИ(D2<ИНДЕКС($B$3:$B$11;СЧЁТЕСЛИ($D$2:D2;1));D2+1;ЕСЛИ(ИНДЕКС($B$3:$B$11;СЧЁТЕСЛИ($D$2:D2;1)+1)="";"";1))
К сообщению приложен файл: 7303367.xlsx(16.3 Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеВариант
Код
=ЕСЛИ(D2<ИНДЕКС($B$3:$B$11;СЧЁТЕСЛИ($D$2:D2;1));D2+1;ЕСЛИ(ИНДЕКС($B$3:$B$11;СЧЁТЕСЛИ($D$2:D2;1)+1)="";"";1))

Автор - Pelena
Дата добавления - 26.11.2020 в 18:58
yn4k_Wert Дата: Четверг, 26.11.2020, 19:18 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
Pelena, Ожидал увидеть что-то с функцией ПОСЛЕД() и копал в этом направлении, как вижу - зря!
Большое спасибо за помощь!
 
Ответить
СообщениеPelena, Ожидал увидеть что-то с функцией ПОСЛЕД() и копал в этом направлении, как вижу - зря!
Большое спасибо за помощь!

Автор - yn4k_Wert
Дата добавления - 26.11.2020 в 19:18
Pelena Дата: Четверг, 26.11.2020, 19:44 | Сообщение № 4
Группа: Админы
Ранг: Местный житель
Сообщений: 17052
Репутация: 3681 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
В моём 2016-м офисе нет такой функции, поэтому я по старинке)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеВ моём 2016-м офисе нет такой функции, поэтому я по старинке)

Автор - Pelena
Дата добавления - 26.11.2020 в 19:44
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Последовательность последовательностей (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования Jobsora jooble
© 2010-2021 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!