Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Как извлечь текст в строке после второго пробела? - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Как извлечь текст в строке после второго пробела? (Формулы/Formulas)
Как извлечь текст в строке после второго пробела?
Aviator Дата: Пятница, 27.11.2020, 11:11 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 18
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
Здравствуйте уважаемые форумчане!
Вот такая задачка - есть текстовая строка, требуется в отдельную ячейку извлечь значения этой строки после второго пробела. Количество символов до второго пробела может быть любым.
Примеры строк:
NSR 75 N/P/R/X/Y(NS-1)
CR 80 RG/RH/RJ/RK/RL7RM
YZF-R 125 (Станд.крепл.переднего суппорта)
YZF-R 125 (Радиал.крепл.переднего суппорта/Без ABS)
YZF-R 125 A (Радиал.крепл.переднего суппорта/ABS)
Freeride E-SM (Electric Powered)
Freeride E-SX (Electric Powered)
Freeride E-XC (Electric Powered)

Заранее благодарен!
 
Ответить
СообщениеЗдравствуйте уважаемые форумчане!
Вот такая задачка - есть текстовая строка, требуется в отдельную ячейку извлечь значения этой строки после второго пробела. Количество символов до второго пробела может быть любым.
Примеры строк:
NSR 75 N/P/R/X/Y(NS-1)
CR 80 RG/RH/RJ/RK/RL7RM
YZF-R 125 (Станд.крепл.переднего суппорта)
YZF-R 125 (Радиал.крепл.переднего суппорта/Без ABS)
YZF-R 125 A (Радиал.крепл.переднего суппорта/ABS)
Freeride E-SM (Electric Powered)
Freeride E-SX (Electric Powered)
Freeride E-XC (Electric Powered)

Заранее благодарен!

Автор - Aviator
Дата добавления - 27.11.2020 в 11:11
Nic70y Дата: Пятница, 27.11.2020, 11:27 | Сообщение № 2
Группа: Друзья
Ранг: Экселист
Сообщений: 6850
Репутация: 1572 ±
Замечаний: 0% ±

Excel 2010
Код
=ПСТР(A1;ПОИСК(" ";ПОДСТАВИТЬ(A1;" ";;1))+2;8888)


ЮMoney(Яндекс Деньги) 41001841029809
 
Ответить
Сообщение
Код
=ПСТР(A1;ПОИСК(" ";ПОДСТАВИТЬ(A1;" ";;1))+2;8888)

Автор - Nic70y
Дата добавления - 27.11.2020 в 11:27
китин Дата: Пятница, 27.11.2020, 11:29 | Сообщение № 3
Группа: Модераторы
Ранг: Экселист
Сообщений: 6429
Репутация: 985 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
без файла на коленке
Код
=ПСТР(A1;ПОИСК(" ";A1;ПОИСК(" ";A1)+1);ДЛСТР(A1))

в А1 ваш тест


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщениебез файла на коленке
Код
=ПСТР(A1;ПОИСК(" ";A1;ПОИСК(" ";A1)+1);ДЛСТР(A1))

в А1 ваш тест

Автор - китин
Дата добавления - 27.11.2020 в 11:29
Aviator Дата: Пятница, 27.11.2020, 12:00 | Сообщение № 4
Группа: Пользователи
Ранг: Новичок
Сообщений: 18
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
Огромное спасибо всем откликнувшимся! Все варианты рабочие! Но второй вариант оставляет в строке результата дополнительный пробел вначале строки
 
Ответить
СообщениеОгромное спасибо всем откликнувшимся! Все варианты рабочие! Но второй вариант оставляет в строке результата дополнительный пробел вначале строки

Автор - Aviator
Дата добавления - 27.11.2020 в 12:00
китин Дата: Пятница, 27.11.2020, 12:57 | Сообщение № 5
Группа: Модераторы
Ранг: Экселист
Сообщений: 6429
Репутация: 985 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
дополнительный пробел вначале строки

я же написал: накоенке
Код
=ПСТР(A1;ПОИСК(" ";A1;ПОИСК(" ";A1)+1);ДЛСТР(A1)-1)


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщение
дополнительный пробел вначале строки

я же написал: накоенке
Код
=ПСТР(A1;ПОИСК(" ";A1;ПОИСК(" ";A1)+1);ДЛСТР(A1)-1)

Автор - китин
Дата добавления - 27.11.2020 в 12:57
Gustav Дата: Пятница, 27.11.2020, 13:57 | Сообщение № 6
Группа: Друзья
Ранг: Старожил
Сообщений: 1880
Репутация: 764 ±
Замечаний: 0% ±

начинал с Excel 4.0, видел 2.1
Можно еще использовать очень компактную пользовательскую функцию (UDF):
[vba]
Код
Function ПОСЛЕВТОРОГОПРОБЕЛА(str)
    ПОСЛЕВТОРОГОПРОБЕЛА = Split(str, " ", 3)(2)
End Function
[/vba]
Вызов в ячейке на рабочем листе:
Код
=ПОСЛЕВТОРОГОПРОБЕЛА(A1)

или, если с обработкой ошибок типа #ЗНАЧ!, то:
Код
=ЕСЛИОШИБКА(ПОСЛЕВТОРОГОПРОБЕЛА(A1);"")


Мой tip box - яд 41001663842605
 
Ответить
СообщениеМожно еще использовать очень компактную пользовательскую функцию (UDF):
[vba]
Код
Function ПОСЛЕВТОРОГОПРОБЕЛА(str)
    ПОСЛЕВТОРОГОПРОБЕЛА = Split(str, " ", 3)(2)
End Function
[/vba]
Вызов в ячейке на рабочем листе:
Код
=ПОСЛЕВТОРОГОПРОБЕЛА(A1)

или, если с обработкой ошибок типа #ЗНАЧ!, то:
Код
=ЕСЛИОШИБКА(ПОСЛЕВТОРОГОПРОБЕЛА(A1);"")

Автор - Gustav
Дата добавления - 27.11.2020 в 13:57
bmv98rus Дата: Пятница, 27.11.2020, 16:08 | Сообщение № 7
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3485
Репутация: 615 ±
Замечаний: 0% ±

Excel 2013/2016
Код
=REPLACE(A2;1;FIND(" ";A2;FIND(" ";A2)+1);)


Замечательный Временно просто медведь , процентов на 20.
 
Ответить
Сообщение
Код
=REPLACE(A2;1;FIND(" ";A2;FIND(" ";A2)+1);)

Автор - bmv98rus
Дата добавления - 27.11.2020 в 16:08
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Как извлечь текст в строке после второго пробела? (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования Jobsora jooble
© 2010-2021 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!