Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/из графика в табель буквенные обозначения ОТ и Б - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » из графика в табель буквенные обозначения ОТ и Б (Формулы/Formulas)
из графика в табель буквенные обозначения ОТ и Б
tvyur Дата: Суббота, 28.11.2020, 10:10 | Сообщение № 1
Группа: Пользователи
Ранг: Участник
Сообщений: 70
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Доброе утро. Уважаемые участники форума, помогите откорректировать формулу ЕСЛИ, чтоб из графика в табель выходили буквенные обозначения ОТ (отпуск) и Б (больничный). Формула выдаёт знач почему то. Файл примера прикладываю.
К сообщению приложен файл: __2021.xlsm(201.9 Kb)


tvyur
 
Ответить
СообщениеДоброе утро. Уважаемые участники форума, помогите откорректировать формулу ЕСЛИ, чтоб из графика в табель выходили буквенные обозначения ОТ (отпуск) и Б (больничный). Формула выдаёт знач почему то. Файл примера прикладываю.

Автор - tvyur
Дата добавления - 28.11.2020 в 10:10
Pelena Дата: Суббота, 28.11.2020, 13:18 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 17563
Репутация: 3910 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Здравствуйте.
Скобочку не там закрыли
Код
=ЕСЛИ('ГРАФИК И.Б АПРЕЛЬ 21'!AC22="ОТ";"ОТ";ЕСЛИ(F16=0;"В";"Я"))


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеЗдравствуйте.
Скобочку не там закрыли
Код
=ЕСЛИ('ГРАФИК И.Б АПРЕЛЬ 21'!AC22="ОТ";"ОТ";ЕСЛИ(F16=0;"В";"Я"))

Автор - Pelena
Дата добавления - 28.11.2020 в 13:18
tvyur Дата: Суббота, 28.11.2020, 13:23 | Сообщение № 3
Группа: Пользователи
Ранг: Участник
Сообщений: 70
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Pelena, Спасибо. hands А помогите сделать так, чтоб в табель выходили и Больничные, если ставится Б в графике, у меня никак не выходит. Пожалуйста!!!


tvyur
 
Ответить
СообщениеPelena, Спасибо. hands А помогите сделать так, чтоб в табель выходили и Больничные, если ставится Б в графике, у меня никак не выходит. Пожалуйста!!!

Автор - tvyur
Дата добавления - 28.11.2020 в 13:23
MikeVol Дата: Суббота, 28.11.2020, 18:54 | Сообщение № 4
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 111
Репутация: 14 ±
Замечаний: 0% ±

Excel 2019
tvyur,
Код
=ЕСЛИ('ГРАФИК И.Б АПРЕЛЬ 21'!CQ22="ОТ";"ОТ";ЕСЛИ('ГРАФИК И.Б АПРЕЛЬ 21'!CQ22="Б";"Б";ЕСЛИ(Q16=0;"В";"Я")))
 
Ответить
Сообщениеtvyur,
Код
=ЕСЛИ('ГРАФИК И.Б АПРЕЛЬ 21'!CQ22="ОТ";"ОТ";ЕСЛИ('ГРАФИК И.Б АПРЕЛЬ 21'!CQ22="Б";"Б";ЕСЛИ(Q16=0;"В";"Я")))

Автор - MikeVol
Дата добавления - 28.11.2020 в 18:54
gling Дата: Суббота, 28.11.2020, 19:50 | Сообщение № 5
Группа: Друзья
Ранг: Старожил
Сообщений: 2254
Репутация: 584 ±
Замечаний: 0% ±

2010
Ещё вариант с Б или любой другой буквой, например У = учёба, или БС и т.д.
Код
=ЕСЛИ(ЕТЕКСТ('ГРАФИК И.Б АПРЕЛЬ 21'!AC22);'ГРАФИК И.Б АПРЕЛЬ 21'!AC22;ЕСЛИ(F16=0;"В";"Я"))


ЯД-41001506838083

Сообщение отредактировал gling - Воскресенье, 29.11.2020, 09:50
 
Ответить
СообщениеЕщё вариант с Б или любой другой буквой, например У = учёба, или БС и т.д.
Код
=ЕСЛИ(ЕТЕКСТ('ГРАФИК И.Б АПРЕЛЬ 21'!AC22);'ГРАФИК И.Б АПРЕЛЬ 21'!AC22;ЕСЛИ(F16=0;"В";"Я"))

Автор - gling
Дата добавления - 28.11.2020 в 19:50
tvyur Дата: Воскресенье, 29.11.2020, 08:56 | Сообщение № 6
Группа: Пользователи
Ранг: Участник
Сообщений: 70
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
MikeVol, Спасибо за помощь. только когда протягиваю формулу на всю строку и в графике забиваю Б по всем дням месяца, формула не играет.


tvyur
 
Ответить
СообщениеMikeVol, Спасибо за помощь. только когда протягиваю формулу на всю строку и в графике забиваю Б по всем дням месяца, формула не играет.

Автор - tvyur
Дата добавления - 29.11.2020 в 08:56
tvyur Дата: Воскресенье, 29.11.2020, 08:57 | Сообщение № 7
Группа: Пользователи
Ранг: Участник
Сообщений: 70
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
gling, Спасибо! Формула работает идеально. hands


tvyur
 
Ответить
Сообщениеgling, Спасибо! Формула работает идеально. hands

Автор - tvyur
Дата добавления - 29.11.2020 в 08:57
MikeVol Дата: Воскресенье, 29.11.2020, 13:27 | Сообщение № 8
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 111
Репутация: 14 ±
Замечаний: 0% ±

Excel 2019
tvyur, это потому что в вашем графике есть объединеные ячейки. Вам ещё тогда в вашей теме говорили об этом. Я вам тогда скинул файл переделанный...
 
Ответить
Сообщениеtvyur, это потому что в вашем графике есть объединеные ячейки. Вам ещё тогда в вашей теме говорили об этом. Я вам тогда скинул файл переделанный...

Автор - MikeVol
Дата добавления - 29.11.2020 в 13:27
tvyur Дата: Понедельник, 30.11.2020, 07:49 | Сообщение № 9
Группа: Пользователи
Ранг: Участник
Сообщений: 70
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
MikeVol, поняла, спасибо ещё раз за помощь. Вашим графиком тоже пользуюсь. hands hands hands


tvyur
 
Ответить
СообщениеMikeVol, поняла, спасибо ещё раз за помощь. Вашим графиком тоже пользуюсь. hands hands hands

Автор - tvyur
Дата добавления - 30.11.2020 в 07:49
Мир MS Excel » Вопросы и решения » Вопросы по Excel » из графика в табель буквенные обозначения ОТ и Б (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования Jobsora jooble
© 2010-2021 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!