Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Торт у которого надо посчитать куски с гранями - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Торт у которого надо посчитать куски с гранями (Формулы/Formulas)
Торт у которого надо посчитать куски с гранями
artem1984 Дата: Четверг, 03.12.2020, 23:22 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 2 ±
Замечаний: 0% ±

Excel 2016
Не понимаю как решить эту задачу и реализовать формулу для всего. Помогите пожалуйста. Задание ниже
 
Ответить
СообщениеНе понимаю как решить эту задачу и реализовать формулу для всего. Помогите пожалуйста. Задание ниже

Автор - artem1984
Дата добавления - 03.12.2020 в 23:22
Serge_007 Дата: Четверг, 03.12.2020, 23:24 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 13925
Репутация: 2318 ±
Замечаний: ±

Excel 2010


Яндекс-деньги:41001419691823 | WMR:126292472390
 
Ответить
СообщениеЕсли Вы студент...

Автор - Serge_007
Дата добавления - 03.12.2020 в 23:24
artem1984 Дата: Четверг, 03.12.2020, 23:43 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 2 ±
Замечаний: 0% ±

Excel 2016
И для чего мне это?


Сообщение отредактировал artem1984 - Четверг, 03.12.2020, 23:44
 
Ответить
СообщениеИ для чего мне это?

Автор - artem1984
Дата добавления - 03.12.2020 в 23:43
bmv98rus Дата: Пятница, 04.12.2020, 08:05 | Сообщение № 4
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3476
Репутация: 613 ±
Замечаний: 0% ±

Excel 2013/2016
И для чего мне это?
для того чтоб включать голову. Форум - не бесплатная авторешалка. Помогают тут в конкретных затруднениях и помогают, а не делают за другого.
Массивная

Код
=SUM(--((ROW($A$1:INDEX(A:A;$A$1))=1)+(ROW($A$1:INDEX(A:A;$A$1))=$A$1)+TRANSPOSE((ROW($A$1:INDEX(A:A;$B$1))=1)+(ROW($A$1:INDEX(A:A;$B$1))=$B$1))=A3))


Главное чтоб проверяющий сильно не удивился.


Замечательный Временно просто медведь , процентов на 20.

Сообщение отредактировал bmv98rus - Пятница, 04.12.2020, 08:57
 
Ответить
Сообщение
И для чего мне это?
для того чтоб включать голову. Форум - не бесплатная авторешалка. Помогают тут в конкретных затруднениях и помогают, а не делают за другого.
Массивная

Код
=SUM(--((ROW($A$1:INDEX(A:A;$A$1))=1)+(ROW($A$1:INDEX(A:A;$A$1))=$A$1)+TRANSPOSE((ROW($A$1:INDEX(A:A;$B$1))=1)+(ROW($A$1:INDEX(A:A;$B$1))=$B$1))=A3))


Главное чтоб проверяющий сильно не удивился.

Автор - bmv98rus
Дата добавления - 04.12.2020 в 08:05
Светлый Дата: Пятница, 04.12.2020, 10:39 | Сообщение № 5
Группа: Друзья
Ранг: Старожил
Сообщений: 1591
Репутация: 416 ±
Замечаний: 0% ±

Excel 2010, 2013
От 0 до 4
Код
=(A1-2)*(B1-2)*(A1>2)*(B1>2)
Код
=(A1+B1-4)*2*(B1>1)*(A1>1)
Код
=A1*B1-B3-B4-B6-B7
Код
=((A1=1)+(B1=1)=1)*2
Код
=Ч(A1*B1=1)


Программировать проще, чем писать стихи.
 
Ответить
СообщениеОт 0 до 4
Код
=(A1-2)*(B1-2)*(A1>2)*(B1>2)
Код
=(A1+B1-4)*2*(B1>1)*(A1>1)
Код
=A1*B1-B3-B4-B6-B7
Код
=((A1=1)+(B1=1)=1)*2
Код
=Ч(A1*B1=1)

Автор - Светлый
Дата добавления - 04.12.2020 в 10:39
bmv98rus Дата: Пятница, 04.12.2020, 11:40 | Сообщение № 6
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3476
Репутация: 613 ±
Замечаний: 0% ±

Excel 2013/2016
0-
Код
=MAX(0;B1-2)*MAX(0;(A1-2))

1-
Код
=2*(MAX(0;B1-2)+MAX(0;A1-2))


Светлый, я с этого начал, но потом подумал что не прикольно :-)


Замечательный Временно просто медведь , процентов на 20.
 
Ответить
Сообщение0-
Код
=MAX(0;B1-2)*MAX(0;(A1-2))

1-
Код
=2*(MAX(0;B1-2)+MAX(0;A1-2))


Светлый, я с этого начал, но потом подумал что не прикольно :-)

Автор - bmv98rus
Дата добавления - 04.12.2020 в 11:40
Светлый Дата: Пятница, 04.12.2020, 18:56 | Сообщение № 7
Группа: Друзья
Ранг: Старожил
Сообщений: 1591
Репутация: 416 ±
Замечаний: 0% ±

Excel 2010, 2013
bmv98rus, а я по твоему варианту массивную формулу состряпал:
Код
=СУММ(Ч((A$1=1)+(ОСТАТ(СТРОКА(ДВССЫЛ("1:"&A$1));A$1)<2)+ТРАНСП((B$1=1)+(ОСТАТ(СТРОКА(ДВССЫЛ("1:"&B$1));B$1)<2))=A3))


Программировать проще, чем писать стихи.
 
Ответить
Сообщениеbmv98rus, а я по твоему варианту массивную формулу состряпал:
Код
=СУММ(Ч((A$1=1)+(ОСТАТ(СТРОКА(ДВССЫЛ("1:"&A$1));A$1)<2)+ТРАНСП((B$1=1)+(ОСТАТ(СТРОКА(ДВССЫЛ("1:"&B$1));B$1)<2))=A3))

Автор - Светлый
Дата добавления - 04.12.2020 в 18:56
bmv98rus Дата: Пятница, 04.12.2020, 20:14 | Сообщение № 8
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3476
Репутация: 613 ±
Замечаний: 0% ±

Excel 2013/2016
Светлый,
согласен, не летучий вариант
Код
=SUM(N((A$1=1)+(MOD(ROW($A$1:INDEX(A:A;$A$1));A$1)<2)+TRANSPOSE((B$1=1)+(MOD(ROW($A$1:INDEX(A:A;$B$1));B$1)<2))=A3))


Замечательный Временно просто медведь , процентов на 20.

Сообщение отредактировал bmv98rus - Пятница, 04.12.2020, 20:15
 
Ответить
СообщениеСветлый,
согласен, не летучий вариант
Код
=SUM(N((A$1=1)+(MOD(ROW($A$1:INDEX(A:A;$A$1));A$1)<2)+TRANSPOSE((B$1=1)+(MOD(ROW($A$1:INDEX(A:A;$B$1));B$1)<2))=A3))

Автор - bmv98rus
Дата добавления - 04.12.2020 в 20:14
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Торт у которого надо посчитать куски с гранями (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования Jobsora jooble
© 2010-2021 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!