Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/функция ЕСЛИ с несколькими условиями - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » функция ЕСЛИ с несколькими условиями (Формулы/Formulas)
функция ЕСЛИ с несколькими условиями
lebensvoll Дата: Вторник, 08.12.2020, 17:12 | Сообщение № 1
Группа: Проверенные
Ранг: Ветеран
Сообщений: 945
Репутация: 27 ±
Замечаний: 0% ±

Excel 2010
Добрый день!!!
Чет не могу ни как совладать и сообразить как сделать
1. Имеется значение (28)-(7)
2. Имеется выпадающий список (бетон; Раствор)
Условие
Нужно учесть
Код
ЕСЛИ(И(ЗНАЧЕН(C1)>27
а дальше еще
Если бетон
Код
=ЕСЛИ(ЗНАЧЕН(P26)>27;"Контроль прочности Вф ≥ Внорм";"Фактический класс бетона Вф")

Если раствор
Код
=ЕСЛИ(ЗНАЧЕН(P26)>27;"Контроль прочности Мф ≥ Мнорм";"Фактическая марка раствора Мф")

Решил пойти таким образом
Код
=ЕСЛИ(И(ЗНАЧЕН(C1)>27;A1="Бетон");"Контроль прочности Вф ≥ Внорм";ЕСЛИ(И(ЗНАЧЕН(C1)>27;A1="Раствор");"Контроль прочности Мф ≥ Мнорм";"Фактический класс бетона Вф"))

Но!!!
Если же значение установить 7 и выбрать раствор то должно быть Фактическая марка раствора Мф а по сути пишет Фактический класс бетона Вф
Понимаю что нужно добавить еще условие но не могу сообразить куда и как
К сообщению приложен файл: 1765558.xlsx(9.5 Kb)


Кто бы ты ни был, мир в твоих руках
 
Ответить
СообщениеДобрый день!!!
Чет не могу ни как совладать и сообразить как сделать
1. Имеется значение (28)-(7)
2. Имеется выпадающий список (бетон; Раствор)
Условие
Нужно учесть
Код
ЕСЛИ(И(ЗНАЧЕН(C1)>27
а дальше еще
Если бетон
Код
=ЕСЛИ(ЗНАЧЕН(P26)>27;"Контроль прочности Вф ≥ Внорм";"Фактический класс бетона Вф")

Если раствор
Код
=ЕСЛИ(ЗНАЧЕН(P26)>27;"Контроль прочности Мф ≥ Мнорм";"Фактическая марка раствора Мф")

Решил пойти таким образом
Код
=ЕСЛИ(И(ЗНАЧЕН(C1)>27;A1="Бетон");"Контроль прочности Вф ≥ Внорм";ЕСЛИ(И(ЗНАЧЕН(C1)>27;A1="Раствор");"Контроль прочности Мф ≥ Мнорм";"Фактический класс бетона Вф"))

Но!!!
Если же значение установить 7 и выбрать раствор то должно быть Фактическая марка раствора Мф а по сути пишет Фактический класс бетона Вф
Понимаю что нужно добавить еще условие но не могу сообразить куда и как

Автор - lebensvoll
Дата добавления - 08.12.2020 в 17:12
Kostya_Ye Дата: Вторник, 08.12.2020, 17:30 | Сообщение № 2
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 218
Репутация: 95 ±
Замечаний: 0% ±

Excel 2016
lebensvoll,
А укажите в примере возможные сочетания исходных значений в 1. и 2. и что хотите получить в результате для каждого сочетания.
 
Ответить
Сообщениеlebensvoll,
А укажите в примере возможные сочетания исходных значений в 1. и 2. и что хотите получить в результате для каждого сочетания.

Автор - Kostya_Ye
Дата добавления - 08.12.2020 в 17:30
lebensvoll Дата: Вторник, 08.12.2020, 17:36 | Сообщение № 3
Группа: Проверенные
Ранг: Ветеран
Сообщений: 945
Репутация: 27 ±
Замечаний: 0% ±

Excel 2010
Kostya_Ye, спасибо за ответ.
вот смотрите к примеру

Значение 7 и выбран бетон
то "Фактический класс бетона Вф"
Значение 7 и выбран раствор
то "Фактическая марка раствора Мф"

Значение 28 и выбран бетон
то "Контроль прочности Вф ≥ Внорм"
Значение 28 и выбран раствор
то "Контроль прочности Мф ≥ Мнорм"


Кто бы ты ни был, мир в твоих руках

Сообщение отредактировал lebensvoll - Вторник, 08.12.2020, 17:40
 
Ответить
СообщениеKostya_Ye, спасибо за ответ.
вот смотрите к примеру

Значение 7 и выбран бетон
то "Фактический класс бетона Вф"
Значение 7 и выбран раствор
то "Фактическая марка раствора Мф"

Значение 28 и выбран бетон
то "Контроль прочности Вф ≥ Внорм"
Значение 28 и выбран раствор
то "Контроль прочности Мф ≥ Мнорм"

Автор - lebensvoll
Дата добавления - 08.12.2020 в 17:36
Kostya_Ye Дата: Вторник, 08.12.2020, 17:42 | Сообщение № 4
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 218
Репутация: 95 ±
Замечаний: 0% ±

Excel 2016
lebensvoll,
а внутри диапазона 7-28 какие возможны варианты ?


Сообщение отредактировал Kostya_Ye - Вторник, 08.12.2020, 17:43
 
Ответить
Сообщениеlebensvoll,
а внутри диапазона 7-28 какие возможны варианты ?

Автор - Kostya_Ye
Дата добавления - 08.12.2020 в 17:42
lebensvoll Дата: Вторник, 08.12.2020, 17:45 | Сообщение № 5
Группа: Проверенные
Ранг: Ветеран
Сообщений: 945
Репутация: 27 ±
Замечаний: 0% ±

Excel 2010
Kostya_Ye, да по сути может любая цифра стоять от 1 до 1000


Кто бы ты ни был, мир в твоих руках
 
Ответить
СообщениеKostya_Ye, да по сути может любая цифра стоять от 1 до 1000

Автор - lebensvoll
Дата добавления - 08.12.2020 в 17:45
Kostya_Ye Дата: Вторник, 08.12.2020, 17:55 | Сообщение № 6
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 218
Репутация: 95 ±
Замечаний: 0% ±

Excel 2016
lebensvoll,
проверяйте, возможно угадал что вам нужно
Код
=ЕСЛИ( C1>27; "Контроль прочности" & ЕСЛИ(A1="раствор"; " Мф ≥ М";  " Вф ≥ В" ) & "норм"; "Фактическ" & ЕСЛИ(A1="раствор"; "ая марка раствора М";  "ий класс бетона В" ) & "ф")
 
Ответить
Сообщениеlebensvoll,
проверяйте, возможно угадал что вам нужно
Код
=ЕСЛИ( C1>27; "Контроль прочности" & ЕСЛИ(A1="раствор"; " Мф ≥ М";  " Вф ≥ В" ) & "норм"; "Фактическ" & ЕСЛИ(A1="раствор"; "ая марка раствора М";  "ий класс бетона В" ) & "ф")

Автор - Kostya_Ye
Дата добавления - 08.12.2020 в 17:55
lebensvoll Дата: Вторник, 08.12.2020, 17:58 | Сообщение № 7
Группа: Проверенные
Ранг: Ветеран
Сообщений: 945
Репутация: 27 ±
Замечаний: 0% ±

Excel 2010
Kostya_Ye, ГЕНИАЛЬНЕЙШЕ!!!! hands
Спасибо огромное


Кто бы ты ни был, мир в твоих руках
 
Ответить
СообщениеKostya_Ye, ГЕНИАЛЬНЕЙШЕ!!!! hands
Спасибо огромное

Автор - lebensvoll
Дата добавления - 08.12.2020 в 17:58
Kostya_Ye Дата: Вторник, 08.12.2020, 18:00 | Сообщение № 8
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 218
Репутация: 95 ±
Замечаний: 0% ±

Excel 2016
ГЕНИАЛЬНЕЙШЕ!!!!

ну вот вряд ли, уверен что местные гуру предложили бы куда более изящное решение.
 
Ответить
Сообщение
ГЕНИАЛЬНЕЙШЕ!!!!

ну вот вряд ли, уверен что местные гуру предложили бы куда более изящное решение.

Автор - Kostya_Ye
Дата добавления - 08.12.2020 в 18:00
Мир MS Excel » Вопросы и решения » Вопросы по Excel » функция ЕСЛИ с несколькими условиями (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования Jobsora jooble
© 2010-2021 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!