Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Циклическая ссылка в функции ПРОСМОТР - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Циклическая ссылка в функции ПРОСМОТР (Формулы/Formulas)
Циклическая ссылка в функции ПРОСМОТР
stalber Дата: Воскресенье, 13.12.2020, 05:49 | Сообщение № 1
Группа: Проверенные
Ранг: Обитатель
Сообщений: 303
Репутация: 7 ±
Замечаний: 0% ±

Excel 2007
Здравствуйте, подскажите пожалуйста:

Использую две таких формулы:
1-ая формула
Код
=ПРОСМОТР(999999;Лист1!A1:A100)

2-ая формула
Код
=ПРОСМОТР(999999;Лист1!B1:B100)

Эти формулы должны быть взаимосвязаны. Например, если в формуле 1-ой результат появился 0, то во 2-ой формуле тоже должен быть 0 (уже не важен результат становится) и наоборот.
Другими словами, если хотя бы в одной из двух формул появляется 0, то и в другой формуле должен появляться 0.

Я сделал такие формулы, но они не правильные, так как цикличные, и они сразу заведомо показывают оба нули, это нерабочие формулы:
Эта формула вставляется в ячейку A1
Код
=ЕСЛИ(B1>0;(ПРОСМОТР(999999;Лист1!A1:A100));ЕСЛИ(B1=0;0))

Эта формула вставляется в ячейку B1
Код
=ЕСЛИ(A1>0;(ПРОСМОТР(999999;Лист1!B1:B100));ЕСЛИ(A1=0;0))


Есть какое то решение данной задачи?
 
Ответить
СообщениеЗдравствуйте, подскажите пожалуйста:

Использую две таких формулы:
1-ая формула
Код
=ПРОСМОТР(999999;Лист1!A1:A100)

2-ая формула
Код
=ПРОСМОТР(999999;Лист1!B1:B100)

Эти формулы должны быть взаимосвязаны. Например, если в формуле 1-ой результат появился 0, то во 2-ой формуле тоже должен быть 0 (уже не важен результат становится) и наоборот.
Другими словами, если хотя бы в одной из двух формул появляется 0, то и в другой формуле должен появляться 0.

Я сделал такие формулы, но они не правильные, так как цикличные, и они сразу заведомо показывают оба нули, это нерабочие формулы:
Эта формула вставляется в ячейку A1
Код
=ЕСЛИ(B1>0;(ПРОСМОТР(999999;Лист1!A1:A100));ЕСЛИ(B1=0;0))

Эта формула вставляется в ячейку B1
Код
=ЕСЛИ(A1>0;(ПРОСМОТР(999999;Лист1!B1:B100));ЕСЛИ(A1=0;0))


Есть какое то решение данной задачи?

Автор - stalber
Дата добавления - 13.12.2020 в 05:49
bmv98rus Дата: Воскресенье, 13.12.2020, 08:22 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3414
Репутация: 594 ±
Замечаний: 0% ±

Excel 2013/2016
j Кто вам мешает не ссылаться на соседа, а предваhительно лишний раз воспользjваться функцией соседа в условии?
Код
=IF(LOOKUP(999999,Лист1!B1:B100)<>0,LOOKUP(999999,Лист1!A1:A100),0)


Замечательный Временно просто медведь , процентов на 20.
 
Ответить
Сообщениеj Кто вам мешает не ссылаться на соседа, а предваhительно лишний раз воспользjваться функцией соседа в условии?
Код
=IF(LOOKUP(999999,Лист1!B1:B100)<>0,LOOKUP(999999,Лист1!A1:A100),0)

Автор - bmv98rus
Дата добавления - 13.12.2020 в 08:22
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Циклическая ссылка в функции ПРОСМОТР (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования Jobsora jooble
© 2010-2021 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!