Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Выборка значений за период по критерию - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Выборка значений за период по критерию (Формулы/Formulas)
Выборка значений за период по критерию
Artem2292 Дата: Воскресенье, 20.12.2020, 02:00 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 33
Репутация: 0 ±
Замечаний: 0% ±

2010, 2019, 365
Всем привет! Нужна помощь светлых голов.
Имеется большущая таблица из которой на отдельном листе делаю (по крайней мере пытаюсь) выборку по определенному критерию за определенный период.
итого:
1. у меня удачно получилось сделать выборку массивной формулой за определенный период, например с 01.01.21 по 31.01.21
Код
=ИНДЕКС(Список!$B$1:$B$31;НАИМЕНЬШИЙ(ЕСЛИ((Список!$H:$H>=$A$8)*(Список!$H:$H<=$A$9);СТРОКА(Список!$H$1:$H$31));СТРОКА(Список!B1));1)
отметил зеленым цветом в файле
2. получилось сделать выборку по определенному критерию (в моем случае это "СТО-1") через массив но только за какой-то определенный день
Код
=ЕСЛИОШИБКА(ИНДЕКС(Список!$B$1:$B$31;НАИМЕНЬШИЙ(ЕСЛИ($A$2&"СТО-1"=Список!$H$1:$H$31&Список!$E$1:$E$31;СТРОКА(Список!$H$1:$H$31));СТРОКА(Список!B9));1);"")
отметил оранжевым в файле

но мне нужно, чтобы одновременно была выборка по определенной СТО и за определенный период времени (2 дня, неделя, месяц и тд). Пытаюсь объединить 2 формулы в одну, но толком ничего не выходит.. работает только одна часть..
Код
=ИНДЕКС(Список!$B$1:$B$31;НАИМЕНЬШИЙ(ЕСЛИ((Список!$H:$H>=$A$8)*(Список!$H:$H<=$A$9);ЕСЛИ("СТО-1"=Список!$E:$E;СТРОКА(Список!$H$1:$H$31));СТРОКА(Список!B3));1))
отметил красным в файле

возможно ли как-то сделать так, чтобы в массивной формуле шла выборка по периоду и по определенному другому критерию (у меня это СТО-1) ?
надеюсь объяснил понятно))
К сообщению приложен файл: 2677200.xlsb(18.6 Kb)


Сообщение отредактировал Artem2292 - Воскресенье, 20.12.2020, 02:02
 
Ответить
СообщениеВсем привет! Нужна помощь светлых голов.
Имеется большущая таблица из которой на отдельном листе делаю (по крайней мере пытаюсь) выборку по определенному критерию за определенный период.
итого:
1. у меня удачно получилось сделать выборку массивной формулой за определенный период, например с 01.01.21 по 31.01.21
Код
=ИНДЕКС(Список!$B$1:$B$31;НАИМЕНЬШИЙ(ЕСЛИ((Список!$H:$H>=$A$8)*(Список!$H:$H<=$A$9);СТРОКА(Список!$H$1:$H$31));СТРОКА(Список!B1));1)
отметил зеленым цветом в файле
2. получилось сделать выборку по определенному критерию (в моем случае это "СТО-1") через массив но только за какой-то определенный день
Код
=ЕСЛИОШИБКА(ИНДЕКС(Список!$B$1:$B$31;НАИМЕНЬШИЙ(ЕСЛИ($A$2&"СТО-1"=Список!$H$1:$H$31&Список!$E$1:$E$31;СТРОКА(Список!$H$1:$H$31));СТРОКА(Список!B9));1);"")
отметил оранжевым в файле

но мне нужно, чтобы одновременно была выборка по определенной СТО и за определенный период времени (2 дня, неделя, месяц и тд). Пытаюсь объединить 2 формулы в одну, но толком ничего не выходит.. работает только одна часть..
Код
=ИНДЕКС(Список!$B$1:$B$31;НАИМЕНЬШИЙ(ЕСЛИ((Список!$H:$H>=$A$8)*(Список!$H:$H<=$A$9);ЕСЛИ("СТО-1"=Список!$E:$E;СТРОКА(Список!$H$1:$H$31));СТРОКА(Список!B3));1))
отметил красным в файле

возможно ли как-то сделать так, чтобы в массивной формуле шла выборка по периоду и по определенному другому критерию (у меня это СТО-1) ?
надеюсь объяснил понятно))

Автор - Artem2292
Дата добавления - 20.12.2020 в 02:00
Pelena Дата: Воскресенье, 20.12.2020, 09:44 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 17242
Репутация: 3767 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Здравствуйте.
Просто добавьте ещё одно условие
Код
=ИНДЕКС(Список!$B$1:$B$31;НАИМЕНЬШИЙ(ЕСЛИ((Список!$H:$H>=$A$8)*(Список!$H:$H<=$A$9)*("СТО-1"=Список!$E:$E);СТРОКА(Список!$H$1:$H$31));СТРОКА(Список!B1));1)

вариант немассивной формулы
Код
=ИНДЕКС(Список!$B$1:$B$31;АГРЕГАТ(15;6;СТРОКА(Список!$H$1:$H$31)/(Список!$H:$H>=$A$8)/(Список!$H:$H<=$A$9)/("СТО-1"=Список!$E:$E);СТРОКА(Список!B1)))

советую только не использовать ссылки на целиковые столбцы, сделайте конечный диапазон, можно с запасом


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеЗдравствуйте.
Просто добавьте ещё одно условие
Код
=ИНДЕКС(Список!$B$1:$B$31;НАИМЕНЬШИЙ(ЕСЛИ((Список!$H:$H>=$A$8)*(Список!$H:$H<=$A$9)*("СТО-1"=Список!$E:$E);СТРОКА(Список!$H$1:$H$31));СТРОКА(Список!B1));1)

вариант немассивной формулы
Код
=ИНДЕКС(Список!$B$1:$B$31;АГРЕГАТ(15;6;СТРОКА(Список!$H$1:$H$31)/(Список!$H:$H>=$A$8)/(Список!$H:$H<=$A$9)/("СТО-1"=Список!$E:$E);СТРОКА(Список!B1)))

советую только не использовать ссылки на целиковые столбцы, сделайте конечный диапазон, можно с запасом

Автор - Pelena
Дата добавления - 20.12.2020 в 09:44
Artem2292 Дата: Воскресенье, 20.12.2020, 13:53 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 33
Репутация: 0 ±
Замечаний: 0% ±

2010, 2019, 365
Просто добавьте ещё одно условие


Спасибо Вам!! Все отлично работает. Был близок, но критерий по СТО пытался добавить через очередное ЕСЛИ, а так же пробовал через И, но ничего не выходило... а нужно было просто *() добавить. ЭХ.. учиться и учиться еще))

вариант немассивной формулы

этот вариант в моем файле более быстрый, спасибо!!

советую только не использовать ссылки на целиковые столбцы, сделайте конечный диапазон, можно с запасом

да, в рабочем файле с этим столкнулся. Там большущие таблицы и при указании в формуле целекового столбца, эксель заметно тормозит

Вопрос решен, тему можно закрыть.
 
Ответить
Сообщение
Просто добавьте ещё одно условие


Спасибо Вам!! Все отлично работает. Был близок, но критерий по СТО пытался добавить через очередное ЕСЛИ, а так же пробовал через И, но ничего не выходило... а нужно было просто *() добавить. ЭХ.. учиться и учиться еще))

вариант немассивной формулы

этот вариант в моем файле более быстрый, спасибо!!

советую только не использовать ссылки на целиковые столбцы, сделайте конечный диапазон, можно с запасом

да, в рабочем файле с этим столкнулся. Там большущие таблицы и при указании в формуле целекового столбца, эксель заметно тормозит

Вопрос решен, тему можно закрыть.

Автор - Artem2292
Дата добавления - 20.12.2020 в 13:53
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Выборка значений за период по критерию (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования Jobsora jooble
© 2010-2021 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!