Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Построить график функции по формуле - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Построить график функции по формуле (Формулы/Formulas)
Построить график функции по формуле
Gegginer_01 Дата: Воскресенье, 20.12.2020, 20:28 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 12
Репутация: 0 ±
Замечаний: 0% ±

Скажите, как написать эту формулу, пытался сделать так
Код
=ЕСЛИ(B6<=3,14/2;COS(B6);ЕСЛИ(3,14/2<B6<3,14;"0";ЕСЛИ(B6>3,14;B6-3,14;0)))[
,
Код
=ЕСЛИ(A2<=3,14/2; SIN(A2)); ЕСЛИ(3,14<A2<3*3,14/2; 3,14/2); ЕСЛИ(A2>3*3,14/2; COS(A2))

но это все не высчитывается. Объясните, пожалуйста, что и как-только начал изучать.
К сообщению приложен файл: 0942635.jpg(15.2 Kb)


Сообщение отредактировал Gegginer_01 - Воскресенье, 20.12.2020, 21:11
 
Ответить
СообщениеСкажите, как написать эту формулу, пытался сделать так
Код
=ЕСЛИ(B6<=3,14/2;COS(B6);ЕСЛИ(3,14/2<B6<3,14;"0";ЕСЛИ(B6>3,14;B6-3,14;0)))[
,
Код
=ЕСЛИ(A2<=3,14/2; SIN(A2)); ЕСЛИ(3,14<A2<3*3,14/2; 3,14/2); ЕСЛИ(A2>3*3,14/2; COS(A2))

но это все не высчитывается. Объясните, пожалуйста, что и как-только начал изучать.

Автор - Gegginer_01
Дата добавления - 20.12.2020 в 20:28
Pelena Дата: Воскресенье, 20.12.2020, 21:44 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 17050
Репутация: 3681 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Код
=ЕСЛИ(A2<=ПИ()/2;SIN(A2);ЕСЛИ(A2<3*ПИ()/2;ПИ()/2;COS(A2)))


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
Сообщение
Код
=ЕСЛИ(A2<=ПИ()/2;SIN(A2);ЕСЛИ(A2<3*ПИ()/2;ПИ()/2;COS(A2)))

Автор - Pelena
Дата добавления - 20.12.2020 в 21:44
bmv98rus Дата: Воскресенье, 20.12.2020, 21:54 | Сообщение № 3
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3394
Репутация: 585 ±
Замечаний: 0% ±

Excel 2013/2016
Лен, даже не хочу ссылки на кросс на кибере делать, но там та же пулеметная очередь.


Замечательный Временно просто медведь , процентов на 20.
 
Ответить
СообщениеЛен, даже не хочу ссылки на кросс на кибере делать, но там та же пулеметная очередь.

Автор - bmv98rus
Дата добавления - 20.12.2020 в 21:54
ZetMenChavo Дата: Воскресенье, 20.12.2020, 22:13 | Сообщение № 4
Группа: Пользователи
Ранг: Новичок
Сообщений: 17
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Gegginer_01, Привет, у тебя ошибка вот в этой части
Код
=ЕСЛИ(3,14/2<B6<3,14;;)

Дело в том что Эксель не считает такие неравенства, тоже когда то оступался на этом.
Правильная запись выглядит вот так
Код
=ЕСЛИ(и(3,14/2<B6;B6<3,14);;)

Либо
Код
=ЕСЛИ((3,14/2<B6)*(B6<3,14);;)

Во втором варианте эффект тот же что и с формулой И(). Эксель приравнивает ИСТИНА к 1, а ЛОЖЬ к 0, так что если (3,14/2<B6) и (B6<3,14) верны то будет 1*1.
А написание
Код
=(3,14/2<B6)+(B6<3,14)

Это альтернатива функции ИЛИ()
Код
=ИЛИ(3,14/2<B6;B6<3,14)

В Эксель любое число, кроме нуля, хоть положительное хоть отрицательное, в формулах приравнивается к ИСТИНА, и только ноль к ЛОЖЬ.
Твои формулы
Код
=ЕСЛИ(B6<=3,14/2;COS(B6);ЕСЛИ(3,14/2<B6<3,14;"0";ЕСЛИ(B6>3,14;B6-3,14;0)))[

Код
=ЕСЛИ(A2<=3,14/2; SIN(A2)); ЕСЛИ(3,14<A2<3*3,14/2; 3,14/2); ЕСЛИ(A2>3*3,14/2; COS(A2))

Исправленный вариант
Код
=ЕСЛИ(B6<=3,14/2;COS(B6);ЕСЛИ(И(3,14/2<B6;B6<3,14);0;ЕСЛИ(B6>3,14;B6-3,14;0)))

Код
=ЕСЛИ(A2<=3,14/2;SIN(A2);ЕСЛИ(И(3,14<A2;A2<3*3,14/2);3,14/2;ЕСЛИ(A2>3*3,14/2;COS(A2);)))

Во второй формуле не совсем ясно какие значения у тебя для Истина а какие для Ложь, из-за того что скобки не в тех местах где надо, да и пробелы тоже лишние, так что как понял формулу так и исправил, а дальше уже сам сможешь разобраться.
Приятной тебе работы в Эксель :)


Сообщение отредактировал ZetMenChavo - Воскресенье, 20.12.2020, 23:56
 
Ответить
СообщениеGegginer_01, Привет, у тебя ошибка вот в этой части
Код
=ЕСЛИ(3,14/2<B6<3,14;;)

Дело в том что Эксель не считает такие неравенства, тоже когда то оступался на этом.
Правильная запись выглядит вот так
Код
=ЕСЛИ(и(3,14/2<B6;B6<3,14);;)

Либо
Код
=ЕСЛИ((3,14/2<B6)*(B6<3,14);;)

Во втором варианте эффект тот же что и с формулой И(). Эксель приравнивает ИСТИНА к 1, а ЛОЖЬ к 0, так что если (3,14/2<B6) и (B6<3,14) верны то будет 1*1.
А написание
Код
=(3,14/2<B6)+(B6<3,14)

Это альтернатива функции ИЛИ()
Код
=ИЛИ(3,14/2<B6;B6<3,14)

В Эксель любое число, кроме нуля, хоть положительное хоть отрицательное, в формулах приравнивается к ИСТИНА, и только ноль к ЛОЖЬ.
Твои формулы
Код
=ЕСЛИ(B6<=3,14/2;COS(B6);ЕСЛИ(3,14/2<B6<3,14;"0";ЕСЛИ(B6>3,14;B6-3,14;0)))[

Код
=ЕСЛИ(A2<=3,14/2; SIN(A2)); ЕСЛИ(3,14<A2<3*3,14/2; 3,14/2); ЕСЛИ(A2>3*3,14/2; COS(A2))

Исправленный вариант
Код
=ЕСЛИ(B6<=3,14/2;COS(B6);ЕСЛИ(И(3,14/2<B6;B6<3,14);0;ЕСЛИ(B6>3,14;B6-3,14;0)))

Код
=ЕСЛИ(A2<=3,14/2;SIN(A2);ЕСЛИ(И(3,14<A2;A2<3*3,14/2);3,14/2;ЕСЛИ(A2>3*3,14/2;COS(A2);)))

Во второй формуле не совсем ясно какие значения у тебя для Истина а какие для Ложь, из-за того что скобки не в тех местах где надо, да и пробелы тоже лишние, так что как понял формулу так и исправил, а дальше уже сам сможешь разобраться.
Приятной тебе работы в Эксель :)

Автор - ZetMenChavo
Дата добавления - 20.12.2020 в 22:13
novodom Дата: Понедельник, 21.12.2020, 11:29 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 1
Репутация: 0 ±
Замечаний: 0% ±

действительно, возможности экселя безграничны, даже не знал, что можно так сделать :)
 
Ответить
Сообщениедействительно, возможности экселя безграничны, даже не знал, что можно так сделать :)

Автор - novodom
Дата добавления - 21.12.2020 в 11:29
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Построить график функции по формуле (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования Jobsora jooble
© 2010-2021 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!