Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Количество отрицательных оценок в процентах - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Количество отрицательных оценок в процентах (Формулы/Formulas)
Количество отрицательных оценок в процентах
mariapysnaa441 Дата: Воскресенье, 20.12.2020, 22:18 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Здравствуйте, нужно посчитать количество отрицательных
оценок, %. Когда 0 - отрицательное 1 - положительное значение.
Не понимаю какую формулу написать, помогите пожалуйста.

Файл таблицы прикрепляю ниже. Благодарю!
К сообщению приложен файл: 0148951.xlsx(30.6 Kb)
 
Ответить
СообщениеЗдравствуйте, нужно посчитать количество отрицательных
оценок, %. Когда 0 - отрицательное 1 - положительное значение.
Не понимаю какую формулу написать, помогите пожалуйста.

Файл таблицы прикрепляю ниже. Благодарю!

Автор - mariapysnaa441
Дата добавления - 20.12.2020 в 22:18
Kostya_Ye Дата: Воскресенье, 20.12.2020, 23:09 | Сообщение № 2
Группа: Проверенные
Ранг: Обитатель
Сообщений: 257
Репутация: 226 ±
Замечаний: 0% ±

Excel 2016
mariapysnaa441, Добрый день,
В вашем примере наименования листов не совпадают со значениями в колонке А. Для этого случая формула будет
Код
=СЧЁТЕСЛИ(Рус.яз!A1:A100;"=0")/СЧЁТЗ(Рус.яз!A1:A100)
для каждой строки нужно будет править в формуле имя листа.

Если вы внесете в колонку А значения, которые в точности будут соответствовать названиям листов, с учетом пробелов, которые есть в конце названий листов у вас, тогда формула
Код
=СЧЁТЕСЛИ(ДВССЫЛ("'"&$A4&"'!R2C"&СТОЛБЕЦ()-1&":R100C"&СТОЛБЕЦ()-1;0);"=0")/СЧЁТЗ(ДВССЫЛ("'"&$A4&"'!R2C"&СТОЛБЕЦ()-1&":R100C"&СТОЛБЕЦ()-1;0))
которую можно протягивать по строкам.
Количество строк для расчета в формуле взято с запасом по примеру но в вашем реальном файле возможно нужно будет корректировать
К сообщению приложен файл: 1975884.xlsx(36.2 Kb)


Сообщение отредактировал Kostya_Ye - Воскресенье, 20.12.2020, 23:11
 
Ответить
Сообщениеmariapysnaa441, Добрый день,
В вашем примере наименования листов не совпадают со значениями в колонке А. Для этого случая формула будет
Код
=СЧЁТЕСЛИ(Рус.яз!A1:A100;"=0")/СЧЁТЗ(Рус.яз!A1:A100)
для каждой строки нужно будет править в формуле имя листа.

Если вы внесете в колонку А значения, которые в точности будут соответствовать названиям листов, с учетом пробелов, которые есть в конце названий листов у вас, тогда формула
Код
=СЧЁТЕСЛИ(ДВССЫЛ("'"&$A4&"'!R2C"&СТОЛБЕЦ()-1&":R100C"&СТОЛБЕЦ()-1;0);"=0")/СЧЁТЗ(ДВССЫЛ("'"&$A4&"'!R2C"&СТОЛБЕЦ()-1&":R100C"&СТОЛБЕЦ()-1;0))
которую можно протягивать по строкам.
Количество строк для расчета в формуле взято с запасом по примеру но в вашем реальном файле возможно нужно будет корректировать

Автор - Kostya_Ye
Дата добавления - 20.12.2020 в 23:09
mariapysnaa441 Дата: Воскресенье, 20.12.2020, 23:23 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Kostya_Ye, Спасибо Вам, попробую применить, ваши формулы!
 
Ответить
СообщениеKostya_Ye, Спасибо Вам, попробую применить, ваши формулы!

Автор - mariapysnaa441
Дата добавления - 20.12.2020 в 23:23
bmv98rus Дата: Воскресенье, 20.12.2020, 23:41 | Сообщение № 4
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3475
Репутация: 613 ±
Замечаний: 0% ±

Excel 2013/2016
Kostya_Ye,
=COUNTIF(Рус.яз!A1:A100,"=0")/COUNTA(Рус.яз!A1:A100)

Это подстава? Зачем заголовок учитывать?
ну и
Код
=COUNTIF(Рус.яз!A:A;)/COUNT(Рус.яз!A:A)


Соответственно и вторая аналогично, а вот использовать ли летучий INDIRECT - вопрос.


Замечательный Временно просто медведь , процентов на 20.
 
Ответить
СообщениеKostya_Ye,
=COUNTIF(Рус.яз!A1:A100,"=0")/COUNTA(Рус.яз!A1:A100)

Это подстава? Зачем заголовок учитывать?
ну и
Код
=COUNTIF(Рус.яз!A:A;)/COUNT(Рус.яз!A:A)


Соответственно и вторая аналогично, а вот использовать ли летучий INDIRECT - вопрос.

Автор - bmv98rus
Дата добавления - 20.12.2020 в 23:41
Kostya_Ye Дата: Понедельник, 21.12.2020, 09:26 | Сообщение № 5
Группа: Проверенные
Ранг: Обитатель
Сообщений: 257
Репутация: 226 ±
Замечаний: 0% ±

Excel 2016
bmv98rus, добрый день,
спасибо за замечание, это ошибка. Надо мне быть более внимательным.
 
Ответить
Сообщениеbmv98rus, добрый день,
спасибо за замечание, это ошибка. Надо мне быть более внимательным.

Автор - Kostya_Ye
Дата добавления - 21.12.2020 в 09:26
bmv98rus Дата: Понедельник, 21.12.2020, 12:13 | Сообщение № 6
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3475
Репутация: 613 ±
Замечаний: 0% ±

Excel 2013/2016
[offtop]
Надо мне быть более внимательным
ага, а то успеваемость под угрозой :-)
[/offtop]


Замечательный Временно просто медведь , процентов на 20.
 
Ответить
Сообщение[offtop]
Надо мне быть более внимательным
ага, а то успеваемость под угрозой :-)
[/offtop]

Автор - bmv98rus
Дата добавления - 21.12.2020 в 12:13
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Количество отрицательных оценок в процентах (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования Jobsora jooble
© 2010-2021 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!