Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Подстановка отрицательных данных с другого листа книги - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подстановка отрицательных данных с другого листа книги (Формулы/Formulas)
Подстановка отрицательных данных с другого листа книги
bosika Дата: Вторник, 22.12.2020, 16:08 | Сообщение № 1
Группа: Пользователи
Ранг: Участник
Сообщений: 79
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010, 2013, 2016
Здравствуйте уважаемые ГУРУ.
Как изменить формулу, чтобы выбирались только отрицательные данные из листа СТО?
Файл приложить не могу в виду закрытых данных.

Код
=ЕСЛИ($A5="";"";СУММЕСЛИ(СТО!$A:$A;$A5;СТО!$F:$F))
К сообщению приложен файл: 7897093.xlsx(12.5 Kb)


Начинающий. Много и долго не пинать. Больно однако.

Сообщение отредактировал bosika - Вторник, 22.12.2020, 17:53
 
Ответить
СообщениеЗдравствуйте уважаемые ГУРУ.
Как изменить формулу, чтобы выбирались только отрицательные данные из листа СТО?
Файл приложить не могу в виду закрытых данных.

Код
=ЕСЛИ($A5="";"";СУММЕСЛИ(СТО!$A:$A;$A5;СТО!$F:$F))

Автор - bosika
Дата добавления - 22.12.2020 в 16:08
jakim Дата: Вторник, 22.12.2020, 16:42 | Сообщение № 2
Группа: Друзья
Ранг: Ветеран
Сообщений: 988
Репутация: 268 ±
Замечаний: 0% ±

Excel 2010
А Вы сделайте свой похожий файл с нужным результатом.
 
Ответить
Сообщение
А Вы сделайте свой похожий файл с нужным результатом.

Автор - jakim
Дата добавления - 22.12.2020 в 16:42
bosika Дата: Вторник, 22.12.2020, 17:54 | Сообщение № 3
Группа: Пользователи
Ранг: Участник
Сообщений: 79
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010, 2013, 2016
jakim, Прикрепил к первому сообщению.


Начинающий. Много и долго не пинать. Больно однако.
 
Ответить
Сообщениеjakim, Прикрепил к первому сообщению.

Автор - bosika
Дата добавления - 22.12.2020 в 17:54
bigor Дата: Вторник, 22.12.2020, 21:35 | Сообщение № 4
Группа: Проверенные
Ранг: Обитатель
Сообщений: 399
Репутация: 71 ±
Замечаний: 0% ±

Excel 2016
Так?
Код
=IF($A5="";"<=0";SUMIFS($СТО.$F$4:$F$100;$СТО.$A$4:$A$100;$A5;$СТО.$F$4:$F$100;"<0"))
 
Ответить
СообщениеТак?
Код
=IF($A5="";"<=0";SUMIFS($СТО.$F$4:$F$100;$СТО.$A$4:$A$100;$A5;$СТО.$F$4:$F$100;"<0"))

Автор - bigor
Дата добавления - 22.12.2020 в 21:35
bosika Дата: Среда, 23.12.2020, 14:33 | Сообщение № 5
Группа: Пользователи
Ранг: Участник
Сообщений: 79
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010, 2013, 2016
bigor, Сейчас на рабо е. Вечерком посмотрю.


Начинающий. Много и долго не пинать. Больно однако.
 
Ответить
Сообщениеbigor, Сейчас на рабо е. Вечерком посмотрю.

Автор - bosika
Дата добавления - 23.12.2020 в 14:33
bosika Дата: Пятница, 25.12.2020, 09:14 | Сообщение № 6
Группа: Пользователи
Ранг: Участник
Сообщений: 79
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010, 2013, 2016
bigor, Все работает. Немного подправить пришлось ссылку на лист. Вместо $СТО. заменил на СТО!. А так все работает, выбирает нужное. Большое спасибо! Плюсую.


Начинающий. Много и долго не пинать. Больно однако.
 
Ответить
Сообщение bigor, Все работает. Немного подправить пришлось ссылку на лист. Вместо $СТО. заменил на СТО!. А так все работает, выбирает нужное. Большое спасибо! Плюсую.

Автор - bosika
Дата добавления - 25.12.2020 в 09:14
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подстановка отрицательных данных с другого листа книги (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования Jobsora jooble
© 2010-2021 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!