Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Выборка значений из массива - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Выборка значений из массива (Формулы/Formulas)
Выборка значений из массива
roskm Дата: Четверг, 24.12.2020, 17:23 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Здравствуйте! Прошу помочь в решении. Есть таблица, по горизонтали наименование продукта АБВ1 ... АБВ50, по вертикали его длина в миллиметрах от 100 до 20000 с шагом 100. На втором листе значение АБВn/1000, АБВn/1100 и далее. Нужно выбрать значение и поставить в соседней ячейке. Пример прикладываю.
К сообщению приложен файл: 241220201720.xlsx(8.8 Kb)
 
Ответить
СообщениеЗдравствуйте! Прошу помочь в решении. Есть таблица, по горизонтали наименование продукта АБВ1 ... АБВ50, по вертикали его длина в миллиметрах от 100 до 20000 с шагом 100. На втором листе значение АБВn/1000, АБВn/1100 и далее. Нужно выбрать значение и поставить в соседней ячейке. Пример прикладываю.

Автор - roskm
Дата добавления - 24.12.2020 в 17:23
Kostya_Ye Дата: Четверг, 24.12.2020, 17:42 | Сообщение № 2
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 235
Репутация: 219 ±
Замечаний: 0% ±

Excel 2016
roskm, добрый день,
как то так
Код
=ИНДЕКС($B$2:$D$6;ПОИСКПОЗ(--ПСТР(I2;ПОИСК("/";I2)+1;999);$A$2:$A$6;0);ПОИСКПОЗ(ЛЕВСИМВ(I2;ПОИСК("/";I2)-1);$B$1:$D$1;0))
 
Ответить
Сообщениеroskm, добрый день,
как то так
Код
=ИНДЕКС($B$2:$D$6;ПОИСКПОЗ(--ПСТР(I2;ПОИСК("/";I2)+1;999);$A$2:$A$6;0);ПОИСКПОЗ(ЛЕВСИМВ(I2;ПОИСК("/";I2)-1);$B$1:$D$1;0))

Автор - Kostya_Ye
Дата добавления - 24.12.2020 в 17:42
roskm Дата: Пятница, 25.12.2020, 13:35 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Kostya_Ye, Сасибо большое
 
Ответить
СообщениеKostya_Ye, Сасибо большое

Автор - roskm
Дата добавления - 25.12.2020 в 13:35
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Выборка значений из массива (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования Jobsora jooble
© 2010-2021 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!