Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Непоследовательный массив констант - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Непоследовательный массив констант (Формулы/Formulas)
Непоследовательный массив констант
Egyptian Дата: Воскресенье, 27.12.2020, 14:48 | Сообщение № 1
Группа: Пользователи
Ранг: Форумчанин
Сообщений: 100
Репутация: 40 ±
Замечаний: 0% ±

Excel 2013/2016
Доброго всем дня.
Как можно сделать, чтобы в функции строка отображался непоследовательный массив?
Например СТРОКА(А1:А10) выдаст {1;2;3;4;5;6;7;8;9;10}.
Мне нужно чтобы было {1;2;3;4;5;6;7;8;9;10;90;91;92 и т.д...до, скажем 250}
Конечно можно оставить все в скобках, но выйдет очень длинно.
Спасибо.
 
Ответить
СообщениеДоброго всем дня.
Как можно сделать, чтобы в функции строка отображался непоследовательный массив?
Например СТРОКА(А1:А10) выдаст {1;2;3;4;5;6;7;8;9;10}.
Мне нужно чтобы было {1;2;3;4;5;6;7;8;9;10;90;91;92 и т.д...до, скажем 250}
Конечно можно оставить все в скобках, но выйдет очень длинно.
Спасибо.

Автор - Egyptian
Дата добавления - 27.12.2020 в 14:48
bmv98rus Дата: Воскресенье, 27.12.2020, 15:09 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3475
Репутация: 613 ±
Замечаний: 0% ±

Excel 2013/2016
написать функцию, которая в зависимсоти от 1,2,3..... будет выдавать требуемое,
например
Код
=ROW(1:20)+80*(ROW(1:20)>10)


Замечательный Временно просто медведь , процентов на 20.
 
Ответить
Сообщениенаписать функцию, которая в зависимсоти от 1,2,3..... будет выдавать требуемое,
например
Код
=ROW(1:20)+80*(ROW(1:20)>10)

Автор - bmv98rus
Дата добавления - 27.12.2020 в 15:09
Egyptian Дата: Воскресенье, 27.12.2020, 15:25 | Сообщение № 3
Группа: Пользователи
Ранг: Форумчанин
Сообщений: 100
Репутация: 40 ±
Замечаний: 0% ±

Excel 2013/2016
bmv98rus, Спасибо. Буду экспериментировать.
 
Ответить
Сообщениеbmv98rus, Спасибо. Буду экспериментировать.

Автор - Egyptian
Дата добавления - 27.12.2020 в 15:25
Gustav Дата: Понедельник, 28.12.2020, 14:22 | Сообщение № 4
Группа: Друзья
Ранг: Старожил
Сообщений: 1880
Репутация: 764 ±
Замечаний: 0% ±

начинал с Excel 4.0, видел 2.1
можно оставить все в скобках, но выйдет очень длинно.

Для сокращения длины можно запрятать массив в имя:
[vba]
Код
Ctrl+F3 -> Создать -> Имя: массив -> Диапазон: ={1:2:3:4:5:6:7:8:9:10:90:91:92...248:249:250} -> OK
[/vba]
и потом использовать имя в формулах:
Код
=ИНДЕКС(массив; 11)
Эта формула вернет результат 90.

Hа всякий случай напомню, что массив констант можно получить так (на примере диапазона A1:A10):
* вводим или генерируем формулой значения от 1 до 10
* в свободной соседней ячейке справа пишем формулу:
Код
=A1:A10
* После сохранения формулы входим в режим редактирования (по F2) и далее жмём F9 - ссылка в ячейке превращается в массив констант из значений диапазона:
Код
={1:2:3:4:5:6:7:8:9:10}
И далее копируем получившуюся в ячейке строку и используем ее при создании имени по Ctrl+F3.


Мой tip box - яд 41001663842605
 
Ответить
Сообщение
можно оставить все в скобках, но выйдет очень длинно.

Для сокращения длины можно запрятать массив в имя:
[vba]
Код
Ctrl+F3 -> Создать -> Имя: массив -> Диапазон: ={1:2:3:4:5:6:7:8:9:10:90:91:92...248:249:250} -> OK
[/vba]
и потом использовать имя в формулах:
Код
=ИНДЕКС(массив; 11)
Эта формула вернет результат 90.

Hа всякий случай напомню, что массив констант можно получить так (на примере диапазона A1:A10):
* вводим или генерируем формулой значения от 1 до 10
* в свободной соседней ячейке справа пишем формулу:
Код
=A1:A10
* После сохранения формулы входим в режим редактирования (по F2) и далее жмём F9 - ссылка в ячейке превращается в массив констант из значений диапазона:
Код
={1:2:3:4:5:6:7:8:9:10}
И далее копируем получившуюся в ячейке строку и используем ее при создании имени по Ctrl+F3.

Автор - Gustav
Дата добавления - 28.12.2020 в 14:22
Egyptian Дата: Понедельник, 28.12.2020, 14:39 | Сообщение № 5
Группа: Пользователи
Ранг: Форумчанин
Сообщений: 100
Репутация: 40 ±
Замечаний: 0% ±

Excel 2013/2016
Для сокращения длины можно запрятать массив в имя:

Да, у меня так и было. Просто стало интересно получить такой массив через функцию СТРОКА.
 
Ответить
Сообщение
Для сокращения длины можно запрятать массив в имя:

Да, у меня так и было. Просто стало интересно получить такой массив через функцию СТРОКА.

Автор - Egyptian
Дата добавления - 28.12.2020 в 14:39
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Непоследовательный массив констант (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования Jobsora jooble
© 2010-2021 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!