Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Скопировать данные без повторов с сохранение порядка - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Скопировать данные без повторов с сохранение порядка (Формулы/Formulas)
Скопировать данные без повторов с сохранение порядка
SergeySE Дата: Понедельник, 28.12.2020, 12:48 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 10
Репутация: 0 ±
Замечаний: 0% ±

Доброго времени суток.
В столбце "A" нумерация от 1 до 300. В столбце "B" до 30 различных текстовых значений вразнобой.

Нужно в "F" вывести все значения без повторов с сохранением порядка. А в "G" сосчитать их количество.
Можно ли это сделать без макросов? Возможно с формулами массивов.

Вручную это выглядит так: скопировать столбец, вставить в нужное место, "Данные" - "Удалить дубликаты".
Вот хотелось бы этот процесс автоматизировать формулами.
К сообщению приложен файл: 8825802.xlsx(10.2 Kb)
 
Ответить
СообщениеДоброго времени суток.
В столбце "A" нумерация от 1 до 300. В столбце "B" до 30 различных текстовых значений вразнобой.

Нужно в "F" вывести все значения без повторов с сохранением порядка. А в "G" сосчитать их количество.
Можно ли это сделать без макросов? Возможно с формулами массивов.

Вручную это выглядит так: скопировать столбец, вставить в нужное место, "Данные" - "Удалить дубликаты".
Вот хотелось бы этот процесс автоматизировать формулами.

Автор - SergeySE
Дата добавления - 28.12.2020 в 12:48
Kostya_Ye Дата: Понедельник, 28.12.2020, 13:06 | Сообщение № 2
Группа: Проверенные
Ранг: Обитатель
Сообщений: 257
Репутация: 226 ±
Замечаний: 0% ±

Excel 2016
SergeySE, добрый день,
список уникальных, формула массива
Код
=ЕСЛИОШИБКА(ИНДЕКС( $B$2:$B$21; НАИМЕНЬШИЙ( ЕСЛИ(ПОИСКПОЗ($B$2:$B$21;$B$2:$B$21;0)=СТРОКА($A$1:$A$20); ПОИСКПОЗ($B$2:$B$21;$B$2:$B$21;0);"" ); СТРОКА(A1) ));"")

количество, обычная формула
Код
=СЧЁТЕСЛИ($B$2:$B$21;F2)
 
Ответить
СообщениеSergeySE, добрый день,
список уникальных, формула массива
Код
=ЕСЛИОШИБКА(ИНДЕКС( $B$2:$B$21; НАИМЕНЬШИЙ( ЕСЛИ(ПОИСКПОЗ($B$2:$B$21;$B$2:$B$21;0)=СТРОКА($A$1:$A$20); ПОИСКПОЗ($B$2:$B$21;$B$2:$B$21;0);"" ); СТРОКА(A1) ));"")

количество, обычная формула
Код
=СЧЁТЕСЛИ($B$2:$B$21;F2)

Автор - Kostya_Ye
Дата добавления - 28.12.2020 в 13:06
jakim Дата: Вторник, 29.12.2020, 10:31 | Сообщение № 3
Группа: Друзья
Ранг: Старожил
Сообщений: 1003
Репутация: 273 ±
Замечаний: 0% ±

Excel 2010
Обычная формула

Для уникальных значений

Код
=IFERROR(INDEX($B$2:$B$310;MATCH(TRUE;INDEX((COUNTIF($F$1:F1;$B$2:$B$310)=0);0);0));"")

Для количества уникальных значений

Код
=COUNTIF(B$2:B$400;F2)
 
Ответить
Сообщение
Обычная формула

Для уникальных значений

Код
=IFERROR(INDEX($B$2:$B$310;MATCH(TRUE;INDEX((COUNTIF($F$1:F1;$B$2:$B$310)=0);0);0));"")

Для количества уникальных значений

Код
=COUNTIF(B$2:B$400;F2)

Автор - jakim
Дата добавления - 29.12.2020 в 10:31
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Скопировать данные без повторов с сохранение порядка (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования Jobsora jooble
© 2010-2021 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!