Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Задание кол-ва дней недели - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Задание кол-ва дней недели (Формулы/Formulas)
Задание кол-ва дней недели
FoxLord Дата: Вторник, 29.12.2020, 13:04 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 9
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
Доброго дня!
Как реализовать подобную зависимость на формулах?
Должны повторяться рабочие дни по 5 раз, выходных не должно быть.
К новому году голова со скрежетом уже думает.
Не могу до ума довести.
Код

=A2+(ЕСЛИ(ДЕНЬНЕД(A2;2)>5;1;0))


Заранее спасибо!
К сообщению приложен файл: 9168228.xlsx(9.4 Kb)


Делить на ноль можно, как процесс, но результат непредсказуем.

Сообщение отредактировал FoxLord - Вторник, 29.12.2020, 13:05
 
Ответить
СообщениеДоброго дня!
Как реализовать подобную зависимость на формулах?
Должны повторяться рабочие дни по 5 раз, выходных не должно быть.
К новому году голова со скрежетом уже думает.
Не могу до ума довести.
Код

=A2+(ЕСЛИ(ДЕНЬНЕД(A2;2)>5;1;0))


Заранее спасибо!

Автор - FoxLord
Дата добавления - 29.12.2020 в 13:04
китин Дата: Вторник, 29.12.2020, 13:13 | Сообщение № 2
Группа: Модераторы
Ранг: Экселист
Сообщений: 6402
Репутация: 986 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
Код
=РАБДЕНЬ($A2;1;)

и тянем вниз


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщение
Код
=РАБДЕНЬ($A2;1;)

и тянем вниз

Автор - китин
Дата добавления - 29.12.2020 в 13:13
Kostya_Ye Дата: Вторник, 29.12.2020, 13:28 | Сообщение № 3
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 225
Репутация: 219 ±
Замечаний: 0% ±

Excel 2016
FoxLord, китин, добрый день,
с учетом запроса ТС на повторение даты 5 раз, в ячейку А7
Код
=ЕСЛИ(СЧЁТЕСЛИ(A2:A6;A6)>=5;РАБДЕНЬ(A6;1);A6)


Сообщение отредактировал Kostya_Ye - Вторник, 29.12.2020, 13:28
 
Ответить
СообщениеFoxLord, китин, добрый день,
с учетом запроса ТС на повторение даты 5 раз, в ячейку А7
Код
=ЕСЛИ(СЧЁТЕСЛИ(A2:A6;A6)>=5;РАБДЕНЬ(A6;1);A6)

Автор - Kostya_Ye
Дата добавления - 29.12.2020 в 13:28
FoxLord Дата: Вторник, 29.12.2020, 13:50 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 9
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
Kostya_Ye, Спасибо, простейшая логика. Новая функция
Код
=РАБДЕНЬ()
в моем арсенале.


Делить на ноль можно, как процесс, но результат непредсказуем.
 
Ответить
СообщениеKostya_Ye, Спасибо, простейшая логика. Новая функция
Код
=РАБДЕНЬ()
в моем арсенале.

Автор - FoxLord
Дата добавления - 29.12.2020 в 13:50
Kostya_Ye Дата: Вторник, 29.12.2020, 14:09 | Сообщение № 5
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 225
Репутация: 219 ±
Замечаний: 0% ±

Excel 2016
FoxLord,
за функцию
Код
=РАБДЕНЬ()
спасибо не мне, а китин, я написал изначально вариант формулы без нее, но перед публикацией увидел сообщение #2 и вспомнил про эту функцию.
 
Ответить
СообщениеFoxLord,
за функцию
Код
=РАБДЕНЬ()
спасибо не мне, а китин, я написал изначально вариант формулы без нее, но перед публикацией увидел сообщение #2 и вспомнил про эту функцию.

Автор - Kostya_Ye
Дата добавления - 29.12.2020 в 14:09
FoxLord Дата: Вторник, 29.12.2020, 14:14 | Сообщение № 6
Группа: Пользователи
Ранг: Прохожий
Сообщений: 9
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
Kostya_Ye, Покажите изначальный вариант?


Делить на ноль можно, как процесс, но результат непредсказуем.
 
Ответить
СообщениеKostya_Ye, Покажите изначальный вариант?

Автор - FoxLord
Дата добавления - 29.12.2020 в 14:14
Kostya_Ye Дата: Вторник, 29.12.2020, 14:20 | Сообщение № 7
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 225
Репутация: 219 ±
Замечаний: 0% ±

Excel 2016
FoxLord,
вот, в А7
Код
=ЕСЛИ(СЧЁТЕСЛИ(A2:A6;A6)>=5;A6+1+2*(ДЕНЬНЕД(A6;2)=5);A6)
 
Ответить
СообщениеFoxLord,
вот, в А7
Код
=ЕСЛИ(СЧЁТЕСЛИ(A2:A6;A6)>=5;A6+1+2*(ДЕНЬНЕД(A6;2)=5);A6)

Автор - Kostya_Ye
Дата добавления - 29.12.2020 в 14:20
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Задание кол-ва дней недели (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования Jobsora jooble
© 2010-2021 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!