Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Как сложить через столбец положительные значения - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Как сложить через столбец положительные значения (Формулы/Formulas)
Как сложить через столбец положительные значения
invoavto2209 Дата: Понедельник, 04.01.2021, 21:41 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Добрый день и С новым годом, форумчане!
Помогите, пожалуйста с такой проблемой - уже мозг подорвал себе
Нужно сложить положительные значения данных, которые идут через столбик, т.е. сложить B2+D2+F2+...., только если в них положительные значения.
Как сложить через столбик знаю, а как туда положительные значение добавить....
К сообщению приложен файл: 3549081.xlsx(10.8 Kb)
 
Ответить
СообщениеДобрый день и С новым годом, форумчане!
Помогите, пожалуйста с такой проблемой - уже мозг подорвал себе
Нужно сложить положительные значения данных, которые идут через столбик, т.е. сложить B2+D2+F2+...., только если в них положительные значения.
Как сложить через столбик знаю, а как туда положительные значение добавить....

Автор - invoavto2209
Дата добавления - 04.01.2021 в 21:41
bigor Дата: Понедельник, 04.01.2021, 22:00 | Сообщение № 2
Группа: Проверенные
Ранг: Обитатель
Сообщений: 439
Репутация: 83 ±
Замечаний: 0% ±

нет
Добрый

Как вариант
Код
=SUMPRODUCT((A2:L2)*(MOD(COLUMN(A2:L2);2)=0)*(A2:L2>0))
 
Ответить
СообщениеДобрый

Как вариант
Код
=SUMPRODUCT((A2:L2)*(MOD(COLUMN(A2:L2);2)=0)*(A2:L2>0))

Автор - bigor
Дата добавления - 04.01.2021 в 22:00
Pelena Дата: Понедельник, 04.01.2021, 22:07 | Сообщение № 3
Группа: Админы
Ранг: Местный житель
Сообщений: 17622
Репутация: 3924 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Исходя из примера, можно так
Код
=СУММЕСЛИМН(A2:L2;$A$1:$L$1;"ИЗМ";A2:L2;">0")


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеИсходя из примера, можно так
Код
=СУММЕСЛИМН(A2:L2;$A$1:$L$1;"ИЗМ";A2:L2;">0")

Автор - Pelena
Дата добавления - 04.01.2021 в 22:07
Che79 Дата: Понедельник, 04.01.2021, 22:36 | Сообщение № 4
Группа: Друзья
Ранг: Старожил
Сообщений: 1649
Репутация: 306 ±
Замечаний: 0% ±

2013 Win, 365 Mac
еще вариант
Код
=СУММПРОИЗВ(A2:L2*(A2:L2>0)*(ЕЧЁТН(СТОЛБЕЦ(A2:L2))))


Делай нормально и будет нормально!
 
Ответить
Сообщениееще вариант
Код
=СУММПРОИЗВ(A2:L2*(A2:L2>0)*(ЕЧЁТН(СТОЛБЕЦ(A2:L2))))

Автор - Che79
Дата добавления - 04.01.2021 в 22:36
invoavto2209 Дата: Вторник, 05.01.2021, 17:43 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

hands все спасибо! Особенно Pelena! Подтянуть верхнюю строку даже и не думал)))
 
Ответить
Сообщениеhands все спасибо! Особенно Pelena! Подтянуть верхнюю строку даже и не думал)))

Автор - invoavto2209
Дата добавления - 05.01.2021 в 17:43
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Как сложить через столбец положительные значения (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования Jobsora jooble
© 2010-2021 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!