Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Если в строке 10 символов то перед началом добавить 0. - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Если в строке 10 символов то перед началом добавить 0. (Формулы/Formulas)
Если в строке 10 символов то перед началом добавить 0.
ЛохRREV111111111 Дата: Четверг, 14.01.2021, 10:28 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Возможно ли такое реализовать? Имеется большая база данных в котором символов должно быть 11, но при выгрузке из системы нули пропадают.
Спасибо за помощь
 
Ответить
СообщениеВозможно ли такое реализовать? Имеется большая база данных в котором символов должно быть 11, но при выгрузке из системы нули пропадают.
Спасибо за помощь

Автор - ЛохRREV111111111
Дата добавления - 14.01.2021 в 10:28
ЩтуКув Дата: Четверг, 14.01.2021, 10:35 | Сообщение № 2
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 134
Репутация: 7 ±
Замечаний: 0% ±

Excel 2013
Вот так)
К сообщению приложен файл: 5070852.xlsx(11.0 Kb)
 
Ответить
СообщениеВот так)

Автор - ЩтуКув
Дата добавления - 14.01.2021 в 10:35
Serge_007 Дата: Четверг, 14.01.2021, 10:41 | Сообщение № 3
Группа: Админы
Ранг: Местный житель
Сообщений: 13524
Репутация: ±
Замечаний: ±

Excel 2010
ЛохRREV111111111, здравствуйте

Если 11 знаков необходимо отображать, то можно форматом ячейки
Код
00000000000
(11-ть нолей)


Яндекс-деньги:41001419691823 | WMR:126292472390
 
Ответить
СообщениеЛохRREV111111111, здравствуйте

Если 11 знаков необходимо отображать, то можно форматом ячейки
Код
00000000000
(11-ть нолей)

Автор - Serge_007
Дата добавления - 14.01.2021 в 10:41
ЛохRREV111111111 Дата: Четверг, 14.01.2021, 10:41 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

ЩтуКув, такой вариант тоже правильный ?
Код
=ЕСЛИ(ДЛСТР(B1)<11;"0"&B1;B1)


Сообщение отредактировал Serge_007 - Четверг, 14.01.2021, 10:45
 
Ответить
СообщениеЩтуКув, такой вариант тоже правильный ?
Код
=ЕСЛИ(ДЛСТР(B1)<11;"0"&B1;B1)

Автор - ЛохRREV111111111
Дата добавления - 14.01.2021 в 10:41
ЩтуКув Дата: Четверг, 14.01.2021, 10:44 | Сообщение № 5
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 134
Репутация: 7 ±
Замечаний: 0% ±

Excel 2013
ЛохRREV111111111, вариант Админа круче и проще!
 
Ответить
СообщениеЛохRREV111111111, вариант Админа круче и проще!

Автор - ЩтуКув
Дата добавления - 14.01.2021 в 10:44
ЛохRREV111111111 Дата: Четверг, 14.01.2021, 10:45 | Сообщение № 6
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Serge_007, спасибо вам большое)) вы просто не представляете на сколько ускорилась наша работа) hands hands
 
Ответить
СообщениеSerge_007, спасибо вам большое)) вы просто не представляете на сколько ускорилась наша работа) hands hands

Автор - ЛохRREV111111111
Дата добавления - 14.01.2021 в 10:45
Serge_007 Дата: Четверг, 14.01.2021, 10:46 | Сообщение № 7
Группа: Админы
Ранг: Местный житель
Сообщений: 13524
Репутация: ±
Замечаний: ±

Excel 2010
:D


Яндекс-деньги:41001419691823 | WMR:126292472390
 
Ответить
Сообщение:D

Автор - Serge_007
Дата добавления - 14.01.2021 в 10:46
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Если в строке 10 символов то перед началом добавить 0. (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования Jobsora jooble
© 2010-2021 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!