Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Разделить текст в ячейке - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Разделить текст в ячейке (Формулы/Formulas)
Разделить текст в ячейке
Chelovekov Дата: Пятница, 15.01.2021, 08:52 | Сообщение № 1
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 192
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Здравствуйте, Уважаемые Форумчане. Помоги те исправить формулу в книге.
Файл с примером прикрепляю.
Спасибо.
К сообщению приложен файл: _4.xlsx(10.3 Kb)
 
Ответить
СообщениеЗдравствуйте, Уважаемые Форумчане. Помоги те исправить формулу в книге.
Файл с примером прикрепляю.
Спасибо.

Автор - Chelovekov
Дата добавления - 15.01.2021 в 08:52
Serge_007 Дата: Пятница, 15.01.2021, 09:07 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 13708
Репутация: 2301 ±
Замечаний: ±

Excel 2010
Здравствуйте

Код
=ПСТР(A2;ПОИСК(":";A2)+1;ПОИСК(СИМВОЛ(160);A2&СИМВОЛ(160))-ПОИСК(":";A2))


Яндекс-деньги:41001419691823 | WMR:126292472390
 
Ответить
СообщениеЗдравствуйте

Код
=ПСТР(A2;ПОИСК(":";A2)+1;ПОИСК(СИМВОЛ(160);A2&СИМВОЛ(160))-ПОИСК(":";A2))

Автор - Serge_007
Дата добавления - 15.01.2021 в 09:07
китин Дата: Пятница, 15.01.2021, 09:09 | Сообщение № 3
Группа: Модераторы
Ранг: Экселист
Сообщений: 6402
Репутация: 986 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
Код
=ЕСЛИОШИБКА(ЛЕВБ(ПСТР($A2;ПОИСК(":";$A2)+1;ДЛСТР($A2));ПОИСК(СИМВОЛ(160);ПСТР($A2;ПОИСК(":";$A2)+1;ДЛСТР($A2))));ПСТР($A2;ПОИСК(":";$A2)+1;ДЛСТР($A2)))

да, несколько монструозно, без оптимизации


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщение
Код
=ЕСЛИОШИБКА(ЛЕВБ(ПСТР($A2;ПОИСК(":";$A2)+1;ДЛСТР($A2));ПОИСК(СИМВОЛ(160);ПСТР($A2;ПОИСК(":";$A2)+1;ДЛСТР($A2))));ПСТР($A2;ПОИСК(":";$A2)+1;ДЛСТР($A2)))

да, несколько монструозно, без оптимизации

Автор - китин
Дата добавления - 15.01.2021 в 09:09
Chelovekov Дата: Пятница, 15.01.2021, 11:35 | Сообщение № 4
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 192
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Огромное спасибо hands
 
Ответить
СообщениеОгромное спасибо hands

Автор - Chelovekov
Дата добавления - 15.01.2021 в 11:35
Chelovekov Дата: Пятница, 15.01.2021, 11:41 | Сообщение № 5
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 192
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Еще подскажите пожалуйста, результат по этим формулам являются текстом, и поэтому если использовать их значения в формулах, появляется ошибка. Можно это исправить ?? Я знаю, что бы перевести, в число нужно умножить на 1, но в данном случае это не работает.
Помогите пожалуйста.
Спасибо.
 
Ответить
СообщениеЕще подскажите пожалуйста, результат по этим формулам являются текстом, и поэтому если использовать их значения в формулах, появляется ошибка. Можно это исправить ?? Я знаю, что бы перевести, в число нужно умножить на 1, но в данном случае это не работает.
Помогите пожалуйста.
Спасибо.

Автор - Chelovekov
Дата добавления - 15.01.2021 в 11:41
Serge_007 Дата: Пятница, 15.01.2021, 13:51 | Сообщение № 6
Группа: Админы
Ранг: Местный житель
Сообщений: 13708
Репутация: 2301 ±
Замечаний: ±

Excel 2010
...что бы перевести текст в число нужно умножить на 1, но в данном случае это не работает
В чем выражается "наработость"?
Умножайте на 1, прибавляйте 0, используйте бинарное отрицание и т.п. (см. ссылку ниже) - все будет работать

Что такое -- или как превратить ИСТИНА в 1, а ЛОЖЬ в 0?


Яндекс-деньги:41001419691823 | WMR:126292472390
 
Ответить
Сообщение
...что бы перевести текст в число нужно умножить на 1, но в данном случае это не работает
В чем выражается "наработость"?
Умножайте на 1, прибавляйте 0, используйте бинарное отрицание и т.п. (см. ссылку ниже) - все будет работать

Что такое -- или как превратить ИСТИНА в 1, а ЛОЖЬ в 0?

Автор - Serge_007
Дата добавления - 15.01.2021 в 13:51
Юрий_Ф Дата: Пятница, 29.01.2021, 02:23 | Сообщение № 7
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 247
Репутация: -9 ±
Замечаний: 0% ±

Excel 2010
Интересно! hands


То, что мы делаем, завораживает!
Кстати! Я не могу всем нравиться! И это взаимно!
 
Ответить
СообщениеИнтересно! hands

Автор - Юрий_Ф
Дата добавления - 29.01.2021 в 02:23
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Разделить текст в ячейке (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования Jobsora jooble
© 2010-2021 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!