Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Подсчет повторяющихся значений после фильтра - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подсчет повторяющихся значений после фильтра (Формулы/Formulas)
Подсчет повторяющихся значений после фильтра
Кузьмич Дата: Воскресенье, 17.01.2021, 13:36 | Сообщение № 1
Группа: Пользователи
Ранг: Участник
Сообщений: 64
Репутация: 2 ±
Замечаний: 0% ±

Excel 2013
Доброго всем дня! Помогите пожалуйста с формулой. Есть столбец с повторами, применяю к нему фильтр, подсчет всех оставшихся вариантов считаю по формуле Промежуточные итоги. А как мне в этом отфильтрованном остатке произвести подсчет дубликатов (повторяющихся значений)? Благодарю за понимание!


Ну, теперь вся утка наша...
 
Ответить
СообщениеДоброго всем дня! Помогите пожалуйста с формулой. Есть столбец с повторами, применяю к нему фильтр, подсчет всех оставшихся вариантов считаю по формуле Промежуточные итоги. А как мне в этом отфильтрованном остатке произвести подсчет дубликатов (повторяющихся значений)? Благодарю за понимание!

Автор - Кузьмич
Дата добавления - 17.01.2021 в 13:36
Anis625 Дата: Понедельник, 18.01.2021, 00:28 | Сообщение № 2
Группа: Проверенные
Ранг: Ветеран
Сообщений: 529
Репутация: 28 ±
Замечаний: 0% ±

Excel 2013
Кузьмич,
Примера нет. Замечание сделают.
А так формулой можно (диапазон свой указывайте):
Код
=СУММПРОИЗВ(--(СЧЁТЕСЛИ(A1:A16;A1:A16)>1))
 
Ответить
СообщениеКузьмич,
Примера нет. Замечание сделают.
А так формулой можно (диапазон свой указывайте):
Код
=СУММПРОИЗВ(--(СЧЁТЕСЛИ(A1:A16;A1:A16)>1))

Автор - Anis625
Дата добавления - 18.01.2021 в 00:28
bmv98rus Дата: Понедельник, 18.01.2021, 08:01 | Сообщение № 3
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3485
Репутация: 615 ±
Замечаний: 0% ±

Excel 2013/2016
Anis625, и это как же ваша формула с фильтром то справится?
Кузьмич, по поводу примера - верно. Намекну, что или нужно доп. столбец делать с признаком скрыто не скрыто через те же промежуточные итого. или также с помощью них и еще летучего смещения массивку делать.


Замечательный Временно просто медведь , процентов на 20.
 
Ответить
СообщениеAnis625, и это как же ваша формула с фильтром то справится?
Кузьмич, по поводу примера - верно. Намекну, что или нужно доп. столбец делать с признаком скрыто не скрыто через те же промежуточные итого. или также с помощью них и еще летучего смещения массивку делать.

Автор - bmv98rus
Дата добавления - 18.01.2021 в 08:01
Кузьмич Дата: Понедельник, 18.01.2021, 20:26 | Сообщение № 4
Группа: Пользователи
Ранг: Участник
Сообщений: 64
Репутация: 2 ±
Замечаний: 0% ±

Excel 2013
Пример
К сообщению приложен файл: 1629307.xlsx(13.9 Kb)


Ну, теперь вся утка наша...
 
Ответить
СообщениеПример

Автор - Кузьмич
Дата добавления - 18.01.2021 в 20:26
Pelena Дата: Понедельник, 18.01.2021, 21:07 | Сообщение № 5
Группа: Админы
Ранг: Местный житель
Сообщений: 17563
Репутация: 3910 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Код
=СУММПРОИЗВ(ПРОМЕЖУТОЧНЫЕ.ИТОГИ(3;СМЕЩ($B$2;СТРОКА($1:$256);0))*($B$3:$B$258=G1))
К сообщению приложен файл: 7722019.xlsx(14.2 Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
Сообщение
Код
=СУММПРОИЗВ(ПРОМЕЖУТОЧНЫЕ.ИТОГИ(3;СМЕЩ($B$2;СТРОКА($1:$256);0))*($B$3:$B$258=G1))

Автор - Pelena
Дата добавления - 18.01.2021 в 21:07
Кузьмич Дата: Вторник, 19.01.2021, 16:04 | Сообщение № 6
Группа: Пользователи
Ранг: Участник
Сообщений: 64
Репутация: 2 ±
Замечаний: 0% ±

Excel 2013
Pelena, Pelena, ты УМНИЦА!!! Очередной раз меня выручаешь. :up:


Ну, теперь вся утка наша...

Сообщение отредактировал Кузьмич - Вторник, 19.01.2021, 16:07
 
Ответить
СообщениеPelena, Pelena, ты УМНИЦА!!! Очередной раз меня выручаешь. :up:

Автор - Кузьмич
Дата добавления - 19.01.2021 в 16:04
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подсчет повторяющихся значений после фильтра (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования Jobsora jooble
© 2010-2021 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!