Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Меняется формула при перетаскивании ячеек - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Меняется формула при перетаскивании ячеек (Формулы/Formulas)
Меняется формула при перетаскивании ячеек
Tavlar Дата: Четверг, 28.01.2021, 11:27 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 48
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
Здравствуйте
в ячейке D3 в файле примере находится формула
Код
=СУММПРОИЗВ(--ЕЧИСЛО(--ЛЕВСИМВ(D4:D30)))
, которая считает количество ячеек в диапазоне, которые начинаются с цифры
при попытке перетаскивания содержимого ячейки D4 вниз, формула в ячейке D3 изменяется на
Код
=СУММПРОИЗВ(--ЕЧИСЛО(--ЛЕВСИМВ(D5:D30)))

тоже самое происходит и при попытке перетащить последнюю ячейку D30 вверх
как можно обойти этот неприятный момент?
К сообщению приложен файл: 0331272.xlsx(41.1 Kb)
 
Ответить
СообщениеЗдравствуйте
в ячейке D3 в файле примере находится формула
Код
=СУММПРОИЗВ(--ЕЧИСЛО(--ЛЕВСИМВ(D4:D30)))
, которая считает количество ячеек в диапазоне, которые начинаются с цифры
при попытке перетаскивания содержимого ячейки D4 вниз, формула в ячейке D3 изменяется на
Код
=СУММПРОИЗВ(--ЕЧИСЛО(--ЛЕВСИМВ(D5:D30)))

тоже самое происходит и при попытке перетащить последнюю ячейку D30 вверх
как можно обойти этот неприятный момент?

Автор - Tavlar
Дата добавления - 28.01.2021 в 11:27
Nic70y Дата: Четверг, 28.01.2021, 11:30 | Сообщение № 2
Группа: Друзья
Ранг: Экселист
Сообщений: 6830
Репутация: 1567 ±
Замечаний: 0% ±

Excel 2010


ЮMoney(Яндекс Деньги) 41001841029809
 
Ответить
СообщениеАбсолютные и относительные ссылки

Автор - Nic70y
Дата добавления - 28.01.2021 в 11:30
Serge_007 Дата: Четверг, 28.01.2021, 11:32 | Сообщение № 3
Группа: Админы
Ранг: Местный житель
Сообщений: 13869
Репутация: 2315 ±
Замечаний: ±

Excel 2010
Есть такое понятие в Excel, как относительные и абсолютные ссылки, почитайте в инете много материалов на эту тему

Так будет работать:
Код
=СУММПРОИЗВ(--ЕЧИСЛО(-ЛЕВБ(D$4:D$30)))


Яндекс-деньги:41001419691823 | WMR:126292472390
 
Ответить
СообщениеЕсть такое понятие в Excel, как относительные и абсолютные ссылки, почитайте в инете много материалов на эту тему

Так будет работать:
Код
=СУММПРОИЗВ(--ЕЧИСЛО(-ЛЕВБ(D$4:D$30)))

Автор - Serge_007
Дата добавления - 28.01.2021 в 11:32
Tavlar Дата: Четверг, 28.01.2021, 11:37 | Сообщение № 4
Группа: Пользователи
Ранг: Новичок
Сообщений: 48
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
Nic70y, Serge_007, спасибо, ответ лежал на поверхности)
 
Ответить
СообщениеNic70y, Serge_007, спасибо, ответ лежал на поверхности)

Автор - Tavlar
Дата добавления - 28.01.2021 в 11:37
Tavlar Дата: Четверг, 28.01.2021, 11:50 | Сообщение № 5
Группа: Пользователи
Ранг: Новичок
Сообщений: 48
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
рано радовался, не помогает данный метод
 
Ответить
Сообщениерано радовался, не помогает данный метод

Автор - Tavlar
Дата добавления - 28.01.2021 в 11:50
Serge_007 Дата: Четверг, 28.01.2021, 11:53 | Сообщение № 6
Группа: Админы
Ранг: Местный житель
Сообщений: 13869
Репутация: 2315 ±
Замечаний: ±

Excel 2010
Он не может не помогать


Яндекс-деньги:41001419691823 | WMR:126292472390
 
Ответить
СообщениеОн не может не помогать

Автор - Serge_007
Дата добавления - 28.01.2021 в 11:53
Nic70y Дата: Четверг, 28.01.2021, 11:54 | Сообщение № 7
Группа: Друзья
Ранг: Экселист
Сообщений: 6830
Репутация: 1567 ±
Замечаний: 0% ±

Excel 2010
Код
=СУММПРОИЗВ(--ЕЧИСЛО(--ЛЕВСИМВ(ИНДЕКС(D:D;5):ИНДЕКС(D:D;30))))


ЮMoney(Яндекс Деньги) 41001841029809
 
Ответить
Сообщение
Код
=СУММПРОИЗВ(--ЕЧИСЛО(--ЛЕВСИМВ(ИНДЕКС(D:D;5):ИНДЕКС(D:D;30))))

Автор - Nic70y
Дата добавления - 28.01.2021 в 11:54
Tavlar Дата: Четверг, 28.01.2021, 11:58 | Сообщение № 8
Группа: Пользователи
Ранг: Новичок
Сообщений: 48
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
Serge_007, попробуйте, пожалуйста, в моем примере поменять формулу в ячейке D3 и перетащить содержимое ячейки D4 на D5 и посмотреть что стало с формулой на ячейке D3
 
Ответить
СообщениеSerge_007, попробуйте, пожалуйста, в моем примере поменять формулу в ячейке D3 и перетащить содержимое ячейки D4 на D5 и посмотреть что стало с формулой на ячейке D3

Автор - Tavlar
Дата добавления - 28.01.2021 в 11:58
Tavlar Дата: Четверг, 28.01.2021, 12:06 | Сообщение № 9
Группа: Пользователи
Ранг: Новичок
Сообщений: 48
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
Nic70y, все супер, но есть еще один нюанс. строки будут добавляться и удаляться. т.е. нижняя граница будет всегда меняться. можно и для этого случая что нибудь придумать?
 
Ответить
СообщениеNic70y, все супер, но есть еще один нюанс. строки будут добавляться и удаляться. т.е. нижняя граница будет всегда меняться. можно и для этого случая что нибудь придумать?

Автор - Tavlar
Дата добавления - 28.01.2021 в 12:06
Nic70y Дата: Четверг, 28.01.2021, 12:25 | Сообщение № 10
Группа: Друзья
Ранг: Экселист
Сообщений: 6830
Репутация: 1567 ±
Замечаний: 0% ±

Excel 2010
Код
=СУММПРОИЗВ(--ЕЧИСЛО(--ЛЕВСИМВ(ИНДЕКС(D:D;СТРОКА()+1):ИНДЕКС(D:D;МАКС(ЕСЛИОШИБКА(СТРОКА()+ПОИСКПОЗ(9E+307;ИНДЕКС(D:D;СТРОКА()+1):ИНДЕКС(D:D;1048576));СТРОКА()+1);ЕСЛИОШИБКА(СТРОКА()+ПОИСКПОЗ("我";ИНДЕКС(D:D;СТРОКА()+1):ИНДЕКС(D:D;1048576));СТРОКА()+1))))))
К сообщению приложен файл: 245.xlsx(41.3 Kb)


ЮMoney(Яндекс Деньги) 41001841029809

Сообщение отредактировал Nic70y - Четверг, 28.01.2021, 12:26
 
Ответить
Сообщение
Код
=СУММПРОИЗВ(--ЕЧИСЛО(--ЛЕВСИМВ(ИНДЕКС(D:D;СТРОКА()+1):ИНДЕКС(D:D;МАКС(ЕСЛИОШИБКА(СТРОКА()+ПОИСКПОЗ(9E+307;ИНДЕКС(D:D;СТРОКА()+1):ИНДЕКС(D:D;1048576));СТРОКА()+1);ЕСЛИОШИБКА(СТРОКА()+ПОИСКПОЗ("我";ИНДЕКС(D:D;СТРОКА()+1):ИНДЕКС(D:D;1048576));СТРОКА()+1))))))

Автор - Nic70y
Дата добавления - 28.01.2021 в 12:25
Serge_007 Дата: Четверг, 28.01.2021, 12:39 | Сообщение № 11
Группа: Админы
Ранг: Местный житель
Сообщений: 13869
Репутация: 2315 ±
Замечаний: ±

Excel 2010
перетащить содержимое ячейки D4 на D5
Это другой разговор
В таком случае так:
Код
=СУММПРОИЗВ(--ЕЧИСЛО(-ЛЕВБ(ДВССЫЛ("D4:D30"))))


Яндекс-деньги:41001419691823 | WMR:126292472390
 
Ответить
Сообщение
перетащить содержимое ячейки D4 на D5
Это другой разговор
В таком случае так:
Код
=СУММПРОИЗВ(--ЕЧИСЛО(-ЛЕВБ(ДВССЫЛ("D4:D30"))))

Автор - Serge_007
Дата добавления - 28.01.2021 в 12:39
Serge_007 Дата: Четверг, 28.01.2021, 12:41 | Сообщение № 12
Группа: Админы
Ранг: Местный житель
Сообщений: 13869
Репутация: 2315 ±
Замечаний: ±

Excel 2010
все супер
Это не супер. Указывать весь столбец в формуле - непродуктивно. Лучше взять кол-во строк с разумным запасом


Яндекс-деньги:41001419691823 | WMR:126292472390
 
Ответить
Сообщение
все супер
Это не супер. Указывать весь столбец в формуле - непродуктивно. Лучше взять кол-во строк с разумным запасом

Автор - Serge_007
Дата добавления - 28.01.2021 в 12:41
Nic70y Дата: Четверг, 28.01.2021, 12:57 | Сообщение № 13
Группа: Друзья
Ранг: Экселист
Сообщений: 6830
Репутация: 1567 ±
Замечаний: 0% ±

Excel 2010
Указывать весь столбец в формуле - непродуктивно
не согласен,
смотря какая формула,
для ПОИСКПОЗ - да
это 1048576 можно заменить на макс.возможную,
а вот
ДВССЫЛ
точно не продуктивно)


ЮMoney(Яндекс Деньги) 41001841029809
 
Ответить
Сообщение
Указывать весь столбец в формуле - непродуктивно
не согласен,
смотря какая формула,
для ПОИСКПОЗ - да
это 1048576 можно заменить на макс.возможную,
а вот
ДВССЫЛ
точно не продуктивно)

Автор - Nic70y
Дата добавления - 28.01.2021 в 12:57
Serge_007 Дата: Четверг, 28.01.2021, 13:02 | Сообщение № 14
Группа: Админы
Ранг: Местный житель
Сообщений: 13869
Репутация: 2315 ±
Замечаний: ±

Excel 2010
смотря какая формула
Любая
Кроме этого - вопрос совместимости форматов

ДВССЫЛ
точно не продуктивно)
Чем? Не нравится на листе - уберем в имена, они и так волатильны


Яндекс-деньги:41001419691823 | WMR:126292472390
 
Ответить
Сообщение
смотря какая формула
Любая
Кроме этого - вопрос совместимости форматов

ДВССЫЛ
точно не продуктивно)
Чем? Не нравится на листе - уберем в имена, они и так волатильны

Автор - Serge_007
Дата добавления - 28.01.2021 в 13:02
Nic70y Дата: Четверг, 28.01.2021, 14:53 | Сообщение № 15
Группа: Друзья
Ранг: Экселист
Сообщений: 6830
Репутация: 1567 ±
Замечаний: 0% ±

Excel 2010
от нечего делать провел эксперимент
Код
=$A$1
и
Код
=ИНДЕКС(A:A;1)
вставляется на 1 000 000 строк с одинаковой скоростью ДВССЫЛ в 5 раз быстрее...
но она ж пересчитывается


ЮMoney(Яндекс Деньги) 41001841029809

Сообщение отредактировал Nic70y - Четверг, 28.01.2021, 14:55
 
Ответить
Сообщениеот нечего делать провел эксперимент
Код
=$A$1
и
Код
=ИНДЕКС(A:A;1)
вставляется на 1 000 000 строк с одинаковой скоростью ДВССЫЛ в 5 раз быстрее...
но она ж пересчитывается

Автор - Nic70y
Дата добавления - 28.01.2021 в 14:53
Serge_007 Дата: Четверг, 28.01.2021, 15:29 | Сообщение № 16
Группа: Админы
Ранг: Местный житель
Сообщений: 13869
Репутация: 2315 ±
Замечаний: ±

Excel 2010
вставляется на 1 000 000 строк с одинаковой скоростью
Дело не в том, как быстро вставляется, а в том, как впоследствии будет влиять на вычисления

ДВССЫЛ в 5 раз быстрее
Волатильные функции в большинстве своем быстрее чем обычные работают, но тот же вопрос - как они впоследствии будет влиять на вычисления

Для каждого конкретного файла надо решать отдельно, что использовать
Для файла-примера в этой теме принципиальной разницы нет, но для других файлов разница в быстродействии может быть в разы)


Яндекс-деньги:41001419691823 | WMR:126292472390
 
Ответить
Сообщение
вставляется на 1 000 000 строк с одинаковой скоростью
Дело не в том, как быстро вставляется, а в том, как впоследствии будет влиять на вычисления

ДВССЫЛ в 5 раз быстрее
Волатильные функции в большинстве своем быстрее чем обычные работают, но тот же вопрос - как они впоследствии будет влиять на вычисления

Для каждого конкретного файла надо решать отдельно, что использовать
Для файла-примера в этой теме принципиальной разницы нет, но для других файлов разница в быстродействии может быть в разы)

Автор - Serge_007
Дата добавления - 28.01.2021 в 15:29
Nic70y Дата: Четверг, 28.01.2021, 16:10 | Сообщение № 17
Группа: Друзья
Ранг: Экселист
Сообщений: 6830
Репутация: 1567 ±
Замечаний: 0% ±

Excel 2010
да все верно,
я как бы об этом и писал.
при изменении 1 ячейки ИНДЕКС проглатывает,
а ДВССЫЛ притормаживает,
на таком кол-ве формул заметно.


ЮMoney(Яндекс Деньги) 41001841029809
 
Ответить
Сообщениеда все верно,
я как бы об этом и писал.
при изменении 1 ячейки ИНДЕКС проглатывает,
а ДВССЫЛ притормаживает,
на таком кол-ве формул заметно.

Автор - Nic70y
Дата добавления - 28.01.2021 в 16:10
Serge_007 Дата: Четверг, 28.01.2021, 16:27 | Сообщение № 18
Группа: Админы
Ранг: Местный житель
Сообщений: 13869
Репутация: 2315 ±
Замечаний: ±

Excel 2010
ДВССЫЛ притормаживает
Ты её в имя запихал?


Яндекс-деньги:41001419691823 | WMR:126292472390
 
Ответить
Сообщение
ДВССЫЛ притормаживает
Ты её в имя запихал?

Автор - Serge_007
Дата добавления - 28.01.2021 в 16:27
Nic70y Дата: Четверг, 28.01.2021, 16:35 | Сообщение № 19
Группа: Друзья
Ранг: Экселист
Сообщений: 6830
Репутация: 1567 ±
Замечаний: 0% ±

Excel 2010
Ты её в имя запихал?
не на листе 1млн шт.


ЮMoney(Яндекс Деньги) 41001841029809
 
Ответить
Сообщение
Ты её в имя запихал?
не на листе 1млн шт.

Автор - Nic70y
Дата добавления - 28.01.2021 в 16:35
Serge_007 Дата: Четверг, 28.01.2021, 16:59 | Сообщение № 20
Группа: Админы
Ранг: Местный житель
Сообщений: 13869
Репутация: 2315 ±
Замечаний: ±

Excel 2010
Так конечно тупить будет, но в имени пересчитывается не лям раз, а один


Яндекс-деньги:41001419691823 | WMR:126292472390
 
Ответить
СообщениеТак конечно тупить будет, но в имени пересчитывается не лям раз, а один

Автор - Serge_007
Дата добавления - 28.01.2021 в 16:59
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Меняется формула при перетаскивании ячеек (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования Jobsora jooble
© 2010-2021 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!