Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Извлечь данные с определенным шагом - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Извлечь данные с определенным шагом (Формулы/Formulas)
Извлечь данные с определенным шагом
Leojse Дата: Четверг, 28.01.2021, 17:59 | Сообщение № 1
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 148
Репутация: 1 ±
Замечаний: 0% ±

2010/2013
Добрый вечер, уважаемые форумчане!
Подскажите, пожалуйста, как можно решить следующую задачу.
Есть столбцы (в примере A, D, G, J).
Хотелось бы, чтобы можно было формулой извлекать данные (в примере нужный результат выделен желтой заливкой). Шаг всегда один и тот же.
К сообщению приложен файл: _n.xls(26.0 Kb)
 
Ответить
СообщениеДобрый вечер, уважаемые форумчане!
Подскажите, пожалуйста, как можно решить следующую задачу.
Есть столбцы (в примере A, D, G, J).
Хотелось бы, чтобы можно было формулой извлекать данные (в примере нужный результат выделен желтой заливкой). Шаг всегда один и тот же.

Автор - Leojse
Дата добавления - 28.01.2021 в 17:59
Serge_007 Дата: Четверг, 28.01.2021, 18:04 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 15428
Репутация: 2539 ±
Замечаний: ±

Excel 2016
Здравствуйте

Код
=ИНДЕКС($A$2:$J$4;СТРОКА()-1;((СТОЛБЕЦ()-12)*3)-2)


ЮMoney:41001419691823 | WMR:126292472390
 
Ответить
СообщениеЗдравствуйте

Код
=ИНДЕКС($A$2:$J$4;СТРОКА()-1;((СТОЛБЕЦ()-12)*3)-2)

Автор - Serge_007
Дата добавления - 28.01.2021 в 18:04
Leojse Дата: Четверг, 28.01.2021, 18:12 | Сообщение № 3
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 148
Репутация: 1 ±
Замечаний: 0% ±

2010/2013
Serge_007, огромное Вам спасибо!
 
Ответить
СообщениеSerge_007, огромное Вам спасибо!

Автор - Leojse
Дата добавления - 28.01.2021 в 18:12
jakim Дата: Суббота, 30.01.2021, 11:40 | Сообщение № 4
Группа: Друзья
Ранг: Старожил
Сообщений: 1116
Репутация: 295 ±
Замечаний: 0% ±

Excel 2010
Ещё одна формула

Код
=INDEX($A$1:$J$4;ROWS($1:1);3*COLUMNS($M:M)-2)
 
Ответить
Сообщение
Ещё одна формула

Код
=INDEX($A$1:$J$4;ROWS($1:1);3*COLUMNS($M:M)-2)

Автор - jakim
Дата добавления - 30.01.2021 в 11:40
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Извлечь данные с определенным шагом (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2022 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!