Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/ЕСЛИ с вычислением значения из дат - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » ЕСЛИ с вычислением значения из дат (Формулы/Formulas)
ЕСЛИ с вычислением значения из дат
gorbachevk Дата: Четверг, 04.02.2021, 13:11 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 7
Репутация: 0 ±
Замечаний: 0% ±

Коллеги,
Задача - есть заказы, размещенные и находящиеся в пути в магазин. Столбец с датами соответственно.
Заказ отменяется на 6й день хранения в магазине (включая день прихода). Сколько заказов будет уже отменено завтра или любую конкретную дату в будущем?
Хотел сделать через ЕСЛИ с подстановкой вычисления значения из вычитания дат, чтобы иметь в соседнем столбце статус ОТМЕНА или АКТИВЕН.
Код
=ЕСЛИ((((ДАТА(2021,02,10)-A3)>6);"ОТМЕНА";"АКТИВЕН")
где A3 первая ячейка из столбца с датой прихода в магазин, а дата стоит например 10.02.2021

В чем ошибаюсь или это в принципе не возможно?
К сообщению приложен файл: 0391827.xlsx(31.1 Kb)


Сообщение отредактировал gorbachevk - Четверг, 04.02.2021, 14:20
 
Ответить
СообщениеКоллеги,
Задача - есть заказы, размещенные и находящиеся в пути в магазин. Столбец с датами соответственно.
Заказ отменяется на 6й день хранения в магазине (включая день прихода). Сколько заказов будет уже отменено завтра или любую конкретную дату в будущем?
Хотел сделать через ЕСЛИ с подстановкой вычисления значения из вычитания дат, чтобы иметь в соседнем столбце статус ОТМЕНА или АКТИВЕН.
Код
=ЕСЛИ((((ДАТА(2021,02,10)-A3)>6);"ОТМЕНА";"АКТИВЕН")
где A3 первая ячейка из столбца с датой прихода в магазин, а дата стоит например 10.02.2021

В чем ошибаюсь или это в принципе не возможно?

Автор - gorbachevk
Дата добавления - 04.02.2021 в 13:11
Serge_007 Дата: Четверг, 04.02.2021, 13:24 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 13701
Репутация: 2299 ±
Замечаний: ±

Excel 2010
gorbachevk, Здравствуйте

В чем ошибаюсь..?
В том что игнорируете правила форума


Яндекс-деньги:41001419691823 | WMR:126292472390
 
Ответить
Сообщениеgorbachevk, Здравствуйте

В чем ошибаюсь..?
В том что игнорируете правила форума

Автор - Serge_007
Дата добавления - 04.02.2021 в 13:24
gorbachevk Дата: Четверг, 04.02.2021, 13:30 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 7
Репутация: 0 ±
Замечаний: 0% ±

В том что игнорируете правила форума

Поясните новому человеку, будьте добры
 
Ответить
Сообщение
В том что игнорируете правила форума

Поясните новому человеку, будьте добры

Автор - gorbachevk
Дата добавления - 04.02.2021 в 13:30
Pelena Дата: Четверг, 04.02.2021, 13:33 | Сообщение № 4
Группа: Админы
Ранг: Местный житель
Сообщений: 17222
Репутация: 3751 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
gorbachevk, формулу заключите в теги. В режиме правки поста выделите формулу и нажмите кнопку fx на панели инструментов, сохраните изменения.
И файл приложите, а не картинку


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
Сообщениеgorbachevk, формулу заключите в теги. В режиме правки поста выделите формулу и нажмите кнопку fx на панели инструментов, сохраните изменения.
И файл приложите, а не картинку

Автор - Pelena
Дата добавления - 04.02.2021 в 13:33
Serge_007 Дата: Четверг, 04.02.2021, 14:02 | Сообщение № 5
Группа: Админы
Ранг: Местный житель
Сообщений: 13701
Репутация: 2299 ±
Замечаний: ±

Excel 2010
Поясните новому человеку
Пояснить что?
Новый человек должен первым делом правила прочитать, там все пояснения есть


Яндекс-деньги:41001419691823 | WMR:126292472390
 
Ответить
Сообщение
Поясните новому человеку
Пояснить что?
Новый человек должен первым делом правила прочитать, там все пояснения есть

Автор - Serge_007
Дата добавления - 04.02.2021 в 14:02
gorbachevk Дата: Четверг, 04.02.2021, 14:09 | Сообщение № 6
Группа: Пользователи
Ранг: Прохожий
Сообщений: 7
Репутация: 0 ±
Замечаний: 0% ±

формулу заключите в теги. В режиме правки поста выделите формулу и нажмите кнопку fx на панели инструментов, сохраните изменения.
И файл приложите, а не картинку


Благодарю, поправил всё!


Сообщение отредактировал gorbachevk - Четверг, 04.02.2021, 14:12
 
Ответить
Сообщение
формулу заключите в теги. В режиме правки поста выделите формулу и нажмите кнопку fx на панели инструментов, сохраните изменения.
И файл приложите, а не картинку


Благодарю, поправил всё!

Автор - gorbachevk
Дата добавления - 04.02.2021 в 14:09
gorbachevk Дата: Четверг, 04.02.2021, 14:11 | Сообщение № 7
Группа: Пользователи
Ранг: Прохожий
Сообщений: 7
Репутация: 0 ±
Замечаний: 0% ±

Пояснить что?
Новый человек должен первым делом правила прочитать, там все пояснения есть

Благодарю за кооперацию
 
Ответить
Сообщение
Пояснить что?
Новый человек должен первым делом правила прочитать, там все пояснения есть

Благодарю за кооперацию

Автор - gorbachevk
Дата добавления - 04.02.2021 в 14:11
Pelena Дата: Четверг, 04.02.2021, 14:20 | Сообщение № 8
Группа: Админы
Ранг: Местный житель
Сообщений: 17222
Репутация: 3751 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
По теме: надо столбец со статусами или просто определить
Сколько заказов будет уже отменено завтра или любую конкретную дату в будущем?


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеПо теме: надо столбец со статусами или просто определить
Сколько заказов будет уже отменено завтра или любую конкретную дату в будущем?

Автор - Pelena
Дата добавления - 04.02.2021 в 14:20
gorbachevk Дата: Четверг, 04.02.2021, 14:21 | Сообщение № 9
Группа: Пользователи
Ранг: Прохожий
Сообщений: 7
Репутация: 0 ±
Замечаний: 0% ±

По теме: надо столбец со статусами или просто определить


Столбец, необходим для наглядности
 
Ответить
Сообщение
По теме: надо столбец со статусами или просто определить


Столбец, необходим для наглядности

Автор - gorbachevk
Дата добавления - 04.02.2021 в 14:21
Pelena Дата: Четверг, 04.02.2021, 14:31 | Сообщение № 10
Группа: Админы
Ранг: Местный житель
Сообщений: 17222
Репутация: 3751 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Как вариант
К сообщению приложен файл: 2510403.xlsx(9.9 Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеКак вариант

Автор - Pelena
Дата добавления - 04.02.2021 в 14:31
Serge_007 Дата: Четверг, 04.02.2021, 14:36 | Сообщение № 11
Группа: Админы
Ранг: Местный житель
Сообщений: 13701
Репутация: 2299 ±
Замечаний: ±

Excel 2010
Сколько заказов будет уже отменено завтра
Код
=ЕСЛИ((СЕГОДНЯ()+1-A3)>6;"ОТМЕНА";"АКТИВЕН")


Яндекс-деньги:41001419691823 | WMR:126292472390
 
Ответить
Сообщение
Сколько заказов будет уже отменено завтра
Код
=ЕСЛИ((СЕГОДНЯ()+1-A3)>6;"ОТМЕНА";"АКТИВЕН")

Автор - Serge_007
Дата добавления - 04.02.2021 в 14:36
gorbachevk Дата: Четверг, 04.02.2021, 14:45 | Сообщение № 12
Группа: Пользователи
Ранг: Прохожий
Сообщений: 7
Репутация: 0 ±
Замечаний: 0% ±

Как вариант

Благодарю!

Удалось таки без вынесения даты в отдельную ячейку.
Код
=ЕСЛИ(ДАТА(2021;2;10)<(A3+5);"АКТИВЕН";"ОТМЕНА")
 
Ответить
Сообщение
Как вариант

Благодарю!

Удалось таки без вынесения даты в отдельную ячейку.
Код
=ЕСЛИ(ДАТА(2021;2;10)<(A3+5);"АКТИВЕН";"ОТМЕНА")

Автор - gorbachevk
Дата добавления - 04.02.2021 в 14:45
Pelena Дата: Четверг, 04.02.2021, 14:46 | Сообщение № 13
Группа: Админы
Ранг: Местный житель
Сообщений: 17222
Репутация: 3751 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
В отдельной ячейке менять дату проще, на мой взгляд


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеВ отдельной ячейке менять дату проще, на мой взгляд

Автор - Pelena
Дата добавления - 04.02.2021 в 14:46
Serge_007 Дата: Четверг, 04.02.2021, 14:57 | Сообщение № 14
Группа: Админы
Ранг: Местный житель
Сообщений: 13701
Репутация: 2299 ±
Замечаний: ±

Excel 2010
Как вариант - задать имя с нужной датой и использовать это имя в формулах


Яндекс-деньги:41001419691823 | WMR:126292472390
 
Ответить
СообщениеКак вариант - задать имя с нужной датой и использовать это имя в формулах

Автор - Serge_007
Дата добавления - 04.02.2021 в 14:57
gorbachevk Дата: Четверг, 04.02.2021, 16:18 | Сообщение № 15
Группа: Пользователи
Ранг: Прохожий
Сообщений: 7
Репутация: 0 ±
Замечаний: 0% ±

Всем спасибо!
 
Ответить
СообщениеВсем спасибо!

Автор - gorbachevk
Дата добавления - 04.02.2021 в 16:18
Мир MS Excel » Вопросы и решения » Вопросы по Excel » ЕСЛИ с вычислением значения из дат (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования Jobsora jooble
© 2010-2021 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!