Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Поиск ближайшей даты к текущей по условию - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск ближайшей даты к текущей по условию (Формулы/Formulas)
Поиск ближайшей даты к текущей по условию
Василий7439 Дата: Четверг, 11.02.2021, 20:26 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Прошу подсказать, есть расписание с датами и предметами. Как сделать выборку даты ближайшего предмета Алгебры, Истории, Биологии. Во вложении пример задачки. Заранее спасибо.
К сообщению приложен файл: 0807421.xlsx(9.3 Kb)
 
Ответить
СообщениеПрошу подсказать, есть расписание с датами и предметами. Как сделать выборку даты ближайшего предмета Алгебры, Истории, Биологии. Во вложении пример задачки. Заранее спасибо.

Автор - Василий7439
Дата добавления - 11.02.2021 в 20:26
Василий7439 Дата: Четверг, 11.02.2021, 20:38 | Сообщение № 2
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Решил задачку самостоятельно. Прикладываю код и пример.

Код
=МИН(ЕСЛИ((A2:A9="Алгебра")*(B2:B9>=СЕГОДНЯ());B2:B9))
К сообщению приложен файл: 4908441.xlsx(10.4 Kb)
 
Ответить
СообщениеРешил задачку самостоятельно. Прикладываю код и пример.

Код
=МИН(ЕСЛИ((A2:A9="Алгебра")*(B2:B9>=СЕГОДНЯ());B2:B9))

Автор - Василий7439
Дата добавления - 11.02.2021 в 20:38
Василий7439 Дата: Четверг, 11.02.2021, 20:51 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Подскажите, как в моем примере сделать так чтобы, если будущих дат в расписании нет, то в ячейке отображалось "Нет даты".
Я попробовал
Код
=ЕСЛИОШИБКА(МИН(ЕСЛИ((A2:A9="Алгебра")*(B2:B9>=СЕГОДНЯ());B2:B9));"Нет даты")

Но при отсутствии даты выдает 00.01.1900
Спасибо.


Сообщение отредактировал Василий7439 - Четверг, 11.02.2021, 20:54
 
Ответить
СообщениеПодскажите, как в моем примере сделать так чтобы, если будущих дат в расписании нет, то в ячейке отображалось "Нет даты".
Я попробовал
Код
=ЕСЛИОШИБКА(МИН(ЕСЛИ((A2:A9="Алгебра")*(B2:B9>=СЕГОДНЯ());B2:B9));"Нет даты")

Но при отсутствии даты выдает 00.01.1900
Спасибо.

Автор - Василий7439
Дата добавления - 11.02.2021 в 20:51
Василий7439 Дата: Четверг, 11.02.2021, 20:59 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Если вдруг кому пригодится.

Код
=ЕСЛИ(МИН(ЕСЛИ((A2:A9="Алгебра")*(B2:B9>=СЕГОДНЯ());B2:B9))=0;"Нет данных";МИН(ЕСЛИ((A2:A9="Алгебра")*(B2:B9>=СЕГОДНЯ());B2:B9)))
 
Ответить
СообщениеЕсли вдруг кому пригодится.

Код
=ЕСЛИ(МИН(ЕСЛИ((A2:A9="Алгебра")*(B2:B9>=СЕГОДНЯ());B2:B9))=0;"Нет данных";МИН(ЕСЛИ((A2:A9="Алгебра")*(B2:B9>=СЕГОДНЯ());B2:B9)))

Автор - Василий7439
Дата добавления - 11.02.2021 в 20:59
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск ближайшей даты к текущей по условию (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования Jobsora jooble
© 2010-2021 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!