Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Подсчет кол-ва ячеек, соответствующих условию, со сравнением - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подсчет кол-ва ячеек, соответствующих условию, со сравнением (Формулы/Formulas)
Подсчет кол-ва ячеек, соответствующих условию, со сравнением
Letterbomb Дата: Пятница, 12.02.2021, 10:58 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 19
Репутация: 0 ±
Замечаний: 0% ±

Здравствуйте!

Помогите, пожалуйста, составить формулу.

Необходимо подсчитать количество ячеек в диапазоне одной строки, которые больше 0, но с условием, если аналогичная ячейка в соседней строке отлична от 0, то соответствующая ячейка строки, в которой ведется подсчет, также учитывается.



В примере нужно подсчитать ячейки в строке 3, которые больше 0 + условие по сравнению если в строке 2 значение не 0 у соответствующей ячейки - это ячейки B2 и G2. Итоговым результатом должно являться 5. То есть 3 ячейки больше 0 + 2 ячейки равные 0, но у которых у аналогичной в строке 2 значения больше 0.
К сообщению приложен файл: 6933024.xlsx(7.5 Kb)
 
Ответить
СообщениеЗдравствуйте!

Помогите, пожалуйста, составить формулу.

Необходимо подсчитать количество ячеек в диапазоне одной строки, которые больше 0, но с условием, если аналогичная ячейка в соседней строке отлична от 0, то соответствующая ячейка строки, в которой ведется подсчет, также учитывается.



В примере нужно подсчитать ячейки в строке 3, которые больше 0 + условие по сравнению если в строке 2 значение не 0 у соответствующей ячейки - это ячейки B2 и G2. Итоговым результатом должно являться 5. То есть 3 ячейки больше 0 + 2 ячейки равные 0, но у которых у аналогичной в строке 2 значения больше 0.

Автор - Letterbomb
Дата добавления - 12.02.2021 в 10:58
Nic70y Дата: Пятница, 12.02.2021, 11:11 | Сообщение № 2
Группа: Друзья
Ранг: Экселист
Сообщений: 6832
Репутация: 1567 ±
Замечаний: 0% ±

Excel 2010
Код
=СУММПРОИЗВ(--((A3:G3+A2:G2)>0))


ЮMoney(Яндекс Деньги) 41001841029809
 
Ответить
Сообщение
Код
=СУММПРОИЗВ(--((A3:G3+A2:G2)>0))

Автор - Nic70y
Дата добавления - 12.02.2021 в 11:11
Letterbomb Дата: Пятница, 12.02.2021, 12:04 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 19
Репутация: 0 ±
Замечаний: 0% ±

=СУММПРОИЗВ(--((A3:G3+A2:G2)>0))


Благодарю Вас! Это то, что нужно!
 
Ответить
Сообщение
=СУММПРОИЗВ(--((A3:G3+A2:G2)>0))


Благодарю Вас! Это то, что нужно!

Автор - Letterbomb
Дата добавления - 12.02.2021 в 12:04
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подсчет кол-ва ячеек, соответствующих условию, со сравнением (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования Jobsora jooble
© 2010-2021 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!