Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Сумма определенного количества значений с учетом пустот - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сумма определенного количества значений с учетом пустот (Формулы/Formulas)
Сумма определенного количества значений с учетом пустот
Allexiss Дата: Суббота, 13.02.2021, 06:56 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Добрый день!
Помогите, пожалуйста с проблемой. Есть перечень значений параметра. И есть частота получения значений параметра в разных случаях. Как можно формулой задать суммирование определенного количества частот с нужного значения параметра? Чтобы пустые значения при этом пропускались. Например, подсчет трех частот от значения 1389,5 в первом случае должно дать 1+100+142, во втором случае 1959+1229+264, в третьем 188+26+10. Спасибо за помощь!
К сообщению приложен файл: __.xls(27.0 Kb)
 
Ответить
СообщениеДобрый день!
Помогите, пожалуйста с проблемой. Есть перечень значений параметра. И есть частота получения значений параметра в разных случаях. Как можно формулой задать суммирование определенного количества частот с нужного значения параметра? Чтобы пустые значения при этом пропускались. Например, подсчет трех частот от значения 1389,5 в первом случае должно дать 1+100+142, во втором случае 1959+1229+264, в третьем 188+26+10. Спасибо за помощь!

Автор - Allexiss
Дата добавления - 13.02.2021 в 06:56
Nic70y Дата: Суббота, 13.02.2021, 08:22 | Сообщение № 2
Группа: Друзья
Ранг: Экселист
Сообщений: 6750
Репутация: 1539 ±
Замечаний: 0% ±

Excel 2010
формула массива
Код
=СУММ(ИНДЕКС(B$2:B$18;ПОИСКПОЗ($E$2;$A$2:$A$18;)):ИНДЕКС(B$1:B$18;НАИМЕНЬШИЙ(ЕСЛИ(ИНДЕКС(B$2:B$18;ПОИСКПОЗ($E$2;$A$2:$A$18;)):B$18<>"";СТРОКА(ИНДЕКС(B$2:B$18;ПОИСКПОЗ($E2;$A$2:$A$18;)):B$18));3)))
где $E$2=1389,5
К сообщению приложен файл: 96.xls(27.5 Kb)


ЮMoney(Яндекс Деньги) 41001841029809
 
Ответить
Сообщениеформула массива
Код
=СУММ(ИНДЕКС(B$2:B$18;ПОИСКПОЗ($E$2;$A$2:$A$18;)):ИНДЕКС(B$1:B$18;НАИМЕНЬШИЙ(ЕСЛИ(ИНДЕКС(B$2:B$18;ПОИСКПОЗ($E$2;$A$2:$A$18;)):B$18<>"";СТРОКА(ИНДЕКС(B$2:B$18;ПОИСКПОЗ($E2;$A$2:$A$18;)):B$18));3)))
где $E$2=1389,5

Автор - Nic70y
Дата добавления - 13.02.2021 в 08:22
Allexiss Дата: Суббота, 13.02.2021, 08:28 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Nic70y, Все работает. Огромное спасибо!!!
 
Ответить
СообщениеNic70y, Все работает. Огромное спасибо!!!

Автор - Allexiss
Дата добавления - 13.02.2021 в 08:28
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сумма определенного количества значений с учетом пустот (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования Jobsora jooble
© 2010-2021 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!