Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Замена знака на числовое значение ячейки - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Замена знака на числовое значение ячейки (Формулы/Formulas)
Замена знака на числовое значение ячейки
Paha3250 Дата: Воскресенье, 14.02.2021, 10:28 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Помогите со способом решения данной задачи. Нужно составить таблицу по питанию школьников, преподаватель будет ставить значек "+" напротив фамилии ребенка, если он питался, и excel должен посчитать этот плюс как значение сверху ячейки для определения суммы. Какие есть способы решения?
К сообщению приложен файл: 9229087.xlsx(8.3 Kb)
 
Ответить
СообщениеПомогите со способом решения данной задачи. Нужно составить таблицу по питанию школьников, преподаватель будет ставить значек "+" напротив фамилии ребенка, если он питался, и excel должен посчитать этот плюс как значение сверху ячейки для определения суммы. Какие есть способы решения?

Автор - Paha3250
Дата добавления - 14.02.2021 в 10:28
jakim Дата: Воскресенье, 14.02.2021, 10:34 | Сообщение № 2
Группа: Друзья
Ранг: Ветеран
Сообщений: 988
Репутация: 268 ±
Замечаний: 0% ±

Excel 2010
Формула

Код
=COUNTA(B2:D2)
 
Ответить
Сообщение
Формула

Код
=COUNTA(B2:D2)

Автор - jakim
Дата добавления - 14.02.2021 в 10:34
Paha3250 Дата: Воскресенье, 14.02.2021, 10:38 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

jakim, Мне нужно посчитать не колличество знаков, а сумму. Каждому "+" соответствует число сверху.


Сообщение отредактировал Paha3250 - Воскресенье, 14.02.2021, 10:38
 
Ответить
Сообщениеjakim, Мне нужно посчитать не колличество знаков, а сумму. Каждому "+" соответствует число сверху.

Автор - Paha3250
Дата добавления - 14.02.2021 в 10:38
прохожий2019 Дата: Воскресенье, 14.02.2021, 11:22 | Сообщение № 4
Группа: Проверенные
Ранг: Обитатель
Сообщений: 430
Репутация: 76 ±
Замечаний: 0% ±

365 Beta Channel
Код
=СУММЕСЛИ(B2:D2;"+";$B$1:$D$1)
К сообщению приложен файл: 3652477.xlsx(9.1 Kb)
 
Ответить
Сообщение
Код
=СУММЕСЛИ(B2:D2;"+";$B$1:$D$1)

Автор - прохожий2019
Дата добавления - 14.02.2021 в 11:22
jakim Дата: Воскресенье, 14.02.2021, 12:08 | Сообщение № 5
Группа: Друзья
Ранг: Ветеран
Сообщений: 988
Репутация: 268 ±
Замечаний: 0% ±

Excel 2010
Тогда такая формула

Код
=SUMPRODUCT((B2:D2="+")*B$1:D$1)
 
Ответить
Сообщение
Тогда такая формула

Код
=SUMPRODUCT((B2:D2="+")*B$1:D$1)

Автор - jakim
Дата добавления - 14.02.2021 в 12:08
Paha3250 Дата: Воскресенье, 14.02.2021, 16:46 | Сообщение № 6
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

прохожий2019, Спасибо огромное. То что надо!
 
Ответить
Сообщениепрохожий2019, Спасибо огромное. То что надо!

Автор - Paha3250
Дата добавления - 14.02.2021 в 16:46
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Замена знака на числовое значение ячейки (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования Jobsora jooble
© 2010-2021 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!