Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Поиск наиболее повторяющего текстового значения - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск наиболее повторяющего текстового значения (Формулы/Formulas)
Поиск наиболее повторяющего текстового значения
spaborly Дата: Воскресенье, 21.02.2021, 17:46 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 9
Репутация: 0 ±
Замечаний: 0% ±

Здравствуйте. Необходимо найти самую частую причину увольнения. Проблема в том, что там есть пустые значения. (их убрать нельзя) Я понимаю, как искать, когда нет пустых ячеек, по формуле:
=ИНДЕКС(Данные!А3:А1691;ПОИСКПОЗ(МАКС(СЧЁТЕСЛИ(Данные!А3:А1691;Данные!А3:А1691));СЧЁТЕСЛИ(Данные!А3:А1691;Данные!А3:А1691);0))
А вот данной ситуации затрудняюсь. Не подскажите, что нужно добавить в формуле?
К сообщению приложен файл: 111.xlsx(20.3 Kb)
 
Ответить
СообщениеЗдравствуйте. Необходимо найти самую частую причину увольнения. Проблема в том, что там есть пустые значения. (их убрать нельзя) Я понимаю, как искать, когда нет пустых ячеек, по формуле:
=ИНДЕКС(Данные!А3:А1691;ПОИСКПОЗ(МАКС(СЧЁТЕСЛИ(Данные!А3:А1691;Данные!А3:А1691));СЧЁТЕСЛИ(Данные!А3:А1691;Данные!А3:А1691);0))
А вот данной ситуации затрудняюсь. Не подскажите, что нужно добавить в формуле?

Автор - spaborly
Дата добавления - 21.02.2021 в 17:46
jakim Дата: Воскресенье, 21.02.2021, 18:24 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 1008
Репутация: 274 ±
Замечаний: 0% ±

Excel 2010
Формула

Код
=INDEX(A3:A2000;AGGREGATE(15;6;ROW($1:$10000)/(AGGREGATE(14;6;COUNTIF($A$3:$A$2000;$A$3:$A$2000)/(A3:A2000<>"");1)=COUNTIF($A$3:$A$2000;$A$3:$A$2000))/(A3:A2000<>"");1))
К сообщению приложен файл: 111-1.xlsx(20.7 Kb)
 
Ответить
Сообщение
Формула

Код
=INDEX(A3:A2000;AGGREGATE(15;6;ROW($1:$10000)/(AGGREGATE(14;6;COUNTIF($A$3:$A$2000;$A$3:$A$2000)/(A3:A2000<>"");1)=COUNTIF($A$3:$A$2000;$A$3:$A$2000))/(A3:A2000<>"");1))

Автор - jakim
Дата добавления - 21.02.2021 в 18:24
Egyptian Дата: Воскресенье, 21.02.2021, 18:33 | Сообщение № 3
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 116
Репутация: 42 ±
Замечаний: 0% ±

Excel 2013/2016
spaborly,
Ваша дополненная формула.
Код
=INDEX($A$3:$A$1691,MATCH(MAX(COUNTIF($A$3:$A$1691,$A$3:$A$1691)*($A$3:$A$1691<>"")),COUNTIF($A$3:$A$1691,$A$3:$A$1691),0))
К сообщению приложен файл: 8166917.xlsx(20.8 Kb)
 
Ответить
Сообщениеspaborly,
Ваша дополненная формула.
Код
=INDEX($A$3:$A$1691,MATCH(MAX(COUNTIF($A$3:$A$1691,$A$3:$A$1691)*($A$3:$A$1691<>"")),COUNTIF($A$3:$A$1691,$A$3:$A$1691),0))

Автор - Egyptian
Дата добавления - 21.02.2021 в 18:33
Pelena Дата: Воскресенье, 21.02.2021, 18:35 | Сообщение № 4
Группа: Админы
Ранг: Местный житель
Сообщений: 17631
Репутация: 3926 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
spaborly, оформите формулу тегами с помощью кнопки fx в режиме правки поста


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
Сообщениеspaborly, оформите формулу тегами с помощью кнопки fx в режиме правки поста

Автор - Pelena
Дата добавления - 21.02.2021 в 18:35
spaborly Дата: Воскресенье, 21.02.2021, 19:12 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 9
Репутация: 0 ±
Замечаний: 0% ±

Egyptian, jakim, Pelena, Спасибо!


Сообщение отредактировал spaborly - Воскресенье, 21.02.2021, 19:14
 
Ответить
СообщениеEgyptian, jakim, Pelena, Спасибо!

Автор - spaborly
Дата добавления - 21.02.2021 в 19:12
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск наиболее повторяющего текстового значения (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования Jobsora jooble
© 2010-2021 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!