Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Сложение чётных и нечётных строк в зависимости от даты - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сложение чётных и нечётных строк в зависимости от даты (Формулы/Formulas)
Сложение чётных и нечётных строк в зависимости от даты
DrMini Дата: Суббота, 27.02.2021, 07:41 | Сообщение № 1
Группа: Проверенные
Ранг: Ветеран
Сообщений: 606
Репутация: 17 ±
Замечаний: 0% ±

Excel 2010, 2013, 2019 RUS
Доброго времени суток форумчане и гости форума.
Нужно сложить из колонки «Итоги за день» D2:D38 через одну строку (Километры отдельно. Литры отдельно) и разнести в таблицу в зависимости от месяца.
Через строку считает формула для километров:
Код
=СУММПРОИЗВ(--(ОСТАТ(СТРОКА($D:$D);2)=0);$D:$D)

для литров:
Код
=СУММПРОИЗВ(--(ОСТАТ(СТРОКА($D:$D);2)=1);$D:$D)

В зависимости от даты в таблицу по месяцам разносил формулой (пример для января):
Код
=СУММПРОИЗВ((МЕСЯЦ($A$2:$A$38)=МЕСЯЦ($G$1))*($D$2:$D$38))

До объединения ячеек (для лучшей визуализации) в столбце A всё распределялось по месяцам.
Помогите пожалуйста объединить эти формулы (моих знаний не хватает).
Если, что непонятно объяснил (заранее прошу прощения) поясню дополнительно.
Файл прикрепил.
К сообщению приложен файл: Test04.xlsx(12.3 Kb)
 
Ответить
СообщениеДоброго времени суток форумчане и гости форума.
Нужно сложить из колонки «Итоги за день» D2:D38 через одну строку (Километры отдельно. Литры отдельно) и разнести в таблицу в зависимости от месяца.
Через строку считает формула для километров:
Код
=СУММПРОИЗВ(--(ОСТАТ(СТРОКА($D:$D);2)=0);$D:$D)

для литров:
Код
=СУММПРОИЗВ(--(ОСТАТ(СТРОКА($D:$D);2)=1);$D:$D)

В зависимости от даты в таблицу по месяцам разносил формулой (пример для января):
Код
=СУММПРОИЗВ((МЕСЯЦ($A$2:$A$38)=МЕСЯЦ($G$1))*($D$2:$D$38))

До объединения ячеек (для лучшей визуализации) в столбце A всё распределялось по месяцам.
Помогите пожалуйста объединить эти формулы (моих знаний не хватает).
Если, что непонятно объяснил (заранее прошу прощения) поясню дополнительно.
Файл прикрепил.

Автор - DrMini
Дата добавления - 27.02.2021 в 07:41
bmv98rus Дата: Суббота, 27.02.2021, 08:39 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3464
Репутация: 602 ±
Замечаний: 0% ±

Excel 2013/2016
DrMini,
1. для массивных функций -вред, хотя потом исправились.
2.
для лучшей визуализации
- это тоже вред
3
Код
=SUMPRODUCT((MONTH($A$2:$A$38)=MONTH(G$1))*($D$2:$D$38)*(MOD(ROW($D$2:$D$38);2)=0))
и
Код
=SUMPRODUCT((MONTH($A$2:$A$38)=MONTH(G$1))*($D$3:$D$39)*(MOD(ROW($D$2:$D$38);2)=0))


Замечательный Временно просто медведь , процентов на 20.
 
Ответить
СообщениеDrMini,
1. для массивных функций -вред, хотя потом исправились.
2.
для лучшей визуализации
- это тоже вред
3
Код
=SUMPRODUCT((MONTH($A$2:$A$38)=MONTH(G$1))*($D$2:$D$38)*(MOD(ROW($D$2:$D$38);2)=0))
и
Код
=SUMPRODUCT((MONTH($A$2:$A$38)=MONTH(G$1))*($D$3:$D$39)*(MOD(ROW($D$2:$D$38);2)=0))

Автор - bmv98rus
Дата добавления - 27.02.2021 в 08:39
Pelena Дата: Суббота, 27.02.2021, 08:51 | Сообщение № 3
Группа: Админы
Ранг: Местный житель
Сообщений: 17499
Репутация: 3886 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
можно попробовать без проверки на чётность.
Формулы для км и л немного разные, но их можно копировать вправо обе сразу
Код
=СУММПРОИЗВ((ТЕКСТ($A$2:$A$38;"ММГГ")=ТЕКСТ(ПРОСМОТР(9^9;$G$1:G$1);"ММГГ"))*($D$2:$D$38))

вот это МЕСЯЦ($A$2:$A$38)=МЕСЯЦ(G$1) неудачный вариант, т.к. в январе для пустых ячеек будет тоже ИСТИНА
К сообщению приложен файл: 9828898.xlsx(13.0 Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
Сообщениеможно попробовать без проверки на чётность.
Формулы для км и л немного разные, но их можно копировать вправо обе сразу
Код
=СУММПРОИЗВ((ТЕКСТ($A$2:$A$38;"ММГГ")=ТЕКСТ(ПРОСМОТР(9^9;$G$1:G$1);"ММГГ"))*($D$2:$D$38))

вот это МЕСЯЦ($A$2:$A$38)=МЕСЯЦ(G$1) неудачный вариант, т.к. в январе для пустых ячеек будет тоже ИСТИНА

Автор - Pelena
Дата добавления - 27.02.2021 в 08:51
DrMini Дата: Суббота, 27.02.2021, 08:52 | Сообщение № 4
Группа: Проверенные
Ранг: Ветеран
Сообщений: 606
Репутация: 17 ±
Замечаний: 0% ±

Excel 2010, 2013, 2019 RUS
Михаил БОЛЬШОЕ СПАСИБО. Всё работает.
- это тоже вред

Да. Знаю, но лучше ничего для данной задачи ничего не придумал.


Сообщение отредактировал DrMini - Суббота, 27.02.2021, 08:53
 
Ответить
СообщениеМихаил БОЛЬШОЕ СПАСИБО. Всё работает.
- это тоже вред

Да. Знаю, но лучше ничего для данной задачи ничего не придумал.

Автор - DrMini
Дата добавления - 27.02.2021 в 08:52
DrMini Дата: Суббота, 27.02.2021, 08:59 | Сообщение № 5
Группа: Проверенные
Ранг: Ветеран
Сообщений: 606
Репутация: 17 ±
Замечаний: 0% ±

Excel 2010, 2013, 2019 RUS
можно попробовать без проверки на чётность.

Елена и Вам БОЛЬШОЕ СПАСИБО. Всё работает.
 
Ответить
Сообщение
можно попробовать без проверки на чётность.

Елена и Вам БОЛЬШОЕ СПАСИБО. Всё работает.

Автор - DrMini
Дата добавления - 27.02.2021 в 08:59
Nic70y Дата: Суббота, 27.02.2021, 12:57 | Сообщение № 6
Группа: Друзья
Ранг: Экселист
Сообщений: 6842
Репутация: 1571 ±
Замечаний: 0% ±

Excel 2010
Код
=СУММЕСЛИМН($D2:$D39;$A2:$A39;">="&G1;$A2:$A39;"<="&КОНМЕСЯЦА(G1;0))
Код
=СУММЕСЛИМН($D3:$D40;$A2:$A39;">="&G1;$A2:$A39;"<="&КОНМЕСЯЦА(G1;0))
К сообщению приложен файл: 27.xlsx(12.9 Kb)


ЮMoney(Яндекс Деньги) 41001841029809
 
Ответить
Сообщение
Код
=СУММЕСЛИМН($D2:$D39;$A2:$A39;">="&G1;$A2:$A39;"<="&КОНМЕСЯЦА(G1;0))
Код
=СУММЕСЛИМН($D3:$D40;$A2:$A39;">="&G1;$A2:$A39;"<="&КОНМЕСЯЦА(G1;0))

Автор - Nic70y
Дата добавления - 27.02.2021 в 12:57
DrMini Дата: Суббота, 27.02.2021, 14:15 | Сообщение № 7
Группа: Проверенные
Ранг: Ветеран
Сообщений: 606
Репутация: 17 ±
Замечаний: 0% ±

Excel 2010, 2013, 2019 RUS
Nic70y,
Николай и Вам БОЛЬШОЕ СПАСИБО. Всё тоже работает.
[offtop]Всегда поражался в Excel возможности одну и ту же задачу решать различными способами.[/offtop]
 
Ответить
СообщениеNic70y,
Николай и Вам БОЛЬШОЕ СПАСИБО. Всё тоже работает.
[offtop]Всегда поражался в Excel возможности одну и ту же задачу решать различными способами.[/offtop]

Автор - DrMini
Дата добавления - 27.02.2021 в 14:15
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сложение чётных и нечётных строк в зависимости от даты (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования Jobsora jooble
© 2010-2021 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!