Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Мешает текст в таблице при расчете формулы СУММПРОИЗВ - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Мешает текст в таблице при расчете формулы СУММПРОИЗВ (Формулы/Formulas)
Мешает текст в таблице при расчете формулы СУММПРОИЗВ
Anis625 Дата: Понедельник, 01.03.2021, 16:52 | Сообщение № 1
Группа: Проверенные
Ранг: Ветеран
Сообщений: 518
Репутация: 27 ±
Замечаний: 0% ±

Excel 2013
Добрый день, всем участникам форума
Первый раз столкнулся с ситуацией в расчете формулы СУММПРОИЗВ (относительно недавно начал чаще применять, благодаря этому форуму):
При наличии в таблице текстовых значений результат формулы #ЗНАЧ. Если использовать формулу массива то такая ошибка не выходит. На одном из дружественных форумов нашел решение прикрутить функцию Ч (первый раз о ней узнал), но все равно не корректно выдает результат.
Буду признателен за подсказку как правильно подправить безмассивную мою формулу
К сообщению приложен файл: SUMMPRIZV.xlsx(10.2 Kb)
 
Ответить
СообщениеДобрый день, всем участникам форума
Первый раз столкнулся с ситуацией в расчете формулы СУММПРОИЗВ (относительно недавно начал чаще применять, благодаря этому форуму):
При наличии в таблице текстовых значений результат формулы #ЗНАЧ. Если использовать формулу массива то такая ошибка не выходит. На одном из дружественных форумов нашел решение прикрутить функцию Ч (первый раз о ней узнал), но все равно не корректно выдает результат.
Буду признателен за подсказку как правильно подправить безмассивную мою формулу

Автор - Anis625
Дата добавления - 01.03.2021 в 16:52
Nic70y Дата: Понедельник, 01.03.2021, 17:07 | Сообщение № 2
Группа: Друзья
Ранг: Экселист
Сообщений: 6832
Репутация: 1567 ±
Замечаний: 0% ±

Excel 2010
Код
=СУММПРОИЗВ(($A$3:$A$8=H11)*($B$1:$G$1=K$9)*($B$2:$G$2=K$10);$B$3:$G$8)


ЮMoney(Яндекс Деньги) 41001841029809
 
Ответить
Сообщение
Код
=СУММПРОИЗВ(($A$3:$A$8=H11)*($B$1:$G$1=K$9)*($B$2:$G$2=K$10);$B$3:$G$8)

Автор - Nic70y
Дата добавления - 01.03.2021 в 17:07
Anis625 Дата: Понедельник, 01.03.2021, 17:08 | Сообщение № 3
Группа: Проверенные
Ранг: Ветеран
Сообщений: 518
Репутация: 27 ±
Замечаний: 0% ±

Excel 2013
Nic70y,
Да лааааадно, и всё? Вот ведь. Спасибо Вам огромное!!!
 
Ответить
СообщениеNic70y,
Да лааааадно, и всё? Вот ведь. Спасибо Вам огромное!!!

Автор - Anis625
Дата добавления - 01.03.2021 в 17:08
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Мешает текст в таблице при расчете формулы СУММПРОИЗВ (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования Jobsora jooble
© 2010-2021 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!