Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Формула ориентированная на цвет клетки - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Формула ориентированная на цвет клетки (Формулы/Formulas)
Формула ориентированная на цвет клетки
dm74 Дата: Четверг, 04.03.2021, 13:24 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 15
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
Коллеги-светилы, у меня имеется очень серьёзный вопрос. Какая-то есть формула, которая может обнаружив цвет клетки повзаимодействовав с соседней клеткой посчитать значение в третьей клетке. Может я сейчас развожу туман! Более понятно станет когда откроете вложение Ух.xlsb.
К сообщению приложен файл: 1294533.xlsb(13.8 Kb)


Киряков
 
Ответить
СообщениеКоллеги-светилы, у меня имеется очень серьёзный вопрос. Какая-то есть формула, которая может обнаружив цвет клетки повзаимодействовав с соседней клеткой посчитать значение в третьей клетке. Может я сейчас развожу туман! Более понятно станет когда откроете вложение Ух.xlsb.

Автор - dm74
Дата добавления - 04.03.2021 в 13:24
Pelena Дата: Четверг, 04.03.2021, 13:53 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 17436
Репутация: 3873 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Используйте ту же СУММ_ЦВЕТ()
Код
=C106/(1+(СУММ_ЦВЕТ(B106;$B$110)<>0))+СЕГОДНЯ()*0


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеИспользуйте ту же СУММ_ЦВЕТ()
Код
=C106/(1+(СУММ_ЦВЕТ(B106;$B$110)<>0))+СЕГОДНЯ()*0

Автор - Pelena
Дата добавления - 04.03.2021 в 13:53
dm74 Дата: Четверг, 04.03.2021, 13:56 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 15
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
Вы молодчина!!! Можно сказать даже Гений!!!! :D hands


Киряков
 
Ответить
СообщениеВы молодчина!!! Можно сказать даже Гений!!!! :D hands

Автор - dm74
Дата добавления - 04.03.2021 в 13:56
dm74 Дата: Четверг, 04.03.2021, 14:14 | Сообщение № 4
Группа: Пользователи
Ранг: Новичок
Сообщений: 15
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
Можно еще одни вопрос уважаемый(ая) Pelena. Он во вложении.
К сообщению приложен файл: 0303345.xlsb(13.7 Kb)


Киряков
 
Ответить
СообщениеМожно еще одни вопрос уважаемый(ая) Pelena. Он во вложении.

Автор - dm74
Дата добавления - 04.03.2021 в 14:14
Pelena Дата: Четверг, 04.03.2021, 14:24 | Сообщение № 5
Группа: Админы
Ранг: Местный житель
Сообщений: 17436
Репутация: 3873 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Код
=СУММ(C106:D106)/(1+(СУММ_ЦВЕТ(B106;$B$108)<>0))+СЕГОДНЯ()*0


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
Сообщение
Код
=СУММ(C106:D106)/(1+(СУММ_ЦВЕТ(B106;$B$108)<>0))+СЕГОДНЯ()*0

Автор - Pelena
Дата добавления - 04.03.2021 в 14:24
dm74 Дата: Суббота, 06.03.2021, 08:38 | Сообщение № 6
Группа: Пользователи
Ранг: Новичок
Сообщений: 15
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
Что-то не работает ;)
К сообщению приложен файл: 9549161.png(46.3 Kb)


Киряков
 
Ответить
СообщениеЧто-то не работает ;)

Автор - dm74
Дата добавления - 06.03.2021 в 08:38
Pelena Дата: Суббота, 06.03.2021, 08:59 | Сообщение № 7
Группа: Админы
Ранг: Местный житель
Сообщений: 17436
Репутация: 3873 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Что именно не работает?
Значок @ уберите
К сообщению приложен файл: 8346055.xlsb(13.7 Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеЧто именно не работает?
Значок @ уберите

Автор - Pelena
Дата добавления - 06.03.2021 в 08:59
dm74 Дата: Суббота, 06.03.2021, 12:34 | Сообщение № 8
Группа: Пользователи
Ранг: Новичок
Сообщений: 15
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
Великодушная Pelena, после вышей рекомендации конечно же формула стала работать. Но задача, которую я себе поставил все-равно не решается. Свой вопрос я озвучил в строке KF5. Можно ли его решить??? %)


Киряков
 
Ответить
СообщениеВеликодушная Pelena, после вышей рекомендации конечно же формула стала работать. Но задача, которую я себе поставил все-равно не решается. Свой вопрос я озвучил в строке KF5. Можно ли его решить??? %)

Автор - dm74
Дата добавления - 06.03.2021 в 12:34
Pelena Дата: Суббота, 06.03.2021, 13:30 | Сообщение № 9
Группа: Админы
Ранг: Местный житель
Сообщений: 17436
Репутация: 3873 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
в строке KF5
это в каком файле?


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
Сообщение
в строке KF5
это в каком файле?

Автор - Pelena
Дата добавления - 06.03.2021 в 13:30
dm74 Дата: Суббота, 06.03.2021, 14:00 | Сообщение № 10
Группа: Пользователи
Ранг: Новичок
Сообщений: 15
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
Вот он.
К сообщению приложен файл: 9258580.xlsb(17.0 Kb)


Киряков
 
Ответить
СообщениеВот он.

Автор - dm74
Дата добавления - 06.03.2021 в 14:00
Pelena Дата: Суббота, 06.03.2021, 15:59 | Сообщение № 11
Группа: Админы
Ранг: Местный житель
Сообщений: 17436
Репутация: 3873 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Именно событие окрашивания ячейки отследить не получится. Всё равно либо после окрашивания надо пересчитать лист (F9), либо ввести/изменить числовые данные.
А в остальном формула аналогичная предыдущим


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеИменно событие окрашивания ячейки отследить не получится. Всё равно либо после окрашивания надо пересчитать лист (F9), либо ввести/изменить числовые данные.
А в остальном формула аналогичная предыдущим

Автор - Pelena
Дата добавления - 06.03.2021 в 15:59
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Формула ориентированная на цвет клетки (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования Jobsora jooble
© 2010-2021 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!