Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/если ячейка совпадает с частью строки то возврат соседних яч - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » если ячейка совпадает с частью строки то возврат соседних яч (Формулы/Formulas)
если ячейка совпадает с частью строки то возврат соседних яч
korenkovkrd Дата: Суббота, 06.03.2021, 20:23 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

если ячейка другого листа совпадает с частью строки А1 то возврат соседних ячеек из другого листа

Прилагаю пример как я это понимаю, я думаю что задействована команда соврад и
Код
=ПСТР(A1;3;14)
К сообщению приложен файл: 1045700.xlsx(21.7 Kb)
 
Ответить
Сообщениеесли ячейка другого листа совпадает с частью строки А1 то возврат соседних ячеек из другого листа

Прилагаю пример как я это понимаю, я думаю что задействована команда соврад и
Код
=ПСТР(A1;3;14)

Автор - korenkovkrd
Дата добавления - 06.03.2021 в 20:23
korenkovkrd Дата: Суббота, 06.03.2021, 20:51 | Сообщение № 2
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Код
=ВПР(ПСТР(A1;3;14);Названия!A:A;3;ЛОЖЬ)
вроде так но не работает...
 
Ответить
Сообщение
Код
=ВПР(ПСТР(A1;3;14);Названия!A:A;3;ЛОЖЬ)
вроде так но не работает...

Автор - korenkovkrd
Дата добавления - 06.03.2021 в 20:51
Kostya_Ye Дата: Суббота, 06.03.2021, 21:15 | Сообщение № 3
Группа: Проверенные
Ранг: Обитатель
Сообщений: 251
Репутация: 224 ±
Замечаний: 0% ±

Excel 2016
korenkovkrd, и вам здравствуйте.
Код
=ВПР(ПСТР(A1;3;14);Названия!$A$1:$D$3;3;0)

и формат ячеек - текстовый. поменяйте на общий или числовой.


Сообщение отредактировал Kostya_Ye - Суббота, 06.03.2021, 21:20
 
Ответить
Сообщениеkorenkovkrd, и вам здравствуйте.
Код
=ВПР(ПСТР(A1;3;14);Названия!$A$1:$D$3;3;0)

и формат ячеек - текстовый. поменяйте на общий или числовой.

Автор - Kostya_Ye
Дата добавления - 06.03.2021 в 21:15
korenkovkrd Дата: Суббота, 06.03.2021, 22:52 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

:D Здравствуйте. решил по другому немножко, вынес значения на тот же лист
Код
=ИНДЕКС(G:G;ПОИСКПОЗ(ПСТР(A35;3;14);F:F))
вроде бы всё хорошо, но есть место где даёт сбой, и понять не могу почему... при этом если удалить 6 строчек выше, начинает работать. но данные этих полей тоже нужны... непойму


Сообщение отредактировал korenkovkrd - Суббота, 06.03.2021, 22:53
 
Ответить
Сообщение:D Здравствуйте. решил по другому немножко, вынес значения на тот же лист
Код
=ИНДЕКС(G:G;ПОИСКПОЗ(ПСТР(A35;3;14);F:F))
вроде бы всё хорошо, но есть место где даёт сбой, и понять не могу почему... при этом если удалить 6 строчек выше, начинает работать. но данные этих полей тоже нужны... непойму

Автор - korenkovkrd
Дата добавления - 06.03.2021 в 22:52
gling Дата: Суббота, 06.03.2021, 23:12 | Сообщение № 5
Группа: Друзья
Ранг: Старожил
Сообщений: 2243
Репутация: 581 ±
Замечаний: 0% ±

2010
Здравствуйте.
Не знаю, что вы там сделали, но без указания третьего аргумента функция ПОИСКПОЗ() ищет не точное совпадение, при этом данные должны быть отсортированы по возрастанию. Укажите третий аргумент 0, так ПОИСКПОЗ(ПСТР(A35;3;14);F:F;0) может и будет считать правильно. Чтобы точно ответить нужно видеть, что вы "наваяли" в файле.


ЯД-41001506838083

Сообщение отредактировал gling - Суббота, 06.03.2021, 23:21
 
Ответить
СообщениеЗдравствуйте.
Не знаю, что вы там сделали, но без указания третьего аргумента функция ПОИСКПОЗ() ищет не точное совпадение, при этом данные должны быть отсортированы по возрастанию. Укажите третий аргумент 0, так ПОИСКПОЗ(ПСТР(A35;3;14);F:F;0) может и будет считать правильно. Чтобы точно ответить нужно видеть, что вы "наваяли" в файле.

Автор - gling
Дата добавления - 06.03.2021 в 23:12
korenkovkrd Дата: Суббота, 06.03.2021, 23:21 | Сообщение № 6
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Да, действительно, отсортировал по возрастанию - проблема ушла, заодно добавил ;0
Спасибо большое
 
Ответить
СообщениеДа, действительно, отсортировал по возрастанию - проблема ушла, заодно добавил ;0
Спасибо большое

Автор - korenkovkrd
Дата добавления - 06.03.2021 в 23:21
Мир MS Excel » Вопросы и решения » Вопросы по Excel » если ячейка совпадает с частью строки то возврат соседних яч (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования Jobsora jooble
© 2010-2021 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!