Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Выборочная сумма из таблицы по массиву условий - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Выборочная сумма из таблицы по массиву условий (Формулы/Formulas)
Выборочная сумма из таблицы по массиву условий
Egyptian Дата: Вторник, 09.03.2021, 20:32 | Сообщение № 1
Группа: Пользователи
Ранг: Участник
Сообщений: 99
Репутация: 40 ±
Замечаний: 0% ±

Excel 2013/2016
Доброго всем вечера. Че-то я туплю сегодня и никак не могу решить наверное простую задачку.
Есть таблица с нумерацией строк. Как в ней можно просуммировать строки по массиву номеров? Скажем: 1, 2, 5... и т.д.
Использовал формулу
Код
=SUM(B2:E9*((A2:A9=H2)+(A2:A9=I2)+(A2:A9=J2)))
которая работает, но хотелось бы указать прямо массив, скажем A2:A9=H2:J2. В данном случае
Код
TRANSPOSE()
не работает.
К сообщению приложен файл: 5865593.xlsx(8.9 Kb)


Сообщение отредактировал Egyptian - Вторник, 09.03.2021, 22:17
 
Ответить
СообщениеДоброго всем вечера. Че-то я туплю сегодня и никак не могу решить наверное простую задачку.
Есть таблица с нумерацией строк. Как в ней можно просуммировать строки по массиву номеров? Скажем: 1, 2, 5... и т.д.
Использовал формулу
Код
=SUM(B2:E9*((A2:A9=H2)+(A2:A9=I2)+(A2:A9=J2)))
которая работает, но хотелось бы указать прямо массив, скажем A2:A9=H2:J2. В данном случае
Код
TRANSPOSE()
не работает.

Автор - Egyptian
Дата добавления - 09.03.2021 в 20:32
прохожий2019 Дата: Вторник, 09.03.2021, 22:22 | Сообщение № 2
Группа: Проверенные
Ранг: Ветеран
Сообщений: 544
Репутация: 131 ±
Замечаний: 0% ±

365 Beta Channel
Код
=СУММ(ЕЧИСЛО(ПОИСКПОЗ(A2:A9;H2:J2;))*B2:E9)
 
Ответить
Сообщение
Код
=СУММ(ЕЧИСЛО(ПОИСКПОЗ(A2:A9;H2:J2;))*B2:E9)

Автор - прохожий2019
Дата добавления - 09.03.2021 в 22:22
nikitan95 Дата: Вторник, 09.03.2021, 22:31 | Сообщение № 3
Группа: Проверенные
Ранг: Обитатель
Сообщений: 409
Репутация: 0 ±
Замечаний: 0% ±

2016
вроде так:
Код
=СУММПРОИЗВ((H2:J2=A2:A9)*E2:E9)


Сообщение отредактировал nikitan95 - Вторник, 09.03.2021, 22:34
 
Ответить
Сообщениевроде так:
Код
=СУММПРОИЗВ((H2:J2=A2:A9)*E2:E9)

Автор - nikitan95
Дата добавления - 09.03.2021 в 22:31
Egyptian Дата: Вторник, 09.03.2021, 23:12 | Сообщение № 4
Группа: Пользователи
Ранг: Участник
Сообщений: 99
Репутация: 40 ±
Замечаний: 0% ±

Excel 2013/2016
прохожий2019, Оно самое. Спасибо!

nikitan95,
Нет, так не сработает.
 
Ответить
Сообщениепрохожий2019, Оно самое. Спасибо!

nikitan95,
Нет, так не сработает.

Автор - Egyptian
Дата добавления - 09.03.2021 в 23:12
nikitan95 Дата: Вторник, 09.03.2021, 23:23 | Сообщение № 5
Группа: Проверенные
Ранг: Обитатель
Сообщений: 409
Репутация: 0 ±
Замечаний: 0% ±

2016
Egyptian, вы правы. Я неверно понял постановку вопроса.
 
Ответить
СообщениеEgyptian, вы правы. Я неверно понял постановку вопроса.

Автор - nikitan95
Дата добавления - 09.03.2021 в 23:23
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Выборочная сумма из таблицы по массиву условий (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования Jobsora jooble
© 2010-2021 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!