Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Сортировка данных, содержащих как числовые, так и текстовые - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сортировка данных, содержащих как числовые, так и текстовые (Форматирование/Formattings)
Сортировка данных, содержащих как числовые, так и текстовые
Cunha Дата: Среда, 10.03.2021, 12:43 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Добрый вечер! Подскажите, пожалуйста, как сделать сортировку данных, в которых присутствуют как числовые, так и текстовые значения (в файле лист №2). Делаю сортировку как обычно, но эксель воспринимает 10 как число, которое должно идти после 1... Вроде бы легкая задача, а который час голову ломаю. Спасибо заранее
К сообщению приложен файл: Excel_Test.xlsx(21.3 Kb)
 
Ответить
СообщениеДобрый вечер! Подскажите, пожалуйста, как сделать сортировку данных, в которых присутствуют как числовые, так и текстовые значения (в файле лист №2). Делаю сортировку как обычно, но эксель воспринимает 10 как число, которое должно идти после 1... Вроде бы легкая задача, а который час голову ломаю. Спасибо заранее

Автор - Cunha
Дата добавления - 10.03.2021 в 12:43
Nic70y Дата: Среда, 10.03.2021, 12:47 | Сообщение № 2
Группа: Друзья
Ранг: Экселист
Сообщений: 6842
Репутация: 1571 ±
Замечаний: 0% ±

Excel 2010
в столбце рядом используйте формулу
Код
=--ЛЕВБ(A1;ПОИСК("@";A1)-1)
и сортируйте по этому столбцу


ЮMoney(Яндекс Деньги) 41001841029809
 
Ответить
Сообщениев столбце рядом используйте формулу
Код
=--ЛЕВБ(A1;ПОИСК("@";A1)-1)
и сортируйте по этому столбцу

Автор - Nic70y
Дата добавления - 10.03.2021 в 12:47
Cunha Дата: Среда, 10.03.2021, 13:08 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Nic70y, После введения формулы в выдает только числа. Плюс при сортировке то же самое происходит - 10 после 1 идет, а 100 после 10
 
Ответить
СообщениеNic70y, После введения формулы в выдает только числа. Плюс при сортировке то же самое происходит - 10 после 1 идет, а 100 после 10

Автор - Cunha
Дата добавления - 10.03.2021 в 13:08
Nic70y Дата: Среда, 10.03.2021, 13:13 | Сообщение № 4
Группа: Друзья
Ранг: Экселист
Сообщений: 6842
Репутация: 1571 ±
Замечаний: 0% ±

Excel 2010
только числа
все верно,
далее настраиваемая сортировка
К сообщению приложен файл: 8516918.xlsx(23.1 Kb)


ЮMoney(Яндекс Деньги) 41001841029809
 
Ответить
Сообщение
только числа
все верно,
далее настраиваемая сортировка

Автор - Nic70y
Дата добавления - 10.03.2021 в 13:13
Serge_007 Дата: Среда, 10.03.2021, 13:41 | Сообщение № 5
Группа: Админы
Ранг: Местный житель
Сообщений: 13920
Репутация: 2318 ±
Замечаний: ±

Excel 2010
при сортировке то же самое происходит - 10 после 1 идет, а 100 после 10
Так будет по порядку:
Код
=ТЕКСТ(ЛЕВБ(A1;ПОИСК("@";A1)-1);"000")


Яндекс-деньги:41001419691823 | WMR:126292472390
 
Ответить
Сообщение
при сортировке то же самое происходит - 10 после 1 идет, а 100 после 10
Так будет по порядку:
Код
=ТЕКСТ(ЛЕВБ(A1;ПОИСК("@";A1)-1);"000")

Автор - Serge_007
Дата добавления - 10.03.2021 в 13:41
Egyptian Дата: Среда, 10.03.2021, 14:00 | Сообщение № 6
Группа: Пользователи
Ранг: Участник
Сообщений: 99
Репутация: 40 ±
Замечаний: 0% ±

Excel 2013/2016
Cunha,
Кажется Вам ответили здесь в том числе и формульными решениями.


Сообщение отредактировал Egyptian - Среда, 10.03.2021, 14:00
 
Ответить
СообщениеCunha,
Кажется Вам ответили здесь в том числе и формульными решениями.

Автор - Egyptian
Дата добавления - 10.03.2021 в 14:00
Cunha Дата: Среда, 10.03.2021, 14:11 | Сообщение № 7
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Nic70y, Serge_007, спасибо, разобрался!
 
Ответить
СообщениеNic70y, Serge_007, спасибо, разобрался!

Автор - Cunha
Дата добавления - 10.03.2021 в 14:11
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сортировка данных, содержащих как числовые, так и текстовые (Форматирование/Formattings)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования Jobsora jooble
© 2010-2021 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!