Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Сбор значений ячеек с одинаковым Заголовком - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сбор значений ячеек с одинаковым Заголовком (Формулы/Formulas)
Сбор значений ячеек с одинаковым Заголовком
itoptunov@grast-stroyru Дата: Вторник, 16.03.2021, 16:35 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Добрый день!

Коллеги нужна помощь, суть таблицы такова: Есть список вещей, которые каждый день забирает разный человек в разном количестве. Например Саша сегодня взял 4 моркови, вчера 1 ананас, позавчера 18 морковок, Коля взял 1 молоток вчера и сегодня 2 и тд. Необходимо на другом листе (Лист 2) вывести все значения сколько всего было взято Сашей всех вещей, Колей, Петей, Васей.... Так же при добавлении новых позиций, чтобы они так же отображались в листе 2 когда человек заберет этот предмет.

Если есть более изящное решение, каким то фильтром может, на одном листе все уместить, то будет еще лучше!

Файл прикрепляю, спасибо!
К сообщению приложен файл: 7791726.xlsx(10.1 Kb)


Сообщение отредактировал itoptunov@grast-stroyru - Вторник, 16.03.2021, 16:38
 
Ответить
СообщениеДобрый день!

Коллеги нужна помощь, суть таблицы такова: Есть список вещей, которые каждый день забирает разный человек в разном количестве. Например Саша сегодня взял 4 моркови, вчера 1 ананас, позавчера 18 морковок, Коля взял 1 молоток вчера и сегодня 2 и тд. Необходимо на другом листе (Лист 2) вывести все значения сколько всего было взято Сашей всех вещей, Колей, Петей, Васей.... Так же при добавлении новых позиций, чтобы они так же отображались в листе 2 когда человек заберет этот предмет.

Если есть более изящное решение, каким то фильтром может, на одном листе все уместить, то будет еще лучше!

Файл прикрепляю, спасибо!

Автор - itoptunov@grast-stroyru
Дата добавления - 16.03.2021 в 16:35
Serge_007 Дата: Вторник, 16.03.2021, 17:15 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 13873
Репутация: 2315 ±
Замечаний: ±

Excel 2010
Здравствуйте

Цитата itoptunov@grast-stroyru, 16.03.2021 в 16:35, в сообщении № 1 ()
Если есть более изящное решение
Если исходные данные вести правильно, то можно сводной таблицей пользоваться (см. вложение)
К сообщению приложен файл: 20210316_itoptu.xls(28.5 Kb)


Яндекс-деньги:41001419691823 | WMR:126292472390
 
Ответить
СообщениеЗдравствуйте

Цитата itoptunov@grast-stroyru, 16.03.2021 в 16:35, в сообщении № 1 ()
Если есть более изящное решение
Если исходные данные вести правильно, то можно сводной таблицей пользоваться (см. вложение)

Автор - Serge_007
Дата добавления - 16.03.2021 в 17:15
itoptunov@grast-stroyru Дата: Вторник, 16.03.2021, 17:23 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Главное чтобы формат на первом листе был такой как в моем прикрепленном пример, ваше решение меняет этот формат.
 
Ответить
СообщениеГлавное чтобы формат на первом листе был такой как в моем прикрепленном пример, ваше решение меняет этот формат.

Автор - itoptunov@grast-stroyru
Дата добавления - 16.03.2021 в 17:23
Serge_007 Дата: Вторник, 16.03.2021, 17:55 | Сообщение № 4
Группа: Админы
Ранг: Местный житель
Сообщений: 13873
Репутация: 2315 ±
Замечаний: ±

Excel 2010
Цитата itoptunov@grast-stroyru, 16.03.2021 в 17:23, в сообщении № 3 ()
формат на первом листе был такой как в моем прикрепленном пример
Тогда простого решения не получится


Яндекс-деньги:41001419691823 | WMR:126292472390
 
Ответить
Сообщение
Цитата itoptunov@grast-stroyru, 16.03.2021 в 17:23, в сообщении № 3 ()
формат на первом листе был такой как в моем прикрепленном пример
Тогда простого решения не получится

Автор - Serge_007
Дата добавления - 16.03.2021 в 17:55
itoptunov@grast-stroyru Дата: Вторник, 16.03.2021, 19:14 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Поэтому и прошу помочь, на первый взгляд простая задачка, но что то пошло нет так... )
 
Ответить
СообщениеПоэтому и прошу помочь, на первый взгляд простая задачка, но что то пошло нет так... )

Автор - itoptunov@grast-stroyru
Дата добавления - 16.03.2021 в 19:14
Светлый Дата: Вторник, 16.03.2021, 21:24 | Сообщение № 6
Группа: Друзья
Ранг: Старожил
Сообщений: 1569
Репутация: 409 ±
Замечаний: 0% ±

Excel 2010, 2013
Диапазоны можно расширить:
Код
=СУММПРОИЗВ((E$2=Лист1!$E$10:$X$10)*($B4=Лист1!$B$12:$B$31)*Лист1!$E$12:$X$31)
или
Код
=ЕСЛИ(ИЛИ($B4="";E$2="");"";СУММПРОИЗВ((E$2=Лист1!$E$10:$X$10)*($B4=Лист1!$B$12:$B$31)*Лист1!$E$12:$X$31))


Программировать проще, чем писать стихи.
 
Ответить
СообщениеДиапазоны можно расширить:
Код
=СУММПРОИЗВ((E$2=Лист1!$E$10:$X$10)*($B4=Лист1!$B$12:$B$31)*Лист1!$E$12:$X$31)
или
Код
=ЕСЛИ(ИЛИ($B4="";E$2="");"";СУММПРОИЗВ((E$2=Лист1!$E$10:$X$10)*($B4=Лист1!$B$12:$B$31)*Лист1!$E$12:$X$31))

Автор - Светлый
Дата добавления - 16.03.2021 в 21:24
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сбор значений ячеек с одинаковым Заголовком (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования Jobsora jooble
© 2010-2021 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!