Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Сравнение прайс-листов - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сравнение прайс-листов (Формулы/Formulas)
Сравнение прайс-листов
Владимир2021 Дата: Понедельник, 22.03.2021, 19:47 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Здравствуйте.
На работе мне приходится проверять предложения о сотрудничестве от поставщиков. Часто заведённое название одного и того же товара у этих поставщиков может отличаться, но разумеется штрих-код един.
Прайс-листы состоят из сотен позиций, цены регулярно меняются, у многих есть своё хорошее предложение на узкую группу позиций, поэтому на подобную проверку уходит много времени.
Прошу посоветовать, как с помощью Excel можно решить эту проблему?
К сообщению приложен файл: _1.xls(133.0 Kb) · _2.xls(108.5 Kb)


Сообщение отредактировал Владимир2021 - Понедельник, 22.03.2021, 23:14
 
Ответить
СообщениеЗдравствуйте.
На работе мне приходится проверять предложения о сотрудничестве от поставщиков. Часто заведённое название одного и того же товара у этих поставщиков может отличаться, но разумеется штрих-код един.
Прайс-листы состоят из сотен позиций, цены регулярно меняются, у многих есть своё хорошее предложение на узкую группу позиций, поэтому на подобную проверку уходит много времени.
Прошу посоветовать, как с помощью Excel можно решить эту проблему?

Автор - Владимир2021
Дата добавления - 22.03.2021 в 19:47
Pelena Дата: Понедельник, 22.03.2021, 21:24 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 17441
Репутация: 3873 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Здравствуйте.
Без файла с примером только общий ответ: посмотрите статью из Готовых решений.
и ещё статью на дружественном форуме


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеЗдравствуйте.
Без файла с примером только общий ответ: посмотрите статью из Готовых решений.
и ещё статью на дружественном форуме

Автор - Pelena
Дата добавления - 22.03.2021 в 21:24
Владимир2021 Дата: Понедельник, 22.03.2021, 23:15 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Pelena, извиняюсь - теперь добавил.
 
Ответить
СообщениеPelena, извиняюсь - теперь добавил.

Автор - Владимир2021
Дата добавления - 22.03.2021 в 23:15
Kostya_Ye Дата: Вторник, 23.03.2021, 08:22 | Сообщение № 4
Группа: Проверенные
Ранг: Обитатель
Сообщений: 251
Репутация: 224 ±
Замечаний: 0% ±

Excel 2016
Владимир2021, добрый день,
Код
=ИНДЕКС([_2.xls]TDSheet!$AM:$AM; ПОИСКПОЗ(U4;[_2.xls]TDSheet!$G:$G;0))

например так, в файле _1.xls выводите цену из файла _2.xls, если позиции нет в файле _2, то формула покажет #Н/Д. Можно скрыть #Н/Д функцией
Код
=ЕСЛИОШИБКА()

Только у вас ведь наверное задача немного шире ? Предположу, то таких файлов не два, а больше, и структура у них отличается (на примере этих двух) - колонки разные, заголовки отличаются. И свод по позициям вы хотели бы получить в некотором отдельном файле, так?
 
Ответить
СообщениеВладимир2021, добрый день,
Код
=ИНДЕКС([_2.xls]TDSheet!$AM:$AM; ПОИСКПОЗ(U4;[_2.xls]TDSheet!$G:$G;0))

например так, в файле _1.xls выводите цену из файла _2.xls, если позиции нет в файле _2, то формула покажет #Н/Д. Можно скрыть #Н/Д функцией
Код
=ЕСЛИОШИБКА()

Только у вас ведь наверное задача немного шире ? Предположу, то таких файлов не два, а больше, и структура у них отличается (на примере этих двух) - колонки разные, заголовки отличаются. И свод по позициям вы хотели бы получить в некотором отдельном файле, так?

Автор - Kostya_Ye
Дата добавления - 23.03.2021 в 08:22
Владимир2021 Дата: Вторник, 23.03.2021, 16:44 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

И свод по позициям вы хотели бы получить в некотором отдельном файле, так?

об этом я могу только мечтать!
 
Ответить
Сообщение
И свод по позициям вы хотели бы получить в некотором отдельном файле, так?

об этом я могу только мечтать!

Автор - Владимир2021
Дата добавления - 23.03.2021 в 16:44
прохожий2019 Дата: Вторник, 23.03.2021, 19:20 | Сообщение № 6
Группа: Проверенные
Ранг: Ветеран
Сообщений: 531
Репутация: 129 ±
Замечаний: 0% ±

365 Beta Channel
Цитата Владимир2021, 23.03.2021 в 16:44, в сообщении № 5 ()
могу только мечтать
а чего мечтать - если файлы лежат в одной папке, если возможно очертить круг наименований полей - например, содержит "Штрихкод", содержит "Товар", содержит "Цена", а поставщик по имени файла, то можно и на PQ соорудить.


Сообщение отредактировал прохожий2019 - Вторник, 23.03.2021, 19:42
 
Ответить
Сообщение
Цитата Владимир2021, 23.03.2021 в 16:44, в сообщении № 5 ()
могу только мечтать
а чего мечтать - если файлы лежат в одной папке, если возможно очертить круг наименований полей - например, содержит "Штрихкод", содержит "Товар", содержит "Цена", а поставщик по имени файла, то можно и на PQ соорудить.

Автор - прохожий2019
Дата добавления - 23.03.2021 в 19:20
Kostya_Ye Дата: Вторник, 23.03.2021, 21:07 | Сообщение № 7
Группа: Проверенные
Ранг: Обитатель
Сообщений: 251
Репутация: 224 ±
Замечаний: 0% ±

Excel 2016
прохожий2019,
совершенно верно, опередили ...
Владимир2021,
во вложении сведение данных с помощью PQ для двух ваших файлов из примера, в A2 укажете путь к папке с файлами, в папку сложите файлы, на таблице в контекстном меню выберите Обновить.
для других вариантов исходных файлов для сведения возможно потребуется донастройка запроса.
К сообщению приложен файл: svod.xlsx(29.3 Kb)
 
Ответить
Сообщениепрохожий2019,
совершенно верно, опередили ...
Владимир2021,
во вложении сведение данных с помощью PQ для двух ваших файлов из примера, в A2 укажете путь к папке с файлами, в папку сложите файлы, на таблице в контекстном меню выберите Обновить.
для других вариантов исходных файлов для сведения возможно потребуется донастройка запроса.

Автор - Kostya_Ye
Дата добавления - 23.03.2021 в 21:07
Владимир2021 Дата: Четверг, 25.03.2021, 21:05 | Сообщение № 8
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

во вложении сведение данных с помощью PQ для двух ваших файлов из примера, в A2 укажете путь к папке с файлами, в папку сложите файлы, на таблице в контекстном меню выберите Обновить.
для других вариантов исходных файлов для сведения возможно потребуется донастройка запроса.


Извините за долгий ответ, было много работы. Вы круто сделали, очень впечатляет!
 
Ответить
Сообщение
во вложении сведение данных с помощью PQ для двух ваших файлов из примера, в A2 укажете путь к папке с файлами, в папку сложите файлы, на таблице в контекстном меню выберите Обновить.
для других вариантов исходных файлов для сведения возможно потребуется донастройка запроса.


Извините за долгий ответ, было много работы. Вы круто сделали, очень впечатляет!

Автор - Владимир2021
Дата добавления - 25.03.2021 в 21:05
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сравнение прайс-листов (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования Jobsora jooble
© 2010-2021 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!