Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Сумма столба с выборкой из другого столбца - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сумма столба с выборкой из другого столбца (Формулы/Formulas)
Сумма столба с выборкой из другого столбца
CrazyGC Дата: Среда, 24.03.2021, 09:20 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

С экселем не работал ранее в таком ключе и прошу помощи(

У меня есть столбцы "статус" и "стоимость"(файл приложил).
В статусе пишется или Свободен или Продан, мне нужно вывести сумму чисел из столба "стоимость" выбрав при этом только те позиции, у которых стоит в строке статус Продан

Код
=ИНДЕКС(R2C5:R11C5;ПОИСКПОЗ("Продан";R2C2:R411C2;0))

Я накидал нечто подобное полазив в интернете, но данная формула выводит лишь первое вхождение по моему условию. Помогите решить(
К сообщению приложен файл: 0312280.xlsx(9.3 Kb)
 
Ответить
СообщениеС экселем не работал ранее в таком ключе и прошу помощи(

У меня есть столбцы "статус" и "стоимость"(файл приложил).
В статусе пишется или Свободен или Продан, мне нужно вывести сумму чисел из столба "стоимость" выбрав при этом только те позиции, у которых стоит в строке статус Продан

Код
=ИНДЕКС(R2C5:R11C5;ПОИСКПОЗ("Продан";R2C2:R411C2;0))

Я накидал нечто подобное полазив в интернете, но данная формула выводит лишь первое вхождение по моему условию. Помогите решить(

Автор - CrazyGC
Дата добавления - 24.03.2021 в 09:20
Nic70y Дата: Среда, 24.03.2021, 09:27 | Сообщение № 2
Группа: Друзья
Ранг: Экселист
Сообщений: 6832
Репутация: 1567 ±
Замечаний: 0% ±

Excel 2010
полазив в интернете
не там лазили
официальная справка
[p.s.]формулу нужно сувать в тег[/p.s.]


ЮMoney(Яндекс Деньги) 41001841029809
 
Ответить
Сообщение
полазив в интернете
не там лазили
официальная справка
[p.s.]формулу нужно сувать в тег[/p.s.]

Автор - Nic70y
Дата добавления - 24.03.2021 в 09:27
jakim Дата: Среда, 24.03.2021, 09:27 | Сообщение № 3
Группа: Друзья
Ранг: Ветеран
Сообщений: 999
Репутация: 272 ±
Замечаний: 0% ±

Excel 2010
формула

Код
=SUM(INDEX((B2:B11="Продан")*E2:E11;0))
 
Ответить
Сообщение
формула

Код
=SUM(INDEX((B2:B11="Продан")*E2:E11;0))

Автор - jakim
Дата добавления - 24.03.2021 в 09:27
CrazyGC Дата: Среда, 24.03.2021, 09:35 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

формула

Код
=СУММ(ИНДЕКС((B2:B11="Продан")*E2:E11;0))

Огромное спасибо! То что нужно
 
Ответить
Сообщениеформула

Код
=СУММ(ИНДЕКС((B2:B11="Продан")*E2:E11;0))

Огромное спасибо! То что нужно

Автор - CrazyGC
Дата добавления - 24.03.2021 в 09:35
CrazyGC Дата: Среда, 24.03.2021, 09:36 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

не там лазили
официальная справка
P.S.
формулу нужно сувать в тег


Вам тоже большое спасибо за ответ, уже изучаю материал !
 
Ответить
Сообщение
не там лазили
официальная справка
P.S.
формулу нужно сувать в тег


Вам тоже большое спасибо за ответ, уже изучаю материал !

Автор - CrazyGC
Дата добавления - 24.03.2021 в 09:36
Serge_007 Дата: Среда, 24.03.2021, 10:22 | Сообщение № 6
Группа: Админы
Ранг: Местный житель
Сообщений: 13873
Репутация: 2315 ±
Замечаний: ±

Excel 2010
jakim, а зачем ИНДЕКС() ?


Яндекс-деньги:41001419691823 | WMR:126292472390
 
Ответить
Сообщениеjakim, а зачем ИНДЕКС() ?

Автор - Serge_007
Дата добавления - 24.03.2021 в 10:22
Egyptian Дата: Среда, 24.03.2021, 11:18 | Сообщение № 7
Группа: Пользователи
Ранг: Участник
Сообщений: 95
Репутация: 39 ±
Замечаний: 0% ±

Excel 2013/2016
а зачем ИНДЕКС() ?

Думаю, позволяет избавиться от массивного ввода.
 
Ответить
Сообщение
а зачем ИНДЕКС() ?

Думаю, позволяет избавиться от массивного ввода.

Автор - Egyptian
Дата добавления - 24.03.2021 в 11:18
Serge_007 Дата: Среда, 24.03.2021, 12:19 | Сообщение № 8
Группа: Админы
Ранг: Местный житель
Сообщений: 13873
Репутация: 2315 ±
Замечаний: ±

Excel 2010
Это можно и через СУММПРОИЗВ()
:D


Яндекс-деньги:41001419691823 | WMR:126292472390
 
Ответить
СообщениеЭто можно и через СУММПРОИЗВ()
:D

Автор - Serge_007
Дата добавления - 24.03.2021 в 12:19
jakim Дата: Среда, 24.03.2021, 12:31 | Сообщение № 9
Группа: Друзья
Ранг: Ветеран
Сообщений: 999
Репутация: 272 ±
Замечаний: 0% ±

Excel 2010
Для разнообразия.
 
Ответить
Сообщение
Для разнообразия.

Автор - jakim
Дата добавления - 24.03.2021 в 12:31
Serge_007 Дата: Среда, 24.03.2021, 12:32 | Сообщение № 10
Группа: Админы
Ранг: Местный житель
Сообщений: 13873
Репутация: 2315 ±
Замечаний: ±

Excel 2010
Я так и подумал :D


Яндекс-деньги:41001419691823 | WMR:126292472390
 
Ответить
СообщениеЯ так и подумал :D

Автор - Serge_007
Дата добавления - 24.03.2021 в 12:32
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сумма столба с выборкой из другого столбца (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования Jobsora jooble
© 2010-2021 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!