Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Суммирование значений на перечечение строк и столбцов - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Суммирование значений на перечечение строк и столбцов (Формулы/Formulas)
Суммирование значений на перечечение строк и столбцов
ivanovcdek Дата: Среда, 24.03.2021, 12:32 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Добрый день!
Имею реестр клиентов с детализацией продаж по неделям по каждому из них. Каждый клиент мог начать покупать в разное время. При этом выведен в отдельном столбце номер первой недели продаж по каждому клиенту.

Мне необходимо посчитать сумму продаж именно в первую неделю. Помогите плз с какой-нибудь изящной формулой т.к. матрица клиентов и номеров недель довольно большая (около 20000 строк).

Упрощенный пример в аттаче
К сообщению приложен файл: 8397198.xlsx(11.9 Kb)
 
Ответить
СообщениеДобрый день!
Имею реестр клиентов с детализацией продаж по неделям по каждому из них. Каждый клиент мог начать покупать в разное время. При этом выведен в отдельном столбце номер первой недели продаж по каждому клиенту.

Мне необходимо посчитать сумму продаж именно в первую неделю. Помогите плз с какой-нибудь изящной формулой т.к. матрица клиентов и номеров недель довольно большая (около 20000 строк).

Упрощенный пример в аттаче

Автор - ivanovcdek
Дата добавления - 24.03.2021 в 12:32
amfor Дата: Среда, 24.03.2021, 13:04 | Сообщение № 2
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 205
Репутация: 61 ±
Замечаний: 0% ±

Excel 2016
Добрый. Как понял.

Код
=СУММПРОИЗВ(($B$4:$F$4=$R5)*($G$5:$G$14=$R5)*$B$5:$F$14)
К сообщению приложен файл: 1408335.xlsx(13.0 Kb)


Семь бед - один RESET.
 
Ответить
СообщениеДобрый. Как понял.

Код
=СУММПРОИЗВ(($B$4:$F$4=$R5)*($G$5:$G$14=$R5)*$B$5:$F$14)

Автор - amfor
Дата добавления - 24.03.2021 в 13:04
ivanovcdek Дата: Среда, 24.03.2021, 13:51 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Спасибо! То что нужно
 
Ответить
СообщениеСпасибо! То что нужно

Автор - ivanovcdek
Дата добавления - 24.03.2021 в 13:51
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Суммирование значений на перечечение строк и столбцов (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования Jobsora jooble
© 2010-2021 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!