Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/преобразование массива в два столбца формулой - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » преобразование массива в два столбца формулой (Формулы/Formulas)
преобразование массива в два столбца формулой
tanya7108 Дата: Вторник, 30.03.2021, 22:49 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 1
Репутация: 0 ±
Замечаний: 0% ±

Помогите пожалуйста в решении следующей задачи. В ячейках A2:F4 имеется массив (матрица) с четным количеством столбцов. Нужно сделать из него два столбца, чтобы 2 соседние ячейки строки оказались в разных столбцах. В ячейки G2:H10 ввожу формулу массива
Код
=СМЕЩ(матрица;(СТРОКА()-СТРОКА($G$2))/(ЧИСЛСТОЛБ(матрица)/2);(ОСТАТ((СТРОКА()-СТРОКА($G$2));(ЧИСЛСТОЛБ(матрица)/2))*2);1;2)
. В результате получаю #ЗНАЧ! Что я делаю не так. Почему формула ={СМЕЩ(матрица;0;2;1;2)} работает если вводить её в две соседние ячейки, а та что выше не работает? Если делать два вспомогательных столбца для расчета смещения по строкам/столбцам, то формула тоже работает, но хочется обойтись без вспомогательных столбцов
К сообщению приложен файл: 1_.xls(17.0 Kb)
 
Ответить
СообщениеПомогите пожалуйста в решении следующей задачи. В ячейках A2:F4 имеется массив (матрица) с четным количеством столбцов. Нужно сделать из него два столбца, чтобы 2 соседние ячейки строки оказались в разных столбцах. В ячейки G2:H10 ввожу формулу массива
Код
=СМЕЩ(матрица;(СТРОКА()-СТРОКА($G$2))/(ЧИСЛСТОЛБ(матрица)/2);(ОСТАТ((СТРОКА()-СТРОКА($G$2));(ЧИСЛСТОЛБ(матрица)/2))*2);1;2)
. В результате получаю #ЗНАЧ! Что я делаю не так. Почему формула ={СМЕЩ(матрица;0;2;1;2)} работает если вводить её в две соседние ячейки, а та что выше не работает? Если делать два вспомогательных столбца для расчета смещения по строкам/столбцам, то формула тоже работает, но хочется обойтись без вспомогательных столбцов

Автор - tanya7108
Дата добавления - 30.03.2021 в 22:49
Pelena Дата: Вторник, 30.03.2021, 23:59 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 17791
Репутация: 3957 ±
Замечаний: ±

Excel 2016 & Mac Excel
Вариант
Код
=ИНДЕКС(матрица;(СТРОКА(A1)-1)/(ЧИСЛСТОЛБ(матрица)/2)+1;(ОСТАТ((СТРОКА(A1)-1);(ЧИСЛСТОЛБ(матрица)/2))*2+СТОЛБЕЦ(A1)))
К сообщению приложен файл: 7928934.xls(32.0 Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеВариант
Код
=ИНДЕКС(матрица;(СТРОКА(A1)-1)/(ЧИСЛСТОЛБ(матрица)/2)+1;(ОСТАТ((СТРОКА(A1)-1);(ЧИСЛСТОЛБ(матрица)/2))*2+СТОЛБЕЦ(A1)))

Автор - Pelena
Дата добавления - 30.03.2021 в 23:59
Egyptian Дата: Среда, 31.03.2021, 00:03 | Сообщение № 3
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 133
Репутация: 47 ±
Замечаний: 0% ±

Excel 2013/2016
tanya7108,
Чуть подправил вашу формулу.
Код
=OFFSET(A$2;(ROW()-ROW($G$2))/(COLUMNS(матрица)/2);(MOD((ROW()-ROW($G$2));(COLUMNS(матрица)/2))*2);1;2)
К сообщению приложен файл: 5252170.xls(32.0 Kb)
 
Ответить
Сообщениеtanya7108,
Чуть подправил вашу формулу.
Код
=OFFSET(A$2;(ROW()-ROW($G$2))/(COLUMNS(матрица)/2);(MOD((ROW()-ROW($G$2));(COLUMNS(матрица)/2))*2);1;2)

Автор - Egyptian
Дата добавления - 31.03.2021 в 00:03
Мир MS Excel » Вопросы и решения » Вопросы по Excel » преобразование массива в два столбца формулой (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования Jobsora jooble
© 2010-2021 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!