Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Как зафиксировать диапазон суммирования при вставке строк? - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Как зафиксировать диапазон суммирования при вставке строк? (Формулы/Formulas)
Как зафиксировать диапазон суммирования при вставке строк?
AS-1 Дата: Вторник, 06.04.2021, 11:19 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Здравствуйте!
Подскажите, как решить следующую задачу:
Каждый день в таблицу вставляется новая строка сверху после заголовка с новой датой (столбец А) и каким-то значением (столбец В). Т.е. таблица растет не вниз, а вверх. Нужно суммировать диапазон значений за последние 10 дней, т.е. суммироваться должен всегда диапазон B2:B11.
Из-за вставки строк в формуле происходит смещение этого диапазона: B3:B12, B4:B13 и т.д.
Какую прописать формулу, чтобы несмотря на вставку строк суммировался всегда диапазон B2:B11?
К сообщению приложен файл: 7107713.xlsx(12.2 Kb)


Сообщение отредактировал AS-1 - Вторник, 06.04.2021, 11:22
 
Ответить
СообщениеЗдравствуйте!
Подскажите, как решить следующую задачу:
Каждый день в таблицу вставляется новая строка сверху после заголовка с новой датой (столбец А) и каким-то значением (столбец В). Т.е. таблица растет не вниз, а вверх. Нужно суммировать диапазон значений за последние 10 дней, т.е. суммироваться должен всегда диапазон B2:B11.
Из-за вставки строк в формуле происходит смещение этого диапазона: B3:B12, B4:B13 и т.д.
Какую прописать формулу, чтобы несмотря на вставку строк суммировался всегда диапазон B2:B11?

Автор - AS-1
Дата добавления - 06.04.2021 в 11:19
Nic70y Дата: Вторник, 06.04.2021, 11:28 | Сообщение № 2
Группа: Друзья
Ранг: Экселист
Сообщений: 7017
Репутация: 1618 ±
Замечаний: 0% ±

Excel 2010
Код
=СУММ(ИНДЕКС(B:B;2):ИНДЕКС(B:B;11))


ЮMoney(Яндекс Деньги) 41001841029809
 
Ответить
Сообщение
Код
=СУММ(ИНДЕКС(B:B;2):ИНДЕКС(B:B;11))

Автор - Nic70y
Дата добавления - 06.04.2021 в 11:28
Serge_007 Дата: Вторник, 06.04.2021, 11:32 | Сообщение № 3
Группа: Админы
Ранг: Местный житель
Сообщений: 14465
Репутация: 2384 ±
Замечаний: ±

Excel 2010
Код
=СУММ(ДВССЫЛ("B2:B11"))
Код
=СУММ(СМЕЩ(B1;;;11))


Яндекс-деньги:41001419691823 | WMR:126292472390
 
Ответить
Сообщение
Код
=СУММ(ДВССЫЛ("B2:B11"))
Код
=СУММ(СМЕЩ(B1;;;11))

Автор - Serge_007
Дата добавления - 06.04.2021 в 11:32
AS-1 Дата: Вторник, 06.04.2021, 11:33 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Код
=СУММ(ИНДЕКС(B:B;2):ИНДЕКС(B:B;11))

Большое спасибо, очень помогли!


Сообщение отредактировал Serge_007 - Вторник, 06.04.2021, 11:34
 
Ответить
Сообщение
Код
=СУММ(ИНДЕКС(B:B;2):ИНДЕКС(B:B;11))

Большое спасибо, очень помогли!

Автор - AS-1
Дата добавления - 06.04.2021 в 11:33
AS-1 Дата: Вторник, 06.04.2021, 11:36 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Код
=СУММ(ДВССЫЛ("B2:B11"))

Serge_007, Аналогично, все работает! Большое спасибо!


Сообщение отредактировал Serge_007 - Вторник, 06.04.2021, 11:58
 
Ответить
Сообщение
Код
=СУММ(ДВССЫЛ("B2:B11"))

Serge_007, Аналогично, все работает! Большое спасибо!

Автор - AS-1
Дата добавления - 06.04.2021 в 11:36
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Как зафиксировать диапазон суммирования при вставке строк? (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования Jobsora jooble
© 2010-2021 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!