Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Формула для сортировки данных - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Формула для сортировки данных (Формулы/Formulas)
Формула для сортировки данных
tarmashevas Дата: Среда, 07.04.2021, 18:10 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

2016
Добрый день!
Подскажите, пожалуйста, как можно отфильтровать формулой данный набор данных? Если простым языком, нужно выявить контейнеры без заказов состоящих из семи цифр в 2 столбцах.
Необходимо по столбцу А (номер контейнера), сделать проверку наличия семизначного номера в одном из столбцов В и С.
При этом, если в одной из ячеек В или С, с одинаковым номером контейнеры (строки столбца А) есть 7 значный номер, это считается как "хорошо", а если ни по одной из строчек с номером контейнера столбцов Б и С данных нет, или количество цифр больше или меньше 7 тогда это "плохо".
К сообщению приложен файл: __.xls(38.5 Kb)
 
Ответить
СообщениеДобрый день!
Подскажите, пожалуйста, как можно отфильтровать формулой данный набор данных? Если простым языком, нужно выявить контейнеры без заказов состоящих из семи цифр в 2 столбцах.
Необходимо по столбцу А (номер контейнера), сделать проверку наличия семизначного номера в одном из столбцов В и С.
При этом, если в одной из ячеек В или С, с одинаковым номером контейнеры (строки столбца А) есть 7 значный номер, это считается как "хорошо", а если ни по одной из строчек с номером контейнера столбцов Б и С данных нет, или количество цифр больше или меньше 7 тогда это "плохо".

Автор - tarmashevas
Дата добавления - 07.04.2021 в 18:10
Kostya_Ye Дата: Среда, 07.04.2021, 18:21 | Сообщение № 2
Группа: Проверенные
Ранг: Обитатель
Сообщений: 251
Репутация: 224 ±
Замечаний: 0% ±

Excel 2016
tarmashevas, добрый день,
В примере номера у вас - восьмизначные.

уточните, вам нужно именно отфильтровать диапазон формулой (т.е. в отдельном диапазоне получить только соответствующие критерию значения) или просто заполнить колонку, как у вас сделано в ручную ?
Если первое, то какая версия Excel у вас?

для заполнения колонки формула
Код
=ЕСЛИ(СУММПРОИЗВ(--(ДЛСТР($B$2:$C$27)=8)*($A$2:$A$27=A2))>0;"Хорошо";"Плохо")


Сообщение отредактировал Kostya_Ye - Среда, 07.04.2021, 18:31
 
Ответить
Сообщениеtarmashevas, добрый день,
В примере номера у вас - восьмизначные.

уточните, вам нужно именно отфильтровать диапазон формулой (т.е. в отдельном диапазоне получить только соответствующие критерию значения) или просто заполнить колонку, как у вас сделано в ручную ?
Если первое, то какая версия Excel у вас?

для заполнения колонки формула
Код
=ЕСЛИ(СУММПРОИЗВ(--(ДЛСТР($B$2:$C$27)=8)*($A$2:$A$27=A2))>0;"Хорошо";"Плохо")

Автор - Kostya_Ye
Дата добавления - 07.04.2021 в 18:21
bmv98rus Дата: Четверг, 08.04.2021, 07:57 | Сообщение № 3
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3444
Репутация: 602 ±
Замечаний: 0% ±

Excel 2013/2016
немного подправим и уберем лишне мазки
Код
=IF(SUMPRODUCT((LEN($B$2:$C$27)=8)*($A$2:$A$27=A2));"Хорошо";"Плохо")


но вариант
Код
=IF(COUNTIFS($A$2:$A$27;A2;$B$2:$B$27;">9999999";$B$2:$B$27;"<99999999")+COUNTIFS($A$2:$A$27;A2;$C$2:$C$27;">9999999";$C$2:$C$27;"<99999999");"Хорошо";"Плохо")
окажется быстрее, на 10000 расчетов он выдал 0,9042969 сек
а тот что выше 0,96875


Замечательный Временно просто медведь , процентов на 20.
 
Ответить
Сообщениенемного подправим и уберем лишне мазки
Код
=IF(SUMPRODUCT((LEN($B$2:$C$27)=8)*($A$2:$A$27=A2));"Хорошо";"Плохо")


но вариант
Код
=IF(COUNTIFS($A$2:$A$27;A2;$B$2:$B$27;">9999999";$B$2:$B$27;"<99999999")+COUNTIFS($A$2:$A$27;A2;$C$2:$C$27;">9999999";$C$2:$C$27;"<99999999");"Хорошо";"Плохо")
окажется быстрее, на 10000 расчетов он выдал 0,9042969 сек
а тот что выше 0,96875

Автор - bmv98rus
Дата добавления - 08.04.2021 в 07:57
tarmashevas Дата: Четверг, 08.04.2021, 09:42 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

2016
Kostya_Ye,
MS Office профессиональный плюс 2010, версия: 14.0.6023.1000 (32 - разрядная)
Вопрос 7 или 8 значному количеству цифр, мог опечататься, в примере количество цифр верное. Формула понятна смогу сам вирировать количество знаков.

Большое спасибо, за помощь.

 
Ответить
СообщениеKostya_Ye,
MS Office профессиональный плюс 2010, версия: 14.0.6023.1000 (32 - разрядная)
Вопрос 7 или 8 значному количеству цифр, мог опечататься, в примере количество цифр верное. Формула понятна смогу сам вирировать количество знаков.

Большое спасибо, за помощь.


Автор - tarmashevas
Дата добавления - 08.04.2021 в 09:42
tarmashevas Дата: Четверг, 08.04.2021, 09:45 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

2016
bmv98rus,

Большое спасибо! Буду пользоваться.
 
Ответить
Сообщениеbmv98rus,

Большое спасибо! Буду пользоваться.

Автор - tarmashevas
Дата добавления - 08.04.2021 в 09:45
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Формула для сортировки данных (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования Jobsora jooble
© 2010-2021 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!