Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Подсчет общей суммы по однотипным услугам, между строк ИТОГО - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подсчет общей суммы по однотипным услугам, между строк ИТОГО (Формулы/Formulas)
Подсчет общей суммы по однотипным услугам, между строк ИТОГО
Tallen Дата: Понедельник, 12.04.2021, 12:51 | Сообщение № 1
Группа: Пользователи
Ранг: Участник
Сообщений: 63
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Добрый день! Помогите пожалуйста посчитать суммы по услугам одного типа Стоки со стоками и т.д. между строками с ИТОГО. Таблица выгружается из 1с, но было бы удобнее, чтобы по однотипным услугам считался итог. В столбце D вручную поставила суммы, которые должны получиться. В промежутке между Итого и Итого количество услуг не всегда одинаково, м.б. и 2 и 3
К сообщению приложен файл: ____.xlsx(11.7 Kb)


Сообщение отредактировал Tallen - Понедельник, 12.04.2021, 12:55
 
Ответить
СообщениеДобрый день! Помогите пожалуйста посчитать суммы по услугам одного типа Стоки со стоками и т.д. между строками с ИТОГО. Таблица выгружается из 1с, но было бы удобнее, чтобы по однотипным услугам считался итог. В столбце D вручную поставила суммы, которые должны получиться. В промежутке между Итого и Итого количество услуг не всегда одинаково, м.б. и 2 и 3

Автор - Tallen
Дата добавления - 12.04.2021 в 12:51
Serge_007 Дата: Понедельник, 12.04.2021, 13:08 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 13959
Репутация: 2322 ±
Замечаний: ±

Excel 2010
Здравствуйте

Так надо (см. вложение)?
К сообщению приложен файл: 20210412_Tallen.xls(31.0 Kb)


Яндекс-деньги:41001419691823 | WMR:126292472390
 
Ответить
СообщениеЗдравствуйте

Так надо (см. вложение)?

Автор - Serge_007
Дата добавления - 12.04.2021 в 13:08
Tallen Дата: Понедельник, 12.04.2021, 13:19 | Сообщение № 3
Группа: Пользователи
Ранг: Участник
Сообщений: 63
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Serge_007, Здравствуйте! Нет, мне нужно чтобы в столбце D, там где я вручную посчитала, считалось формулами. Можно так? т.е.сложились Стоки между Итого во 2 и 10 строках - должно получиться 678,24 и т.д.
 
Ответить
СообщениеSerge_007, Здравствуйте! Нет, мне нужно чтобы в столбце D, там где я вручную посчитала, считалось формулами. Можно так? т.е.сложились Стоки между Итого во 2 и 10 строках - должно получиться 678,24 и т.д.

Автор - Tallen
Дата добавления - 12.04.2021 в 13:19
NikitaDvorets Дата: Понедельник, 12.04.2021, 14:14 | Сообщение № 4
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 106
Репутация: 179 ±
Замечаний: 0% ±

Excel 2019
Tallen, добрый день.
Сомнительный (?) вариант расчета без формул: добавляем в базу данных два столбца - "Итог" и "Группа услуг" и применяем сводную таблицу.
К сообщению приложен файл: ____12-04-2021.xlsx(28.1 Kb)
 
Ответить
СообщениеTallen, добрый день.
Сомнительный (?) вариант расчета без формул: добавляем в базу данных два столбца - "Итог" и "Группа услуг" и применяем сводную таблицу.

Автор - NikitaDvorets
Дата добавления - 12.04.2021 в 14:14
Tallen Дата: Понедельник, 12.04.2021, 14:32 | Сообщение № 5
Группа: Пользователи
Ранг: Участник
Сообщений: 63
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
NikitaDvorets, нее, так не пойдет. Мне не нужно складывать все стоки в столбце, нужно сложить их в промежутке между Итого, т.е. от строки 2 до строки 9 Стоки 678,24 ГВС 1051,1 ХВС 334,45
Потом в промежутке между строками 10-17 Стоки 773,82 ГВС 1166,05 ХВС 389,53
 
Ответить
СообщениеNikitaDvorets, нее, так не пойдет. Мне не нужно складывать все стоки в столбце, нужно сложить их в промежутке между Итого, т.е. от строки 2 до строки 9 Стоки 678,24 ГВС 1051,1 ХВС 334,45
Потом в промежутке между строками 10-17 Стоки 773,82 ГВС 1166,05 ХВС 389,53

Автор - Tallen
Дата добавления - 12.04.2021 в 14:32
Serge_007 Дата: Понедельник, 12.04.2021, 18:00 | Сообщение № 6
Группа: Админы
Ранг: Местный житель
Сообщений: 13959
Репутация: 2322 ±
Замечаний: ±

Excel 2010
См. вложение

По первому блоку так надо?
К сообщению приложен файл: 20210412_Tallen.xlsb(10.6 Kb)


Яндекс-деньги:41001419691823 | WMR:126292472390
 
Ответить
СообщениеСм. вложение

По первому блоку так надо?

Автор - Serge_007
Дата добавления - 12.04.2021 в 18:00
Tallen Дата: Понедельник, 12.04.2021, 18:37 | Сообщение № 7
Группа: Пользователи
Ранг: Участник
Сообщений: 63
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Serge_007, Да! Только Я похоже сама народ сбила с толку этим столбцом с ключевыми словами. Нужно чтобы значения проставлялись прямо в столбец D
 
Ответить
СообщениеSerge_007, Да! Только Я похоже сама народ сбила с толку этим столбцом с ключевыми словами. Нужно чтобы значения проставлялись прямо в столбец D

Автор - Tallen
Дата добавления - 12.04.2021 в 18:37
Pelena Дата: Понедельник, 12.04.2021, 21:36 | Сообщение № 8
Группа: Админы
Ранг: Местный житель
Сообщений: 17544
Репутация: 3906 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Вариант
Код
=ЕСЛИ(E2=E3;"";ЕСЛИ(B2="Итого к оплате";C2;СУММПРОИЗВ((ИНДЕКС($C$2:$C$35;ПРОСМОТР(0;-1/($B$2:B2="Итого к оплате");$A$2:A2)+1):ИНДЕКС($C3:$C$35;ЕСЛИОШИБКА(ПОИСКПОЗ("Итого к оплате";$B3:$B$35;0);ЧСТРОК($C3:$C$35))))*(ЛЕВСИМВ(B2;ПОИСК(" ";B2&" ")-1)=ИНДЕКС($E$2:$E$35;ПРОСМОТР(0;-1/($B$2:B2="Итого к оплате");$A$2:A2)+1):ИНДЕКС($E3:$E$35;ЕСЛИОШИБКА(ПОИСКПОЗ("Итого к оплате";$B3:$B$35;0);ЧСТРОК($E3:$E$35)))))))
К сообщению приложен файл: Tallen.xlsx(14.7 Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеВариант
Код
=ЕСЛИ(E2=E3;"";ЕСЛИ(B2="Итого к оплате";C2;СУММПРОИЗВ((ИНДЕКС($C$2:$C$35;ПРОСМОТР(0;-1/($B$2:B2="Итого к оплате");$A$2:A2)+1):ИНДЕКС($C3:$C$35;ЕСЛИОШИБКА(ПОИСКПОЗ("Итого к оплате";$B3:$B$35;0);ЧСТРОК($C3:$C$35))))*(ЛЕВСИМВ(B2;ПОИСК(" ";B2&" ")-1)=ИНДЕКС($E$2:$E$35;ПРОСМОТР(0;-1/($B$2:B2="Итого к оплате");$A$2:A2)+1):ИНДЕКС($E3:$E$35;ЕСЛИОШИБКА(ПОИСКПОЗ("Итого к оплате";$B3:$B$35;0);ЧСТРОК($E3:$E$35)))))))

Автор - Pelena
Дата добавления - 12.04.2021 в 21:36
Tallen Дата: Вторник, 13.04.2021, 06:15 | Сообщение № 9
Группа: Пользователи
Ранг: Участник
Сообщений: 63
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Pelena, Спасибо огромное! Это то, что нужно! :flower:
 
Ответить
СообщениеPelena, Спасибо огромное! Это то, что нужно! :flower:

Автор - Tallen
Дата добавления - 13.04.2021 в 06:15
Светлый Дата: Вторник, 13.04.2021, 11:27 | Сообщение № 10
Группа: Друзья
Ранг: Старожил
Сообщений: 1596
Репутация: 422 ±
Замечаний: 0% ±

Excel 2010, 2013
Воспользовался файликом Pelena. Добавил формулы в зелёных столбцах. Может быть, так будет удобнее.
Код
=ИНДЕКС(I$2:I$8;МИН(7;СТРОКА(B3)-МАКС((B$1:B2=B$2)*СТРОКА($1:2))))
Код
=СУММ(ЕЧИСЛО(ПОИСК(G2;ИНДЕКС(B:B;МАКС((B$1:B2=B$2)*СТРОКА($1:2))):ИНДЕКС(B:B;МИН(ЕСЛИ((B2:B$300=B$2)+(B2:B$300="");СТРОКА(2:$300))))))*ИНДЕКС(C:C;МАКС((B$1:B2=B$2)*СТРОКА($1:2))):ИНДЕКС(C:C;МИН(ЕСЛИ((B2:B$300=B$2)+(B2:B$300="");СТРОКА(2:$300)))))
массивная.
К сообщению приложен файл: Tallen-1.xlsx(17.3 Kb)


Программировать проще, чем писать стихи.
 
Ответить
СообщениеВоспользовался файликом Pelena. Добавил формулы в зелёных столбцах. Может быть, так будет удобнее.
Код
=ИНДЕКС(I$2:I$8;МИН(7;СТРОКА(B3)-МАКС((B$1:B2=B$2)*СТРОКА($1:2))))
Код
=СУММ(ЕЧИСЛО(ПОИСК(G2;ИНДЕКС(B:B;МАКС((B$1:B2=B$2)*СТРОКА($1:2))):ИНДЕКС(B:B;МИН(ЕСЛИ((B2:B$300=B$2)+(B2:B$300="");СТРОКА(2:$300))))))*ИНДЕКС(C:C;МАКС((B$1:B2=B$2)*СТРОКА($1:2))):ИНДЕКС(C:C;МИН(ЕСЛИ((B2:B$300=B$2)+(B2:B$300="");СТРОКА(2:$300)))))
массивная.

Автор - Светлый
Дата добавления - 13.04.2021 в 11:27
Tallen Дата: Вторник, 13.04.2021, 13:29 | Сообщение № 11
Группа: Пользователи
Ранг: Участник
Сообщений: 63
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Светлый, спасибо и Вам за неравнодушие. Если честно, то у Pelena именно то, что мне нужно. Из 1с вносятся данные в др систему (к сожалению пока никак не загружается автоматически, все ручками) и там есть подробно по каждой услуге суммы и отдельно Итого по группе этих услуг
 
Ответить
СообщениеСветлый, спасибо и Вам за неравнодушие. Если честно, то у Pelena именно то, что мне нужно. Из 1с вносятся данные в др систему (к сожалению пока никак не загружается автоматически, все ручками) и там есть подробно по каждой услуге суммы и отдельно Итого по группе этих услуг

Автор - Tallen
Дата добавления - 13.04.2021 в 13:29
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подсчет общей суммы по однотипным услугам, между строк ИТОГО (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования Jobsora jooble
© 2010-2021 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!