Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Написать условие соответствия значений одного столбца другом - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Написать условие соответствия значений одного столбца другом (Формулы/Formulas)
Написать условие соответствия значений одного столбца другом
Derriktor Дата: Четверг, 15.04.2021, 21:44 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Здравствуйте!
Нужна помощь.
Суть проблемы следующая:

У меня есть два столбца со значениями, левый столбец-текстовые значения(идут с пустыми строками), рядом подряд идут числовые значения (Скриншот1).
Мне нужно получить результат как на Скриншоте2 с помощью формул Excel (желательно одной).
То есть, нужно чтобы возраст соответствовал имени по порядку, с учетом, что есть пустые строки.
P.S.
Пробовал написать через индекс и поискпоз, пробовал логические формулы использовать, прихожу к одному результату, что присваиваю именам любые значения, но только не возраст с правой колонки.
Фильтром пользоваться нельзя. Только формулами.
Буду очень благодарен помощи!
К сообщению приложен файл: 6361236.png(3.3 Kb) · 2490540.png(3.5 Kb)
 
Ответить
СообщениеЗдравствуйте!
Нужна помощь.
Суть проблемы следующая:

У меня есть два столбца со значениями, левый столбец-текстовые значения(идут с пустыми строками), рядом подряд идут числовые значения (Скриншот1).
Мне нужно получить результат как на Скриншоте2 с помощью формул Excel (желательно одной).
То есть, нужно чтобы возраст соответствовал имени по порядку, с учетом, что есть пустые строки.
P.S.
Пробовал написать через индекс и поискпоз, пробовал логические формулы использовать, прихожу к одному результату, что присваиваю именам любые значения, но только не возраст с правой колонки.
Фильтром пользоваться нельзя. Только формулами.
Буду очень благодарен помощи!

Автор - Derriktor
Дата добавления - 15.04.2021 в 21:44
Pelena Дата: Четверг, 15.04.2021, 21:50 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 17499
Репутация: 3886 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Здравствуйте.
Формула для В2
Код
=ЕСЛИ(A2="";"";ИНДЕКС($C$2:$C$7;СЧЁТЗ($A$2:A2)))


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеЗдравствуйте.
Формула для В2
Код
=ЕСЛИ(A2="";"";ИНДЕКС($C$2:$C$7;СЧЁТЗ($A$2:A2)))

Автор - Pelena
Дата добавления - 15.04.2021 в 21:50
Derriktor Дата: Четверг, 15.04.2021, 21:53 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Pelena, Спасибо огромное! Очень выручили!
 
Ответить
СообщениеPelena, Спасибо огромное! Очень выручили!

Автор - Derriktor
Дата добавления - 15.04.2021 в 21:53
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Написать условие соответствия значений одного столбца другом (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования Jobsora jooble
© 2010-2021 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!