Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Доработка таблицы для расчёта стоимости проживания - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Доработка таблицы для расчёта стоимости проживания (Формулы/Formulas)
Доработка таблицы для расчёта стоимости проживания
seel2304 Дата: Понедельник, 19.04.2021, 18:08 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 20% ±

Создал файл, с 5 номерами. Цены отличаются в зависимости от номера и даты. Пока что всё работает, только если вручную прописывать количество дней в каждый из периодов проживания. А нужно так, чтобы можно было ввести дату заезда и дату отъезда, а количество в каждый из периодов вставилось самостоятельно (и уже дальше система сама производила расчёты). Я начал городить формулу из кучи ЕСЛИ в первом периоде первого номера, но запутался и не смог закончить. Помогите пожалуйста, если можете)
К сообщению приложен файл: 0836006.xlsx(13.3 Kb)
 
Ответить
СообщениеСоздал файл, с 5 номерами. Цены отличаются в зависимости от номера и даты. Пока что всё работает, только если вручную прописывать количество дней в каждый из периодов проживания. А нужно так, чтобы можно было ввести дату заезда и дату отъезда, а количество в каждый из периодов вставилось самостоятельно (и уже дальше система сама производила расчёты). Я начал городить формулу из кучи ЕСЛИ в первом периоде первого номера, но запутался и не смог закончить. Помогите пожалуйста, если можете)

Автор - seel2304
Дата добавления - 19.04.2021 в 18:08
Pelena Дата: Понедельник, 19.04.2021, 18:39 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 17625
Репутация: 3925 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
И Вам здравствуйте.
Если Вы разделите даты на два столбца, всё будет гораздо проще
Код
=ЕСЛИ(C$10>0;МАКС(МИН(C$11;$B14)-МАКС(C$10;$A14);0);0)
К сообщению приложен файл: 3547165.xlsx(13.5 Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеИ Вам здравствуйте.
Если Вы разделите даты на два столбца, всё будет гораздо проще
Код
=ЕСЛИ(C$10>0;МАКС(МИН(C$11;$B14)-МАКС(C$10;$A14);0);0)

Автор - Pelena
Дата добавления - 19.04.2021 в 18:39
seel2304 Дата: Понедельник, 19.04.2021, 19:30 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 20% ±

Код
=ЕСЛИ(C$10>0;МАКС(МИН(C$11;$B14)-МАКС(C$10;$A14);0);0)

Спасибо вам огромное!!! Не думал, что моя задача сможет решиться такой короткой формулой))


Сообщение отредактировал Serge_007 - Вторник, 20.04.2021, 09:03
 
Ответить
Сообщение
Код
=ЕСЛИ(C$10>0;МАКС(МИН(C$11;$B14)-МАКС(C$10;$A14);0);0)

Спасибо вам огромное!!! Не думал, что моя задача сможет решиться такой короткой формулой))

Автор - seel2304
Дата добавления - 19.04.2021 в 19:30
seel2304 Дата: Вторник, 20.04.2021, 08:51 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 20% ±

В результате тестирования обнаружил проблему. Когда даты в пределах одного месяца (или периода оплаты)- то всё окей. Но когда вписываешь даты, например, с 20.06 по 04.07, он должен просчитать 11 дней в первом периоде и 3 дня во втором. Но он считает как 10 дней в первом и 3 дня во втором, т.е. один день (на стыке месяцев) просто выпадает. Как это можно исправить?


Сообщение отредактировал Serge_007 - Вторник, 20.04.2021, 09:02
 
Ответить
СообщениеВ результате тестирования обнаружил проблему. Когда даты в пределах одного месяца (или периода оплаты)- то всё окей. Но когда вписываешь даты, например, с 20.06 по 04.07, он должен просчитать 11 дней в первом периоде и 3 дня во втором. Но он считает как 10 дней в первом и 3 дня во втором, т.е. один день (на стыке месяцев) просто выпадает. Как это можно исправить?

Автор - seel2304
Дата добавления - 20.04.2021 в 08:51
Pelena Дата: Вторник, 20.04.2021, 09:30 | Сообщение № 5
Группа: Админы
Ранг: Местный житель
Сообщений: 17625
Репутация: 3925 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
должен просчитать 11
Почему? Обычно ведь в гостиницах ночи считают. Нет? В июне 30 дней


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
Сообщение
должен просчитать 11
Почему? Обычно ведь в гостиницах ночи считают. Нет? В июне 30 дней

Автор - Pelena
Дата добавления - 20.04.2021 в 09:30
китин Дата: Вторник, 20.04.2021, 10:36 | Сообщение № 6
Группа: Модераторы
Ранг: Экселист
Сообщений: 6456
Репутация: 989 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
непонятно ваша логика. почему с 20.06 по 30.06 11 дней ( у вас) а с 01.07 по 04.07 3 дня? когда по вашей логике д.б. 4 дня?


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщениенепонятно ваша логика. почему с 20.06 по 30.06 11 дней ( у вас) а с 01.07 по 04.07 3 дня? когда по вашей логике д.б. 4 дня?

Автор - китин
Дата добавления - 20.04.2021 в 10:36
seel2304 Дата: Вторник, 20.04.2021, 11:01 | Сообщение № 7
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 20% ±

почему с 20.06 по 30.06 11 дней ( у вас) а с 01.07 по 04.07 3 дня?

Потому что сутки с 30го на 1е считаются по цене 30го (т.к. заезд 30го). Вот и выходит:
20-21 -1
21-22 -2
22-23 -3
23-24 -4
24-25 -5
25-26 -6
26-27 -7
27-28 -8
28-29 -9
29-30 -10
30-1 -11
ну а дальше второй период
1-2 -1
2-3 -2
3-4 -3
 
Ответить
Сообщение
почему с 20.06 по 30.06 11 дней ( у вас) а с 01.07 по 04.07 3 дня?

Потому что сутки с 30го на 1е считаются по цене 30го (т.к. заезд 30го). Вот и выходит:
20-21 -1
21-22 -2
22-23 -3
23-24 -4
24-25 -5
25-26 -6
26-27 -7
27-28 -8
28-29 -9
29-30 -10
30-1 -11
ну а дальше второй период
1-2 -1
2-3 -2
3-4 -3

Автор - seel2304
Дата добавления - 20.04.2021 в 11:01
seel2304 Дата: Вторник, 20.04.2021, 11:03 | Сообщение № 8
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 20% ±

Почему? Обычно ведь в гостиницах ночи считают.

Да, но ваш вариант таблицы не учитывает ночь с 30 на 1 (которая идёт по цене 30).
 
Ответить
Сообщение
Почему? Обычно ведь в гостиницах ночи считают.

Да, но ваш вариант таблицы не учитывает ночь с 30 на 1 (которая идёт по цене 30).

Автор - seel2304
Дата добавления - 20.04.2021 в 11:03
Pelena Дата: Вторник, 20.04.2021, 12:13 | Сообщение № 9
Группа: Админы
Ранг: Местный житель
Сообщений: 17625
Репутация: 3925 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Так проверьте
Код
=ЕСЛИ(C$10>0;МАКС(МИН(C$11;$B14+1)-МАКС(C$10;$A14);0);0)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеТак проверьте
Код
=ЕСЛИ(C$10>0;МАКС(МИН(C$11;$B14+1)-МАКС(C$10;$A14);0);0)

Автор - Pelena
Дата добавления - 20.04.2021 в 12:13
seel2304 Дата: Вторник, 20.04.2021, 15:34 | Сообщение № 10
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 20% ±

=ЕСЛИ(C$10>0;МАКС(МИН(C$11;$B14+1)-МАКС(C$10;$A14);0);0)

Проверяю, вроде пока что всё работает) Потом на практике ещё опробую, если вдруг что то будет не так - отпишусь) Спасибо вам огромное!)
 
Ответить
Сообщение
=ЕСЛИ(C$10>0;МАКС(МИН(C$11;$B14+1)-МАКС(C$10;$A14);0);0)

Проверяю, вроде пока что всё работает) Потом на практике ещё опробую, если вдруг что то будет не так - отпишусь) Спасибо вам огромное!)

Автор - seel2304
Дата добавления - 20.04.2021 в 15:34
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Доработка таблицы для расчёта стоимости проживания (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования Jobsora jooble
© 2010-2021 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!