Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Округление по двум значащим значениям - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Округление по двум значащим значениям (Формулы/Formulas)
Округление по двум значащим значениям
Версаль Дата: Вторник, 27.04.2021, 19:44 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Добрый день, коллеги.

Для обработки результата испытаний требуется округление по двум значащим цифрам после запятой, например:
0,00023654 округлить до 0,00024
0,01032 округлить до 0,01
0,0094362 округлить до 0,0094
1,2356 округлить до 1,24
и так далее...
Возможно ли это средствами эксель или нужен код?
 
Ответить
СообщениеДобрый день, коллеги.

Для обработки результата испытаний требуется округление по двум значащим цифрам после запятой, например:
0,00023654 округлить до 0,00024
0,01032 округлить до 0,01
0,0094362 округлить до 0,0094
1,2356 округлить до 1,24
и так далее...
Возможно ли это средствами эксель или нужен код?

Автор - Версаль
Дата добавления - 27.04.2021 в 19:44
Kostya_Ye Дата: Вторник, 27.04.2021, 20:39 | Сообщение № 2
Группа: Проверенные
Ранг: Обитатель
Сообщений: 258
Репутация: 226 ±
Замечаний: 0% ±

Excel 2016
Версаль, добрый день,
воспользуйтесь функцией
Код
=ОКРУГЛ()
 
Ответить
СообщениеВерсаль, добрый день,
воспользуйтесь функцией
Код
=ОКРУГЛ()

Автор - Kostya_Ye
Дата добавления - 27.04.2021 в 20:39
Светлый Дата: Среда, 28.04.2021, 06:31 | Сообщение № 3
Группа: Друзья
Ранг: Старожил
Сообщений: 1596
Репутация: 422 ±
Замечаний: 0% ±

Excel 2010, 2013
Добрый день!
Первое, что пришло в голову:
Код
=ОКРУГЛ(A1;АГРЕГАТ(15;6;ПОИСК(СТРОКА($1:$9);A1;ПОИСК(",";A1));1)-1)
*для чисел меньше 10.
**А это для любых:
Код
=ОКРУГЛ(A1;АГРЕГАТ(15;6;ПОИСК(СТРОКА($1:$9);A1;ПОИСК(",";A1));1)-ПОИСК(",";A1)+1)


Программировать проще, чем писать стихи.

Сообщение отредактировал Светлый - Среда, 28.04.2021, 06:37
 
Ответить
СообщениеДобрый день!
Первое, что пришло в голову:
Код
=ОКРУГЛ(A1;АГРЕГАТ(15;6;ПОИСК(СТРОКА($1:$9);A1;ПОИСК(",";A1));1)-1)
*для чисел меньше 10.
**А это для любых:
Код
=ОКРУГЛ(A1;АГРЕГАТ(15;6;ПОИСК(СТРОКА($1:$9);A1;ПОИСК(",";A1));1)-ПОИСК(",";A1)+1)

Автор - Светлый
Дата добавления - 28.04.2021 в 06:31
прохожий2019 Дата: Среда, 28.04.2021, 08:02 | Сообщение № 4
Группа: Проверенные
Ранг: Ветеран
Сообщений: 549
Репутация: 134 ±
Замечаний: 0% ±

365 Beta Channel
Код
=ОКРУГЛТ(A1;10^МИН(ОКРВВЕРХ(LOG10(A1);1)-2;-2))


Сообщение отредактировал прохожий2019 - Среда, 28.04.2021, 08:03
 
Ответить
Сообщение
Код
=ОКРУГЛТ(A1;10^МИН(ОКРВВЕРХ(LOG10(A1);1)-2;-2))

Автор - прохожий2019
Дата добавления - 28.04.2021 в 08:02
Светлый Дата: Среда, 28.04.2021, 10:25 | Сообщение № 5
Группа: Друзья
Ранг: Старожил
Сообщений: 1596
Репутация: 422 ±
Замечаний: 0% ±

Excel 2010, 2013
Версаль, а целая часть какая максимальная может быть?
Как округлить 1356,000123 ?


Программировать проще, чем писать стихи.
 
Ответить
СообщениеВерсаль, а целая часть какая максимальная может быть?
Как округлить 1356,000123 ?

Автор - Светлый
Дата добавления - 28.04.2021 в 10:25
ortan Дата: Среда, 28.04.2021, 10:54 | Сообщение № 6
Группа: Пользователи
Ранг: Новичок
Сообщений: 10
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Значимые цифры после запятой получаются - 1356,00012


Сообщение отредактировал Serge_007 - Среда, 28.04.2021, 11:03
 
Ответить
СообщениеЗначимые цифры после запятой получаются - 1356,00012

Автор - ortan
Дата добавления - 28.04.2021 в 10:54
прохожий2019 Дата: Среда, 28.04.2021, 18:25 | Сообщение № 7
Группа: Проверенные
Ранг: Ветеран
Сообщений: 549
Репутация: 134 ±
Замечаний: 0% ±

365 Beta Channel
ortan, как бы все нули после ненулевой цифры являются значащими, но это математика... подождем ответа ТС-а
 
Ответить
Сообщениеortan, как бы все нули после ненулевой цифры являются значащими, но это математика... подождем ответа ТС-а

Автор - прохожий2019
Дата добавления - 28.04.2021 в 18:25
Версаль Дата: Среда, 28.04.2021, 19:20 | Сообщение № 8
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Цитата Светлый, 28.04.2021 в 10:25, в сообщении № 5 ()
Версаль, а целая часть какая максимальная может быть?
Как округлить 1356,000123 ?


Да, все верно 1356,00012 должно быть
Цитата прохожий2019, 28.04.2021 в 18:25, в сообщении № 7 ()
ortan, как бы все нули после ненулевой цифры являются значащими, но это математика... подождем ответа ТС-а

прохожий2019, Ваше решение работает как надо, но только если его "запустить". Если менять значение в А1 то ничего не меняется, но если запустить формулу через интер, то работает, но только с 0,00. Если цифра 1356,000123, то округляет на одно значение, а не два
 
Ответить
Сообщение
Цитата Светлый, 28.04.2021 в 10:25, в сообщении № 5 ()
Версаль, а целая часть какая максимальная может быть?
Как округлить 1356,000123 ?


Да, все верно 1356,00012 должно быть
Цитата прохожий2019, 28.04.2021 в 18:25, в сообщении № 7 ()
ortan, как бы все нули после ненулевой цифры являются значащими, но это математика... подождем ответа ТС-а

прохожий2019, Ваше решение работает как надо, но только если его "запустить". Если менять значение в А1 то ничего не меняется, но если запустить формулу через интер, то работает, но только с 0,00. Если цифра 1356,000123, то округляет на одно значение, а не два

Автор - Версаль
Дата добавления - 28.04.2021 в 19:20
прохожий2019 Дата: Среда, 28.04.2021, 19:36 | Сообщение № 9
Группа: Проверенные
Ранг: Ветеран
Сообщений: 549
Репутация: 134 ±
Замечаний: 0% ±

365 Beta Channel
Цитата Версаль, 28.04.2021 в 19:20, в сообщении № 8 ()
1356,00012 должно быть
тогда
Код
=ОКРУГЛТ(A1;10^МИН(ОКРВВЕРХ(LOG10(ОСТАТ(A1;1));1)-2;-2))
Цитата Версаль, 28.04.2021 в 19:20, в сообщении № 8 ()
но только если его "запустить"
дело не в решении, проверьте ваши вычисления - похоже ручные стоят вместо автоматических
ну и тему тогда переназвать - округлить до двух ненулевых цифр после запятой - к значащим цифрам вопрос отношения не имеет
 
Ответить
Сообщение
Цитата Версаль, 28.04.2021 в 19:20, в сообщении № 8 ()
1356,00012 должно быть
тогда
Код
=ОКРУГЛТ(A1;10^МИН(ОКРВВЕРХ(LOG10(ОСТАТ(A1;1));1)-2;-2))
Цитата Версаль, 28.04.2021 в 19:20, в сообщении № 8 ()
но только если его "запустить"
дело не в решении, проверьте ваши вычисления - похоже ручные стоят вместо автоматических
ну и тему тогда переназвать - округлить до двух ненулевых цифр после запятой - к значащим цифрам вопрос отношения не имеет

Автор - прохожий2019
Дата добавления - 28.04.2021 в 19:36
Светлый Дата: Среда, 28.04.2021, 21:47 | Сообщение № 10
Группа: Друзья
Ранг: Старожил
Сообщений: 1596
Репутация: 422 ±
Замечаний: 0% ±

Excel 2010, 2013
А всё гораздо проще:
Код
=ОКРУГЛ(A1;2-ОТБР(LOG(ОСТАТ(A1;1))))
стоит только немного подумать.


Программировать проще, чем писать стихи.
 
Ответить
СообщениеА всё гораздо проще:
Код
=ОКРУГЛ(A1;2-ОТБР(LOG(ОСТАТ(A1;1))))
стоит только немного подумать.

Автор - Светлый
Дата добавления - 28.04.2021 в 21:47
прохожий2019 Дата: Среда, 28.04.2021, 21:56 | Сообщение № 11
Группа: Проверенные
Ранг: Ветеран
Сообщений: 549
Репутация: 134 ±
Замечаний: 0% ±

365 Beta Channel
Цитата Светлый, 28.04.2021 в 21:47, в сообщении № 10 ()
стоит только немного подумать
ну извините, видимо не всем дано
 
Ответить
Сообщение
Цитата Светлый, 28.04.2021 в 21:47, в сообщении № 10 ()
стоит только немного подумать
ну извините, видимо не всем дано

Автор - прохожий2019
Дата добавления - 28.04.2021 в 21:56
Светлый Дата: Среда, 28.04.2021, 23:50 | Сообщение № 12
Группа: Друзья
Ранг: Старожил
Сообщений: 1596
Репутация: 422 ±
Замечаний: 0% ±

Excel 2010, 2013
Цитата прохожий2019, 28.04.2021 в 21:56, в сообщении № 11 ()
ну извините, видимо не всем дано
Я только о себе. Какую я первую формулу наворочал и что сейчас получилось:
Код
=ОКРУГЛ(A1;2-LOG(ОСТАТ(A1;1)))


Программировать проще, чем писать стихи.
 
Ответить
Сообщение
Цитата прохожий2019, 28.04.2021 в 21:56, в сообщении № 11 ()
ну извините, видимо не всем дано
Я только о себе. Какую я первую формулу наворочал и что сейчас получилось:
Код
=ОКРУГЛ(A1;2-LOG(ОСТАТ(A1;1)))

Автор - Светлый
Дата добавления - 28.04.2021 в 23:50
прохожий2019 Дата: Четверг, 29.04.2021, 07:16 | Сообщение № 13
Группа: Проверенные
Ранг: Ветеран
Сообщений: 549
Репутация: 134 ±
Замечаний: 0% ±

365 Beta Channel
Да, такой МШ пропал....


Сообщение отредактировал прохожий2019 - Четверг, 29.04.2021, 07:19
 
Ответить
СообщениеДа, такой МШ пропал....

Автор - прохожий2019
Дата добавления - 29.04.2021 в 07:16
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Округление по двум значащим значениям (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования Jobsora jooble
© 2010-2021 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!