Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Выбор всех непустых значений из диапазона (строка) - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Выбор всех непустых значений из диапазона (строка) (Формулы/Formulas)
Выбор всех непустых значений из диапазона (строка)
ciokovalev Дата: Вторник, 04.05.2021, 01:55 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 0% ±

Добрый день
Есть таблица - 426 строк и часть таблицы - строка (порядка 500 столбцов), которая содержит данные только в некоторых из столбцов
Остальные - пустые. Данные - текст.
Нужно преобразовать эти данные так, чтобы остались только непустые столбцы (делаю преобразованную таблицу на соседнем листе).
Сделал такую формулу:
Код
=ИНДЕКС(Первичка!AP2:TL2;ПОИСКПОЗ(1;ИНДЕКС(1-ЕПУСТО(Первичка!AP2:TL2);1;0);0))

Она выводит только 1й непустой элемент AP2:TL2 - как раз строка с этими данными. А мне нужно вывести их все по очереди.

Заранее спасибо
 
Ответить
СообщениеДобрый день
Есть таблица - 426 строк и часть таблицы - строка (порядка 500 столбцов), которая содержит данные только в некоторых из столбцов
Остальные - пустые. Данные - текст.
Нужно преобразовать эти данные так, чтобы остались только непустые столбцы (делаю преобразованную таблицу на соседнем листе).
Сделал такую формулу:
Код
=ИНДЕКС(Первичка!AP2:TL2;ПОИСКПОЗ(1;ИНДЕКС(1-ЕПУСТО(Первичка!AP2:TL2);1;0);0))

Она выводит только 1й непустой элемент AP2:TL2 - как раз строка с этими данными. А мне нужно вывести их все по очереди.

Заранее спасибо

Автор - ciokovalev
Дата добавления - 04.05.2021 в 01:55
Serge_007 Дата: Вторник, 04.05.2021, 09:20 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 14156
Репутация: 2341 ±
Замечаний: ±

Excel 2010
Здравствуйте

В любую ячейку столбца А, формула массива:
Код
=ИНДЕКС(Первичка!$AP2:$TL2;НАИМЕНЬШИЙ(ЕСЛИ(Первичка!$AP2:$TL2<>"";СТОЛБЕЦ($A:$RW));СТОЛБЕЦ()))


Яндекс-деньги:41001419691823 | WMR:126292472390
 
Ответить
СообщениеЗдравствуйте

В любую ячейку столбца А, формула массива:
Код
=ИНДЕКС(Первичка!$AP2:$TL2;НАИМЕНЬШИЙ(ЕСЛИ(Первичка!$AP2:$TL2<>"";СТОЛБЕЦ($A:$RW));СТОЛБЕЦ()))

Автор - Serge_007
Дата добавления - 04.05.2021 в 09:20
ciokovalev Дата: Вторник, 04.05.2021, 11:31 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 0% ±

Не сработало - пишет Ошибка в значении
 
Ответить
СообщениеНе сработало - пишет Ошибка в значении

Автор - ciokovalev
Дата добавления - 04.05.2021 в 11:31
Serge_007 Дата: Вторник, 04.05.2021, 12:15 | Сообщение № 4
Группа: Админы
Ранг: Местный житель
Сообщений: 14156
Репутация: 2341 ±
Замечаний: ±

Excel 2010
Значит неправильно вводите
формулу массива


Яндекс-деньги:41001419691823 | WMR:126292472390
 
Ответить
СообщениеЗначит неправильно вводите
формулу массива

Автор - Serge_007
Дата добавления - 04.05.2021 в 12:15
ciokovalev Дата: Вторник, 04.05.2021, 14:08 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 0% ±

ок. Это я исправил и формула выдала первое непустое значение.
Но как получить остальные?
При копировании формулы в следующий столбец Эксель выдает значение "Неправильное число"
 
Ответить
Сообщениеок. Это я исправил и формула выдала первое непустое значение.
Но как получить остальные?
При копировании формулы в следующий столбец Эксель выдает значение "Неправильное число"

Автор - ciokovalev
Дата добавления - 04.05.2021 в 14:08
bigor Дата: Вторник, 04.05.2021, 14:16 | Сообщение № 6
Группа: Проверенные
Ранг: Обитатель
Сообщений: 439
Репутация: 83 ±
Замечаний: 0% ±

нет
как получить остальные?
приложите файл, и в нем покажите где на что Эксель ругается
 
Ответить
Сообщение
как получить остальные?
приложите файл, и в нем покажите где на что Эксель ругается

Автор - bigor
Дата добавления - 04.05.2021 в 14:16
ciokovalev Дата: Вторник, 04.05.2021, 14:58 | Сообщение № 7
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 0% ±

Прикладываю - Исходные данные на листе Первичка
ВЫчисление - на листе вычисление
В столбце К - вычисление по вашей формуле (корректное)
В столбцах L и М - копирование формулы и выдача ошибки экселем
К сообщению приложен файл: _____-.xls(105.5 Kb)
 
Ответить
СообщениеПрикладываю - Исходные данные на листе Первичка
ВЫчисление - на листе вычисление
В столбце К - вычисление по вашей формуле (корректное)
В столбцах L и М - копирование формулы и выдача ошибки экселем

Автор - ciokovalev
Дата добавления - 04.05.2021 в 14:58
Serge_007 Дата: Вторник, 04.05.2021, 15:18 | Сообщение № 8
Группа: Админы
Ранг: Местный житель
Сообщений: 14156
Репутация: 2341 ±
Замечаний: ±

Excel 2010
У меня всё работает (см. вложение)
К сообщению приложен файл: 20210504_ciokov.xlsb(82.1 Kb)


Яндекс-деньги:41001419691823 | WMR:126292472390
 
Ответить
СообщениеУ меня всё работает (см. вложение)

Автор - Serge_007
Дата добавления - 04.05.2021 в 15:18
ciokovalev Дата: Вторник, 04.05.2021, 16:53 | Сообщение № 9
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 0% ±

Я не понял - сейчас в нем прописан не тот диапазон, поэтому увидеть как оно работает не получается.
- я меняю в этом файле на нужный мне диапазон (AP2:TL2) - он выдает совсем не то
 
Ответить
СообщениеЯ не понял - сейчас в нем прописан не тот диапазон, поэтому увидеть как оно работает не получается.
- я меняю в этом файле на нужный мне диапазон (AP2:TL2) - он выдает совсем не то

Автор - ciokovalev
Дата добавления - 04.05.2021 в 16:53
Serge_007 Дата: Вторник, 04.05.2021, 17:02 | Сообщение № 10
Группа: Админы
Ранг: Местный житель
Сообщений: 14156
Репутация: 2341 ±
Замечаний: ±

Excel 2010
сейчас в нем прописан не тот диапазон, поэтому увидеть как оно работает не получается
Вы приложили файл формата .xls, в котором столбцов меньше, чем в .xlsb, поэтому мне пришлось уменьшить диапазон в формуле, что никак не влияет на понимание принципа её работы. Результат работы формулы тоже есть в файле

я меняю в этом файле на нужный мне диапазон (AP2:TL2) - он выдает совсем не то
Значит что-то неправильно делаете. Как Вы уже убедились - формула работает корректно


Яндекс-деньги:41001419691823 | WMR:126292472390
 
Ответить
Сообщение
сейчас в нем прописан не тот диапазон, поэтому увидеть как оно работает не получается
Вы приложили файл формата .xls, в котором столбцов меньше, чем в .xlsb, поэтому мне пришлось уменьшить диапазон в формуле, что никак не влияет на понимание принципа её работы. Результат работы формулы тоже есть в файле

я меняю в этом файле на нужный мне диапазон (AP2:TL2) - он выдает совсем не то
Значит что-то неправильно делаете. Как Вы уже убедились - формула работает корректно

Автор - Serge_007
Дата добавления - 04.05.2021 в 17:02
Pelena Дата: Вторник, 04.05.2021, 17:25 | Сообщение № 11
Группа: Админы
Ранг: Местный житель
Сообщений: 17624
Репутация: 3925 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
ciokovalev, формула для К4
Код
=ЕСЛИОШИБКА(ИНДЕКС(Первичка!$AP2:$TL2;НАИМЕНЬШИЙ(ЕСЛИ(Первичка!$AP2:$TL2<>"";СТОЛБЕЦ(Первичка!$AP2:$TL2)-41);СТОЛБЕЦ(A1)));"")


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
Сообщениеciokovalev, формула для К4
Код
=ЕСЛИОШИБКА(ИНДЕКС(Первичка!$AP2:$TL2;НАИМЕНЬШИЙ(ЕСЛИ(Первичка!$AP2:$TL2<>"";СТОЛБЕЦ(Первичка!$AP2:$TL2)-41);СТОЛБЕЦ(A1)));"")

Автор - Pelena
Дата добавления - 04.05.2021 в 17:25
ciokovalev Дата: Вторник, 04.05.2021, 19:18 | Сообщение № 12
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 0% ±

Все - разобрался - работает
Спасибо большое)))
 
Ответить
СообщениеВсе - разобрался - работает
Спасибо большое)))

Автор - ciokovalev
Дата добавления - 04.05.2021 в 19:18
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Выбор всех непустых значений из диапазона (строка) (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования Jobsora jooble
© 2010-2021 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!