Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Не вычисляет формула СУММЕСЛИМН - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Не вычисляет формула СУММЕСЛИМН (Формулы/Formulas)
Не вычисляет формула СУММЕСЛИМН
ПАМ Дата: Четверг, 06.05.2021, 15:29 | Сообщение № 1
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 210
Репутация: 11 ±
Замечаний: 0% ±

Excel 2010
Здравствуйте уважаемые форумчане! Помогите пожалуйста мне решить мою проблему:
У меня есть таблица в которую вставляются различные данные по интервалу времени. Хотелось вывести в определенное время цифру, на пересечении времени и даты, но Эксель пишет ЗНАЧ?. Пытался это действие сделать через
Код
=СУММЕСЛИМН(B4:Y34;A4:A34;AA4;B2:Y2;AB4)


Прошу Вас, объясните мне пожалуйста, что я делаю не так? Может есть альтернативные варианты?

Заранее очень благодарен.
К сообщению приложен файл: 0449519.xlsx(13.9 Kb)
 
Ответить
СообщениеЗдравствуйте уважаемые форумчане! Помогите пожалуйста мне решить мою проблему:
У меня есть таблица в которую вставляются различные данные по интервалу времени. Хотелось вывести в определенное время цифру, на пересечении времени и даты, но Эксель пишет ЗНАЧ?. Пытался это действие сделать через
Код
=СУММЕСЛИМН(B4:Y34;A4:A34;AA4;B2:Y2;AB4)


Прошу Вас, объясните мне пожалуйста, что я делаю не так? Может есть альтернативные варианты?

Заранее очень благодарен.

Автор - ПАМ
Дата добавления - 06.05.2021 в 15:29
Serge_007 Дата: Четверг, 06.05.2021, 15:52 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 14169
Репутация: 2344 ±
Замечаний: ±

Excel 2010
Здравствуйте

есть альтернативные варианты?
Код
=СУММПРОИЗВ(B$4:Y$34*(A$4:A$34=--AA4)*(B$2:Y$2=AB4))


Яндекс-деньги:41001419691823 | WMR:126292472390
 
Ответить
СообщениеЗдравствуйте

есть альтернативные варианты?
Код
=СУММПРОИЗВ(B$4:Y$34*(A$4:A$34=--AA4)*(B$2:Y$2=AB4))

Автор - Serge_007
Дата добавления - 06.05.2021 в 15:52
bigor Дата: Четверг, 06.05.2021, 15:58 | Сообщение № 3
Группа: Проверенные
Ранг: Обитатель
Сообщений: 441
Репутация: 85 ±
Замечаний: 0% ±

нет
Если просто пересечение, то лучше наверно через ИНДЕКС()
Код
=INDEX($B$4:$Y$34;MATCH(AA4;$A$4:$A$34;0);MATCH(AB4;$B$2:$Y$2;0))
 
Ответить
СообщениеЕсли просто пересечение, то лучше наверно через ИНДЕКС()
Код
=INDEX($B$4:$Y$34;MATCH(AA4;$A$4:$A$34;0);MATCH(AB4;$B$2:$Y$2;0))

Автор - bigor
Дата добавления - 06.05.2021 в 15:58
Serge_007 Дата: Четверг, 06.05.2021, 16:02 | Сообщение № 4
Группа: Админы
Ранг: Местный житель
Сообщений: 14169
Репутация: 2344 ±
Замечаний: ±

Excel 2010
лучше наверно через ИНДЕКС()
Безусловно! ИНДЕКС не такая "тяжелая", как СУММПРОИЗВ
Но так ещё лучше и короче:
Код
=ГПР(AB4;B$2:Y$34;ПОИСКПОЗ(AA4+0;A$2:A$34;);)
:D


Яндекс-деньги:41001419691823 | WMR:126292472390
 
Ответить
Сообщение
лучше наверно через ИНДЕКС()
Безусловно! ИНДЕКС не такая "тяжелая", как СУММПРОИЗВ
Но так ещё лучше и короче:
Код
=ГПР(AB4;B$2:Y$34;ПОИСКПОЗ(AA4+0;A$2:A$34;);)
:D

Автор - Serge_007
Дата добавления - 06.05.2021 в 16:02
ПАМ Дата: Четверг, 06.05.2021, 17:08 | Сообщение № 5
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 210
Репутация: 11 ±
Замечаний: 0% ±

Excel 2010
Serge_007, bigor, Огромное СПАСИБО!!! hands hands hands Все работает! Хотел поставить плюсы, но почему-то окно репутации у меня не открывается :(


Сообщение отредактировал ПАМ - Четверг, 06.05.2021, 17:09
 
Ответить
СообщениеSerge_007, bigor, Огромное СПАСИБО!!! hands hands hands Все работает! Хотел поставить плюсы, но почему-то окно репутации у меня не открывается :(

Автор - ПАМ
Дата добавления - 06.05.2021 в 17:08
Serge_007 Дата: Четверг, 06.05.2021, 17:29 | Сообщение № 6
Группа: Админы
Ранг: Местный житель
Сообщений: 14169
Репутация: 2344 ±
Замечаний: ±

Excel 2010
окно репутации у меня не открывается
Плюсы можно ставить двумя способами :)


Яндекс-деньги:41001419691823 | WMR:126292472390
 
Ответить
Сообщение
окно репутации у меня не открывается
Плюсы можно ставить двумя способами :)

Автор - Serge_007
Дата добавления - 06.05.2021 в 17:29
bmv98rus Дата: Четверг, 06.05.2021, 18:34 | Сообщение № 7
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3496
Репутация: 616 ±
Замечаний: 0% ±

Excel 2013/2016
Но так ещё лучше и короче:

не верю :D
Код
=INDEX($B$4:$Y$34;DAY(AA4);AB4)


Код
=INDEX(B$4:Y$34;DAY(AA4);AB4)


Замечательный Временно просто медведь , процентов на 20.

Сообщение отредактировал bmv98rus - Пятница, 07.05.2021, 09:18
 
Ответить
Сообщение
Но так ещё лучше и короче:

не верю :D
Код
=INDEX($B$4:$Y$34;DAY(AA4);AB4)


Код
=INDEX(B$4:Y$34;DAY(AA4);AB4)

Автор - bmv98rus
Дата добавления - 06.05.2021 в 18:34
Serge_007 Дата: Пятница, 07.05.2021, 09:09 | Сообщение № 8
Группа: Админы
Ранг: Местный житель
Сообщений: 14169
Репутация: 2344 ±
Замечаний: ±

Excel 2010
В формуле 2 лишних знака ;)

не верю
И правильно делаешь :D
Код
=ВПР(--AA4;A$4:Y$34;AB4+1;)


Яндекс-деньги:41001419691823 | WMR:126292472390
 
Ответить
СообщениеВ формуле 2 лишних знака ;)

не верю
И правильно делаешь :D
Код
=ВПР(--AA4;A$4:Y$34;AB4+1;)

Автор - Serge_007
Дата добавления - 07.05.2021 в 09:09
bmv98rus Дата: Пятница, 07.05.2021, 09:31 | Сообщение № 9
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3496
Репутация: 616 ±
Замечаний: 0% ±

Excel 2013/2016
прикол в другом, быстрее всего и так как поиск почти не нужен при таких данных
Код
=INDEX(B$4:Y$34;LEFT(AA4;2);AB4)


на 100000 расчетов
=INDEX(B$4:Y$34,DAY(AA4),AB4) 2,929688
=VLOOKUP(--AA4,A$4:Y$34,AB4+1) 2,878906
=INDEX(B$4:Y$34,LEFT(AA4,2),AB4) 2,535156


Замечательный Временно просто медведь , процентов на 20.
 
Ответить
Сообщениеприкол в другом, быстрее всего и так как поиск почти не нужен при таких данных
Код
=INDEX(B$4:Y$34;LEFT(AA4;2);AB4)


на 100000 расчетов
=INDEX(B$4:Y$34,DAY(AA4),AB4) 2,929688
=VLOOKUP(--AA4,A$4:Y$34,AB4+1) 2,878906
=INDEX(B$4:Y$34,LEFT(AA4,2),AB4) 2,535156

Автор - bmv98rus
Дата добавления - 07.05.2021 в 09:31
Serge_007 Дата: Пятница, 07.05.2021, 09:51 | Сообщение № 10
Группа: Админы
Ранг: Местный житель
Сообщений: 14169
Репутация: 2344 ±
Замечаний: ±

Excel 2010
=INDEX(B$4:Y$34,LEFT(AA4,2),AB4) 2,535156
И это при наличии текстовой функции!


Яндекс-деньги:41001419691823 | WMR:126292472390
 
Ответить
Сообщение
=INDEX(B$4:Y$34,LEFT(AA4,2),AB4) 2,535156
И это при наличии текстовой функции!

Автор - Serge_007
Дата добавления - 07.05.2021 в 09:51
bmv98rus Дата: Пятница, 07.05.2021, 10:05 | Сообщение № 11
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3496
Репутация: 616 ±
Замечаний: 0% ±

Excel 2013/2016
Serge_007, да, видимо DAY более тяжкая.


Замечательный Временно просто медведь , процентов на 20.
 
Ответить
СообщениеSerge_007, да, видимо DAY более тяжкая.

Автор - bmv98rus
Дата добавления - 07.05.2021 в 10:05
Serge_007 Дата: Пятница, 07.05.2021, 10:43 | Сообщение № 12
Группа: Админы
Ранг: Местный житель
Сообщений: 14169
Репутация: 2344 ±
Замечаний: ±

Excel 2010
DAY более тяжкая
И я даже догадываюсь почему


Яндекс-деньги:41001419691823 | WMR:126292472390
 
Ответить
Сообщение
DAY более тяжкая
И я даже догадываюсь почему

Автор - Serge_007
Дата добавления - 07.05.2021 в 10:43
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Не вычисляет формула СУММЕСЛИМН (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования Jobsora jooble
© 2010-2021 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!