Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/сравнение дат в excel - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » сравнение дат в excel (Формулы/Formulas)
сравнение дат в excel
artaimenimes Дата: Суббота, 08.05.2021, 23:14 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Друзья, доброго времени суток! Помогите разобраться. Имеется таблица, куда постепенно будут вноситься даты, нужно сделать контроль дать, чтобы в верхней ячейки дата была более ранняя чем в нижней, если все заполнено правильно, то выводиться "ok", если даты в ячейках ниже более ранние, то выводится ошибка. Что-то вроде такой формулы :
Код
=ЕСЛИ(И(C4<C5:C105;C5<C6:C105);"OK" ;"Ошибка")
. Проблема в том, что при сравнение учитываются пустые ячейки и всегда выходит ошибка. Вопрос, как не учитывать пустые ячейки или использовать другую формулу?
Заранее извиняюсь за сумбур, надеюсь получилось донести суть. Файл прилогается.
К сообщению приложен файл: test.xlsx(11.5 Kb)
 
Ответить
СообщениеДрузья, доброго времени суток! Помогите разобраться. Имеется таблица, куда постепенно будут вноситься даты, нужно сделать контроль дать, чтобы в верхней ячейки дата была более ранняя чем в нижней, если все заполнено правильно, то выводиться "ok", если даты в ячейках ниже более ранние, то выводится ошибка. Что-то вроде такой формулы :
Код
=ЕСЛИ(И(C4<C5:C105;C5<C6:C105);"OK" ;"Ошибка")
. Проблема в том, что при сравнение учитываются пустые ячейки и всегда выходит ошибка. Вопрос, как не учитывать пустые ячейки или использовать другую формулу?
Заранее извиняюсь за сумбур, надеюсь получилось донести суть. Файл прилогается.

Автор - artaimenimes
Дата добавления - 08.05.2021 в 23:14
Egyptian Дата: Суббота, 08.05.2021, 23:52 | Сообщение № 2
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 134
Репутация: 47 ±
Замечаний: 0% ±

Excel 2013/2016
Попробуйте так:
Код
=IF((C4<C5:C105)*(C5<C6:C105)*(C4:C105>0);"OK";"Ошибка")

Вводите тремя клавишами CTRL+SHIFT+ENTER
 
Ответить
СообщениеПопробуйте так:
Код
=IF((C4<C5:C105)*(C5<C6:C105)*(C4:C105>0);"OK";"Ошибка")

Вводите тремя клавишами CTRL+SHIFT+ENTER

Автор - Egyptian
Дата добавления - 08.05.2021 в 23:52
artaimenimes Дата: Воскресенье, 09.05.2021, 00:39 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Код
=ЕСЛИ((C4<C5:C105)*(C5<C6:C105)*(C4:C105>0);"OK";"Ошибка")


не совсем понимаю, как мне поможет формула массива, все та же ошибка, если ячейки пусты.

Вопрос, как мне заставить Excel не учитывать пустые ячейки при сравнении?


Сообщение отредактировал artaimenimes - Воскресенье, 09.05.2021, 00:45
 
Ответить
Сообщение
Код
=ЕСЛИ((C4<C5:C105)*(C5<C6:C105)*(C4:C105>0);"OK";"Ошибка")


не совсем понимаю, как мне поможет формула массива, все та же ошибка, если ячейки пусты.

Вопрос, как мне заставить Excel не учитывать пустые ячейки при сравнении?

Автор - artaimenimes
Дата добавления - 09.05.2021 в 00:39
прохожий2019 Дата: Воскресенье, 09.05.2021, 01:08 | Сообщение № 4
Группа: Проверенные
Ранг: Ветеран
Сообщений: 616
Репутация: 142 ±
Замечаний: 0% ±

365 Beta Channel
Код
=ЕСЛИ(И(ЕСЛИ(ЕЧИСЛО(C5:C105);C5:C105>C4:C104;""));"ОК";"Ошибка")


да еще и кросс
К сообщению приложен файл: 2363539.xlsx(11.4 Kb)


Сообщение отредактировал прохожий2019 - Воскресенье, 09.05.2021, 23:24
 
Ответить
Сообщение
Код
=ЕСЛИ(И(ЕСЛИ(ЕЧИСЛО(C5:C105);C5:C105>C4:C104;""));"ОК";"Ошибка")


да еще и кросс

Автор - прохожий2019
Дата добавления - 09.05.2021 в 01:08
artaimenimes Дата: Понедельник, 10.05.2021, 23:01 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Товарищи, всем спасибо за помощь
 
Ответить
СообщениеТоварищи, всем спасибо за помощь

Автор - artaimenimes
Дата добавления - 10.05.2021 в 23:01
Nic70y Дата: Вторник, 11.05.2021, 17:23 | Сообщение № 6
Группа: Друзья
Ранг: Экселист
Сообщений: 6932
Репутация: 1599 ±
Замечаний: 0% ±

Excel 2010
так смешнее
Код
=ЕСЛИ(ЕНД(ПРОСМОТР("-";ЛЕВБ(C5:C105-C4:C104)));"OK";"Ошибка")
без массивного ввода


ЮMoney(Яндекс Деньги) 41001841029809
 
Ответить
Сообщениетак смешнее
Код
=ЕСЛИ(ЕНД(ПРОСМОТР("-";ЛЕВБ(C5:C105-C4:C104)));"OK";"Ошибка")
без массивного ввода

Автор - Nic70y
Дата добавления - 11.05.2021 в 17:23
Юрий_Ф Дата: Среда, 12.05.2021, 19:31 | Сообщение № 7
Группа: Проверенные
Ранг: Обитатель
Сообщений: 328
Репутация: -5 ±
Замечаний: 20% ±

Excel 2010
Nic70y
Поэксперементировал с вашими формулами.
Если выставить:
04.01.21
27.02.21
31.01.21
26.02.21
28.02.21
Пишет ОК и ОК! (А должна быть - ОШИБКА и ОШИБКА).

Если переместить в таком порядке:
04.01.21
27.02.21
26.02.21
31.01.21
28.02.21
То пишет ОШИБКА и ОШИБКА!


То, что мы делаем, завораживает!
Кстати! Я не могу всем нравиться! И это взаимно!
 
Ответить
СообщениеNic70y
Поэксперементировал с вашими формулами.
Если выставить:
04.01.21
27.02.21
31.01.21
26.02.21
28.02.21
Пишет ОК и ОК! (А должна быть - ОШИБКА и ОШИБКА).

Если переместить в таком порядке:
04.01.21
27.02.21
26.02.21
31.01.21
28.02.21
То пишет ОШИБКА и ОШИБКА!

Автор - Юрий_Ф
Дата добавления - 12.05.2021 в 19:31
artaimenimes Дата: Среда, 12.05.2021, 20:10 | Сообщение № 8
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Мне подсказали другую формулу:
Код
=ЕСЛИ(СУММПРОИЗВ(--($C$4:ИНДЕКС($C:$C;@ПС-1)>$C$5:ИНДЕКС($C:$C;@ПС)));"ОШИБКА!!!";"")


и еще интересное решение с условным форматированием
К сообщению приложен файл: test-1-.xlsx(10.5 Kb)


Сообщение отредактировал Serge_007 - Четверг, 13.05.2021, 09:03
 
Ответить
СообщениеМне подсказали другую формулу:
Код
=ЕСЛИ(СУММПРОИЗВ(--($C$4:ИНДЕКС($C:$C;@ПС-1)>$C$5:ИНДЕКС($C:$C;@ПС)));"ОШИБКА!!!";"")


и еще интересное решение с условным форматированием

Автор - artaimenimes
Дата добавления - 12.05.2021 в 20:10
Мир MS Excel » Вопросы и решения » Вопросы по Excel » сравнение дат в excel (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования Jobsora jooble
© 2010-2021 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!